Hello,
This should have the changes you wanted!
Thank you,
Matthew Beliveau
On Fri, Aug 16, 2019 at 12:30 PM Jeff Law wrote:
>
> On 8/13/19 9:09 AM, Matthew Beliveau wrote:
> > Hello,
> >
> > This should have the changes you all asked for! Let me know if I
> >
Hello,
This should have the changes you all asked for! Let me know if I
missed anything!
Thank you,
Matthew Beliveau
On Tue, Aug 13, 2019 at 5:15 AM Richard Biener
wrote:
>
> On Tue, Aug 13, 2019 at 10:18 AM Richard Sandiford
> wrote:
> >
> > Thanks for doing this.
>
This patch improves DSE to handle missing optimizations for zero
initializations.
Thank you,
Matthew Beliveau
Bootstrapped/regtested on x86_64-linux, ok for trunk?
2019-08-12 Matthew Beliveau
PR c++/DSE.patch
* tree-ssa-dse.c (dse_optimize_redundant_stores): Improved check to
catch more
ping
On Tue, Jul 23, 2019 at 10:27 AM Matthew Beliveau wrote:
>
> ping
>
> On Tue, Jul 16, 2019 at 8:40 AM Marek Polacek wrote:
> >
> > On Mon, Jul 15, 2019 at 09:47:26AM -0400, Matthew Beliveau wrote:
> > > Okay I kept the TYPE_MAIN_VARIANT and dropped the acc
ping
On Tue, Jul 16, 2019 at 8:40 AM Marek Polacek wrote:
>
> On Mon, Jul 15, 2019 at 09:47:26AM -0400, Matthew Beliveau wrote:
> > Okay I kept the TYPE_MAIN_VARIANT and dropped the accidental new line!
> > Hopefully this should be fine!
>
> CCing Joseph as
Tested on GCC 8 and 9.
Bootstrapped/regtested on x86_64-linux, ok for trunk?
2019-07-23 Matthew Beliveau
Backported from mainline
2019-07-16 Jeff Law
PR rtl-optimization/91173
* tree-ssa-address.c (addr_for_mem_ref): If the base is an
SSA_NAME with a constant value, fold its value
Okay I kept the TYPE_MAIN_VARIANT and dropped the accidental new line!
Hopefully this should be fine!
On Fri, Jul 12, 2019 at 6:49 PM Marek Polacek wrote:
>
> On Fri, Jul 12, 2019 at 02:38:59PM -0400, Marek Polacek wrote:
> > On Fri, Jul 12, 2019 at 02:34:37PM -0400, Matthew Be
Hi,
This should fix the concerns you had! Now the function only gets the
location from the type, and then only look for the name if the type's
location is in the header.
On Tue, Jul 9, 2019 at 5:21 PM Jason Merrill wrote:
>
> On 7/9/19 11:18 AM, Matthew Beliveau wrote:
> > This
This patch suppresses the warning: "enumeration value not handled in
switch", for enumerators that are defined in system headers and use
reserved names.
Bootstrapped/regtested on x86_64-linux, ok for trunk?
2019-07-08 Matthew Beliveau
PR c++/90590
* c-warn.c (c_do_switc
Sorry, the last version had some problems.
On Thu, Jun 20, 2019 at 4:26 PM Matthew Beliveau wrote:
>
> Hopefully fixed!
>
> On Thu, Jun 20, 2019 at 2:42 PM Marek Polacek wrote:
> >
> > On Thu, Jun 20, 2019 at 09:33:18AM -0400, Matthew Beliveau wrote:
> > > Sor
Hopefully fixed!
On Thu, Jun 20, 2019 at 2:42 PM Marek Polacek wrote:
>
> On Thu, Jun 20, 2019 at 09:33:18AM -0400, Matthew Beliveau wrote:
> > Sorry for the last update, I guess I didn't notice the other changes, oops!
> >
> > This should have all the changes. Let m
Sorry for the last update, I guess I didn't notice the other changes, oops!
This should have all the changes. Let me know if anything went wrong!
Thanks,
Matthew Beliveau
On Tue, Jun 18, 2019 at 1:38 PM Marek Polacek wrote:
>
> On Tue, Jun 18, 2019 at 01:17:10PM -0400, Matthew Bel
Hello,
This patch should change the formatting, and move the test files into
the appropriate directory!
Thank you
On Mon, Jun 17, 2019 at 1:45 PM Marek Polacek wrote:
>
> Thanks for the patch.
>
> On Mon, Jun 17, 2019 at 01:26:37PM -0400, Matthew Beliveau wrote:
> > ---
This patch adds a new warning option: Wswitch-outside-range, so that
users are able to selectively control the warning. The warning is
enabled by default.
Best,
Matthew Beliveau
Bootstrapped/regtested on x86_64-linux, ok for trunk?
2019-06-14 Matthew Beliveau
PR c++/90875 - added -Wswitch
Oops! Sorry about that, should be fixed now!
On Tue, Jun 11, 2019 at 3:32 PM Rainer Orth
wrote:
>
> Matthew Beliveau writes:
>
> > ChangeLog:
> >
> > 2019-06-11 Matthew Beliveau
>
>
> I don't
ChangeLog:
2019-06-11 Matthew Beliveau
* MAINTAINERS: Add myself.
--- MAINTAINERS (revision 272167)
+++ MAINTAINERS (working copy)
@@ -316,6 +316,7 @@
Gergö Barany
Charles Baylis
Tejas Belagod
+Matthew Beliveau
Jon Beniston
Andrew Bennett
Andrew Benson
k you,
Matthew Beliveau
On Tue, Jun 11, 2019 at 12:43 AM Jason Merrill wrote:
>
> On 6/10/19 12:02 PM, Matthew Beliveau wrote:
> > if (!uniquely_derived_from_p (basetype, t))
> > - warning (OPT_Wextra, "virtual base %qT inaccessible in %qT due "
> &
est in my build directory and received 4 passes and 1
unsupported test, which was expected.
Bootstrapped/regtested on x86_64-linux, ok for trunk?
2019-06-10 Matthew Beliveau
PR c++/87250
* g++.dg/cpp0x/pr87250.C: New test.
diff --git gcc/testsuite/g++.dg/cpp0x/pr87250.C gcc/testsuite/g++.dg/cpp0
Hello,
i changed the doc/invoke.texi like you suggested. Let me know If I
missed anything!
Thank you,
Matthew Beliveau
On Mon, Jun 10, 2019 at 11:39 AM Martin Sebor wrote:
>
> On 6/7/19 2:10 PM, Matthew Beliveau wrote:
> > This patch adds a new warning option: Winaccessible-b
Hello,
I've changed the name of warn_about_ambiguous_bases to
maybe_warn_about_inaccessible_bases.
I've attached the new patch below.
Best,
Matthew Beliveau
On Fri, Jun 7, 2019 at 4:42 PM Paolo Carlini wrote:
>
> Hi,
>
> On 07/06/19 22:31, Marek Polacek wrote:
> >
06-07 Matthew Beliveau
PR c++/90449 - add -Winaccessible-base option.
* doc/invoke.texi (Winaccessible-base): Document.
* c.opt (Winaccessible-base): Added new option.
* class.c (warn_about_ambiguous_bases): Implemented new
Winaccessible-base warning option for
21 matches
Mail list logo