Re: [PATCH] libgcc: PR target/116363 Fix SFtype to UDWtype conversion

2025-02-22 Thread Jeff Law
On 2/22/25 8:10 AM, Jan Dubiec wrote: This patch fixes SFtype to UDWtype (aka float to unsigned long long) conversion on targets without DFmode like e.g. H8/300H. It solely relies on SFtype->UWtype and UWtype->UDWtype conversions/casts. The existing code in line 2218 (counter = a) assigns/cast

[PATCH v1] RISC-V: Fix bug for expand_const_vector interleave [PR118931]

2025-02-22 Thread pan2 . li
From: Pan Li This patch would like to fix one bug when expanding const vector for the interleave case. For example, we have: base1 = 151 step = 121 For vec_series, we will generate vector in format of v[i] = base + i * step. Then the vec_series will have below result for HImode, and we can fin

[committed] libstdc++: Fix bootstrap failure with --enable-vtable-verify [PR118981]

2025-02-22 Thread Jonathan Wakely
The compiler emits code with init_priority(99) for -fvtable-verify=std and that creates a section conflict with the uses of init_priority(99) that I recently added to src/c++20/tzdb.cc. Change tzdb.cc to use a different priority to avoid the conflict. libstdc++-v3/ChangeLog: PR c++/11898

Gracefully handle the case that 'gcc/testsuite/lib/gcc-dg.exp:find-dg-do-what' has not been called (indirectly) from 'dg-test' (was: Refactor duplicated code into 'gcc/testsuite/lib/gcc-dg.exp:find-dg

2025-02-22 Thread Thomas Schwinge
Hi! On 2025-02-22T22:51:36+0100, I wrote: > On 2025-02-22T22:49:47+0100, I wrote: >> Pushed to trunk branch commit f553b1aaa2b1b925c918e5dcf966290b045321c2 >> "Refactor duplicated code into >> 'gcc/testsuite/lib/gcc-dg.exp:find-dg-do-what'", >> [...] > --- a/gcc/testsuite/lib/gcc-dg.exp > +++ b/

Refactor duplicated code into 'gcc/testsuite/lib/gcc-dg.exp:find-dg-do-what' (was: nvptx: PTX 'alloca' for '-mptx=7.3'+, '-march=sm_52'+ [PR65181])

2025-02-22 Thread Thomas Schwinge
Hi! On 2025-02-22T22:49:47+0100, I wrote: > On 2025-01-09T14:21:18+0100, I wrote: >> Pushed to trunk branch commit 3861d362ec7e3c50742fc43833fe9d8674f4070e >> "nvptx: PTX 'alloca' for '-mptx=7.3'+, '-march=sm_52'+ [PR65181]", >> [...] > >> --- a/gcc/testsuite/lib/target-supports.exp >> +++ b/gcc/t

Refactor duplicated code into 'gcc/testsuite/lib/gcc-dg.exp:find-dg-do-what' (was: nvptx: PTX 'alloca' for '-mptx=7.3'+, '-march=sm_52'+ [PR65181])

2025-02-22 Thread Thomas Schwinge
Hi! On 2025-01-09T14:21:18+0100, I wrote: > Pushed to trunk branch commit 3861d362ec7e3c50742fc43833fe9d8674f4070e > "nvptx: PTX 'alloca' for '-mptx=7.3'+, '-march=sm_52'+ [PR65181]", > [...] > --- a/gcc/testsuite/lib/target-supports.exp > +++ b/gcc/testsuite/lib/target-supports.exp > @@ -1009,9

libgomp: Add '__attribute__((unused))' to variables used only in 'assert(...)' (was: [PATCH] libgomp: avoid unused-variable-error when configured with CFLAGS=-DNDEBUG)

2025-02-22 Thread Thomas Schwinge
Hi! On 2025-02-17T16:40:05+, "shynur ." wrote: >> As part of the Git commit message, please include a ChangeLog update (see >> and 'git log'). > > I've written a new patch which is attached. Pushed to trunk branch commit e759ff08e2e2e71

[committed] libstdc++: Remove redundant cast in floating_from_chars.cc

2025-02-22 Thread Jonathan Wakely
In r15-7647-g32457bc25fea80 I added a cast and also changed the type of the variable, making the cast redundant. This removes the cast. libstdc++-v3/ChangeLog: * src/c++17/floating_from_chars.cc (__floating_from_chars_hex): Remove redundant cast. --- Tested x86_64-linux. Pushed t

[committed] libstdc++: Remove misleading comment in __atomic_base

2025-02-22 Thread Jonathan Wakely
No conversion is needed because the type of _M_i is __int_type anyway. libstdc++-v3/ChangeLog: * include/bits/atomic_base.h (__atomic_base<_ITp>): Remove misleading comment. --- Tested x86_64-linux. Pushed to trunk. libstdc++-v3/include/bits/atomic_base.h | 1 - 1 file changed,

How to retrieve the CCVS/85 User Guide

2025-02-22 Thread James K. Lowden
On Fri, 21 Feb 2025 19:59:25 +0100 Florian Weimer wrote: > * James K. Lowden: > > > As I mentioned in other posts, IMO (IANAL) the copyright in > > unimportant and probably unenforceable. The National Computing > > Centre no longer exists, and the document was also published by NIST > > which,

[committed, obvious] OpenMP: Silence uninitialized variable warning in C++ front end.

2025-02-22 Thread Sandra Loosemore
There's no actual problem with the code here, just a false-positive warning emitted by some older GCC versions. gcc/cp/ChangeLog * parser.cc (cp_finish_omp_declare_variant): Initialize append_args_last. --- gcc/cp/parser.cc | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) di

Re: [Fortran, Patch, PR107635, 4_v1] Fix class type and descriptor handling for new coarray interface [PR107635]

2025-02-22 Thread Andre Vehreschild
Hi Harald, thanks for the review. Silently I'd hoped that there is some macro to get the i-th argument, that I just haven't found and someone could point me to. I will add a comment, when ko one comes up with the macro by Monday. Thanks, Andre Andre Vehreschild * ve...@gmx.de Am 22. Februar 2025

[PATCH] libgcc: PR target/116363 Fix SFtype to UDWtype conversion

2025-02-22 Thread Jan Dubiec
This patch fixes SFtype to UDWtype (aka float to unsigned long long) conversion on targets without DFmode like e.g. H8/300H. It solely relies on SFtype->UWtype and UWtype->UDWtype conversions/casts. The existing code in line 2218 (counter = a) assigns/casts a float which is *always* not lesser tha

Re: [PATCH 1/2] Add TARGET_COMPUTE_MULTILIB_OS hook to override multi-lib-os result.

2025-02-22 Thread Jeff Law
On 2/22/25 7:31 AM, Palmer Dabbelt wrote: On Sat, 22 Feb 2025 02:19:03 PST (-0800), ji...@linux.alibaba.com wrote: On Fri, 14 Feb 2025 21:03:46 +0800, Jin Ma wrote: Create a new hook to let target could override the multi-lib-os result. The motivation for this change arises from the fact th

Re: [PATCH 1/2] Add TARGET_COMPUTE_MULTILIB_OS hook to override multi-lib-os result.

2025-02-22 Thread Palmer Dabbelt
On Sat, 22 Feb 2025 02:19:03 PST (-0800), ji...@linux.alibaba.com wrote: On Fri, 14 Feb 2025 21:03:46 +0800, Jin Ma wrote: Create a new hook to let target could override the multi-lib-os result. The motivation for this change arises from the fact that using TARGET_COMPUTE_MULTILIB to override t

Re: [Fortran, Patch, PR107635, 4_v1] Fix class type and descriptor handling for new coarray interface [PR107635]

2025-02-22 Thread Harald Anlauf
Hi Andre, Am 21.02.25 um 14:35 schrieb Andre Vehreschild: Hi all, during testing and compiling some larger coarray codes, I found a few deficiencies. One was with handling class types when splitting the coarray expression and the other was that the backend_decl of a formal argument in a functio

Re: The COBOL front end, version 3, now in 14 easy pieces (+NIST)

2025-02-22 Thread Richard Kenner
Paul Koning wrote: > >> As I mentioned in other posts, IMO (IANAL) the copyright in > >> unimportant and probably unenforceable. The National Computing > >> Centre no longer exists, and the document was also published by NIST > >> which, as part of the US government, does not copyright its > >> p

Re: [PATCH 1/2] Add TARGET_COMPUTE_MULTILIB_OS hook to override multi-lib-os result.

2025-02-22 Thread Jin Ma
On Fri, 14 Feb 2025 21:03:46 +0800, Jin Ma wrote: > Create a new hook to let target could override the multi-lib-os result. > > The motivation for this change arises from the fact that using > TARGET_COMPUTE_MULTILIB to override the original multilib_dir can lead > to unexpected behavior with mult