Re: [PATCH] LoongArch: add -mdirect-extern-access option

2022-09-03 Thread Xi Ruoyao via Gcc-patches
On Sun, 2022-09-04 at 11:22 +0800, Lulu Cheng wrote: > > 在 2022/9/4 上午10:51, Xi Ruoyao 写道: >   > > On Sun, 2022-09-04 at 10:26 +0800, Lulu Cheng wrote: > >   > > > If the above modifications are not added, the function call is: > > > > > >  bl %plt(test1) > > > > > > now is : > > > > > >  bl te

Re: [PATCH] LoongArch: add -mdirect-extern-access option

2022-09-03 Thread Lulu Cheng
在 2022/9/4 上午10:51, Xi Ruoyao 写道: On Sun, 2022-09-04 at 10:26 +0800, Lulu Cheng wrote: If the above modifications are not added, the function call is:  bl %plt(test1) now is :  bl test1 Regarding "%plt(...)", in the binutils code: /* For compatible old asm code. */ if (0 == str

Re: [PATCH] LoongArch: add -mdirect-extern-access option

2022-09-03 Thread Xi Ruoyao via Gcc-patches
On Sun, 2022-09-04 at 10:26 +0800, Lulu Cheng wrote: > If the above modifications are not added, the function call is: > >  bl %plt(test1) > > now is : > >  bl test1 Regarding "%plt(...)", in the binutils code: /* For compatible old asm code. */ if (0 == strcmp (op_c_str, "plt")) b

Re: [PATCH] LoongArch: add -mdirect-extern-access option

2022-09-03 Thread Lulu Cheng
I think the following modification should be added: git diff loongarch/predicates.md +;; Do not use GOT to access external symbols, when define +;; TARGET_DIRECT_EXTERN_ACCESS. +  (define_predicate "is_const_call_local_symbol"    (and (match_operand 0 "const_call_insn_operand")     (ior (mat

Re: [PATCH] LoongArch: add -mdirect-extern-access option

2022-09-03 Thread Fangrui Song via Gcc-patches
On Fri, Sep 2, 2022 at 4:31 AM Xi Ruoyao via Gcc-patches wrote: > > On Thu, 2022-09-01 at 18:54 +0800, Xi Ruoyao wrote: > > We'd like to introduce a new codegen option to align with the old > > "-Wa,-mla-global-with-pcrel" and avoid a performance & size regression > > building the Linux kernel wit

[PATCH] coroutines: Wrap awaiting if/swich in a BIND_EXPR, if needed [PR106188]

2022-09-03 Thread Arsen Arsenović via Gcc-patches
In the edge case of a coroutine not containing any locals, the ifcd/swch temporaries would get added to the coroutine frame, corrupting its layout. We can prevent this by ensuring that in cases where the scope of the if/switch is the same as the coroutine frame one, we insert a wrapping BIND_EXPR a

Re: [PATCH 2/3] rename DBX_REGISTER_NUMBER to DEBUGGER_REGISTER_NUMBER

2022-09-03 Thread Jeff Law via Gcc-patches
On 9/2/2022 1:05 AM, Martin Liška wrote: On 9/1/22 14:32, Michael Matz wrote: Hello, okay, I'll bite :)  DBG_REGISTER_NUMBER?  DEBUGGER_REGNO? Yep, I'm fine with the shorter macro name. May I install such a change? Yes. jeff

Re: [PATCH] Add real_isdenormal.

2022-09-03 Thread Jeff Law via Gcc-patches
On 9/3/2022 7:48 AM, Aldy Hernandez via Gcc-patches wrote: There are 6 idioms of the same check and I'd like to add more. It seems there are macros as well as functions for things like REAL_VALUE_ISINF and REAL_VALUE_NEGATIVE. I don't know if there was historical need for this duplicity, but

[PATCH] c++: Implement C++23 P2266R1, Simpler implicit move [PR101165]

2022-09-03 Thread Marek Polacek via Gcc-patches
This patch implements https://wg21.link/p2266, which, once again, changes the implicit move rules. Here's a brief summary of various changes in this area: r125211: Introduced moving from certain lvalues when returning them r171071: CWG 1148, enable move from value parameter on return r212099: CWG

[COMMITTED] [PR 106819] NANs can never be a singleton

2022-09-03 Thread Aldy Hernandez via Gcc-patches
Possible NANs can never be a singleton, so they will never be propagated. This was the intent, and then the signed zero code crept in, and was mistakenly checked before the NAN. PR 106819 gcc/ChangeLog: * value-range.cc (frange::singleton_p): Move NAN check to the top. gcc/test

[PATCH] Add real_isdenormal.

2022-09-03 Thread Aldy Hernandez via Gcc-patches
There are 6 idioms of the same check and I'd like to add more. It seems there are macros as well as functions for things like REAL_VALUE_ISINF and REAL_VALUE_NEGATIVE. I don't know if there was historical need for this duplicity, but I think it's cleaner if we start gravitating towards inline fun

Re: [PATCH] libcpp, v3: Named universal character escapes and delimited escape sequence tweaks

2022-09-03 Thread Jakub Jelinek via Gcc-patches
On Sat, Sep 03, 2022 at 12:29:52PM +0200, Jakub Jelinek wrote: > On Thu, Sep 01, 2022 at 03:00:28PM -0400, Jason Merrill wrote: > > We might as well use the same flag name, and document it to mean what it > > currently means for GCC. > > Ok, following patch introduces -Wunicode (on by default). >

[PATCH] libcpp, v3: Named universal character escapes and delimited escape sequence tweaks

2022-09-03 Thread Jakub Jelinek via Gcc-patches
On Thu, Sep 01, 2022 at 03:00:28PM -0400, Jason Merrill wrote: > We might as well use the same flag name, and document it to mean what it > currently means for GCC. Ok, following patch introduces -Wunicode (on by default). > It looks like this is handling \N{abc}, for which "incomplete" seems lik

[committed] openmp: Partial OpenMP 5.2 doacross and omp_cur_iteration support

2022-09-03 Thread Jakub Jelinek via Gcc-patches
Hi! The following patch implements part of the OpenMP 5.2 changes related to ordered loops and with the assumed resolution of https://github.com/OpenMP/spec/issues/3302 issues. The changes are: 1) the depend clause on stand-alone ordered constructs has been renamed to doacross (because depend