It turns out that the target hook that this is supposed to satisfy
disappeared in 2004. Probably time to retire it.
Bootstrapped and tested on powerpc64le-unknown-linux-gnu with no
regressions; committed as obvious.
Thanks,
Bill
2020-08-28 Bill Schmidt
gcc/
* config/rs6000/rs6000-b
On Fri, Aug 28, 2020 at 11:48:41AM -0500, Bill Schmidt wrote:
> Remove unnecessary tests before copying function address to r12, as
> requested by Segher.
>
> Bootstrapped and tested on powerpc64le-unknown-linx-gnu with no
> regressions, committed as obvious.
Thanks!
Segher
On 27/08/20 22:41 +0100, Jonathan Wakely wrote:
This implements the changes from P0548 "common_type and duration". That
was a change for C++17, but as it corrects some issues introduced by DRs
I'm also treating it as a DR and changing it for all modes from C++11
up.
The main change is that durat
On 29/08/20 00:20 +0200, Daniel Krügler wrote:
Am Sa., 29. Aug. 2020 um 00:12 Uhr schrieb Jonathan Wakely via
Libstdc++ :
This fixes a bug with mixed signed and unsigned types, where converting
a negative value to the unsigned result type alters the value. The
solution is to obtain the absolut
Hi,
this patch changes ipa_call_context::estimate_size_and_time to store
its results into member fields of the ipa_call_context class instead
into pointers it receives as parameters so that it can compute ore
stuff without cluttering the interface even further.
Bootstrapped and tested on x86_64-l
Am Sa., 29. Aug. 2020 um 00:12 Uhr schrieb Jonathan Wakely via
Libstdc++ :
>
> This fixes a bug with mixed signed and unsigned types, where converting
> a negative value to the unsigned result type alters the value. The
> solution is to obtain the absolute values of the arguments immediately
> and
This fixes a bug with mixed signed and unsigned types, where converting
a negative value to the unsigned result type alters the value. The
solution is to obtain the absolute values of the arguments immediately
and to perform the actual GCD or LCM algorithm on two arguments of the
same type.
In ord
> The patch misses documentation of the pragma.
This was an intentional omission - when looking for documentation of
the pragma in clang I found none.
If we do want to document the pragmas in GCC:
- what section of the documentation would that go in?
- gcc/doc/cpp.texi, section 7, "Pragmas"
"duanbo (C)" writes:
> @@ -4395,6 +4395,40 @@ vect_recog_mask_conversion_pattern (vec_info *vinfo,
> {
> tmp = vect_recog_temp_ssa_var (TREE_TYPE (rhs1), NULL);
> pattern_stmt = gimple_build_assign (tmp, rhs1);
> + tree rhs1_op0 = TREE_OPERAND (rhs1, 0);
> + tree
On 28/08/2020 16:36, Christophe Lyon via Gcc-patches wrote:
> On Fri, 28 Aug 2020 at 16:27, Richard Earnshaw
> wrote:
>>
>> On 28/08/2020 14:24, Christophe Lyon via Gcc-patches wrote:
>>> On Fri, 28 Aug 2020 at 14:00, Richard Earnshaw
>>> wrote:
On 27/08/2020 14:27, Christophe Lyon via
On Thu, Aug 27, 2020 at 8:24 PM Jakub Jelinek wrote:
>
> On Thu, Jul 09, 2020 at 04:33:46PM +0800, Hongtao Liu via Gcc-patches wrote:
> > +static void
> > +replace_constant_pool_with_broadcast (rtx_insn* insn)
> > +{
> > + subrtx_ptr_iterator::array_type array;
> > + FOR_EACH_SUBRTX_PTR (iter, a
The gimple_call_alloc_size() function that determines the range
of sizes of allocated objects and constrains the bounds in calls
to functions like memcpy calls get_range() instead of
get_size_range() to obtain its result. The latter is the right
function to call because it has the necessary logic
On Fri, Aug 28, 2020 at 04:40:48PM +0100, Maciej W. Rozycki wrote:
> As far as `-fexceptions' and `-fasynchronous-unwind-tables' are concerned
> it aligns with my understanding, i.e. in this specific scenario we need
> `-fasynchronous-unwind-tables' for libcalls (all of them) so that an
-fasyn
Ping! Only the fix for the Fortran bootstrap failure in part 3 has been
reviewed.
-Sandra
https://gcc.gnu.org/pipermail/gcc-patches/2020-August/551927.html
On 8/13/20 10:34 AM, Sandra Loosemore wrote:
This is a revised version of the patch set originally posted
last November:
https://gcc.g
Hi,
the testcase causes and ICE in the SRA verifier on x86_64 when
compiling with -m32 because build_user_friendly_ref_for_offset looks
at an out-of-bounds array_ref within an array_ref which accesses an
offset which does not fit into a signed 32bit integer and turns it
into an array-ref with a ne
Remove unnecessary tests before copying function address to r12, as
requested by Segher.
Bootstrapped and tested on powerpc64le-unknown-linx-gnu with no
regressions, committed as obvious.
Thanks,
Bill
2020-08-28 Bill Schmidt
gcc/
* config/rs6000/rs6000.c (rs6000_call_aix): Remove te
(Removing libstd...@gcc.gnu.org from CC list)
On Fri, 28 Aug 2020, Patrick Palka wrote:
> In resolve_address_of_overloaded_function, currently only the second
> pass over the overload set (which considers just the function templates
> in the overload set) checks constraints and performs return typ
In resolve_address_of_overloaded_function, currently only the second
pass over the overload set (which considers just the function templates
in the overload set) checks constraints and performs return type
deduction when necessary. But as the testcases below show, we need to
do this when consideri
On Fri, Aug 28, 2020 at 05:07:11PM +0100, Richard Sandiford wrote:
> Jakub Jelinek via Gcc-patches writes:
> > + auto_vec buffer;
> > + auto_vec vec;
> > + object_allocator
> > +data_pool ("constant_descriptor_rtx_data_pool");
> > + int idx = 0;
> > + size_t size = 0;
> > + for (constant
Thanks for doing this. I don't feel qualified to review the full
patch, but one thing:
Jakub Jelinek via Gcc-patches writes:
> + auto_vec buffer;
> + auto_vec vec;
> + object_allocator
> +data_pool ("constant_descriptor_rtx_data_pool");
> + int idx = 0;
> + size_t size = 0;
> + for (co
On Wed, Aug 26, 2020 at 12:08 PM Richard Biener via Gcc-patches
wrote:
>
> On Tue, Aug 25, 2020 at 6:32 PM Maciej W. Rozycki wrote:
> >
> > Hi Kito,
> >
> > > I just found the mail thread about div mod with -fnon-call-exceptions,
> > > I think keeping the default LIB2_DIVMOD_EXCEPTION_FLAGS uncha
Ping: https://gcc.gnu.org/pipermail/gcc-patches/2020-August/551783.html
On 8/19/20 9:00 AM, Martin Sebor wrote:
Ping: https://gcc.gnu.org/pipermail/gcc-patches/2020-August/551783.html
On 8/11/20 10:19 AM, Martin Sebor wrote:
-Wplacement-new handles array indices and pointer offsets the same:
b
On Wed, 26 Aug 2020, Jakub Jelinek wrote:
> On Wed, Aug 26, 2020 at 01:08:00PM +0200, Richard Biener via Gcc-patches
> wrote:
> > You only need -fexceptions for that, then you can throw; from a signal
> > handler
> > for example. If you want to be able to catch the exception somewhere up
> > th
GCC maintainers:
The defines for vec_popcnt, bvec_popcnth, vec_popcntw, vec_popcntd in
gcc/config/rs6000/altivec.h are not listed in the Power 64-Bi ELF V2
ABI specification revision 1.4, May 10, 2017. They are not used by any
of the regression tests. They also do not work as reported in:
https
On Fri, 28 Aug 2020 at 16:27, Richard Earnshaw
wrote:
>
> On 28/08/2020 14:24, Christophe Lyon via Gcc-patches wrote:
> > On Fri, 28 Aug 2020 at 14:00, Richard Earnshaw
> > wrote:
> >>
> >> On 27/08/2020 14:27, Christophe Lyon via Gcc-patches wrote:
> >>> In comment 14 from PR94538, it was sugges
On Fri, Aug 28, 2020 at 8:22 AM Qing Zhao wrote:
>
>
>
> > On Aug 28, 2020, at 2:47 AM, Alexandre Oliva wrote:
> >
> > On Aug 26, 2020, Qing Zhao wrote:
> >
> >> There are two issues I can see with adding a default generator in middle
> >> end:
> >
> >> 1. In order to determine where a target s
> On Aug 28, 2020, at 2:47 AM, Alexandre Oliva wrote:
>
> On Aug 26, 2020, Qing Zhao wrote:
>
>> There are two issues I can see with adding a default generator in middle end:
>
>> 1. In order to determine where a target should not use the generic
>> code to emit the zeroing sequence,
>> a n
On Tue, 25 Aug 2020, Martin Liška wrote:
> I noticed your continual effort to change http:// links to https://.
> I've written a simple script that can do that in automatic way.
Thanks, Martin! My missions isn't actually changing http:// to https://
where possible, but checking for broken links a
On Fri, Aug 28, 2020 at 01:06:40PM +0200, Richard Biener via Gcc-patches wrote:
> > I don't see why it would break, it will not optimize { -1LL, -1LL }
> > vs. -1 scalar, sure, but it uses the hash and equality function the
> > rtl constant pool uses, which means it compares both the constants
> >
On 28/08/2020 15:26, Martin Liška wrote:
On 8/28/20 4:24 PM, Andrew Stubbs wrote:
Should I just add "true" to fix it? That's enough to make it build.
Yes, please and push it as obvious.
I've committed the attached.
Andrew
amdgcn: Update vec_safe_grow_cleared usage
An API change broke the a
On 8/28/20 12:49 AM, Martin Liška wrote:
On 8/28/20 1:29 AM, Martin Sebor wrote:
With --enable-valgrind-annotations the change to the member function
signature in this patch triggers compilation errors during bootstrap:
I must confirm I didn't tested the configuration. Feel free to install
the
On 28/08/2020 15:27, Richard Earnshaw wrote:
> On 28/08/2020 14:24, Christophe Lyon via Gcc-patches wrote:
>> On Fri, 28 Aug 2020 at 14:00, Richard Earnshaw
>> wrote:
>>>
>>> On 27/08/2020 14:27, Christophe Lyon via Gcc-patches wrote:
In comment 14 from PR94538, it was suggested to switch off
On 28/08/2020 14:24, Christophe Lyon via Gcc-patches wrote:
> On Fri, 28 Aug 2020 at 14:00, Richard Earnshaw
> wrote:
>>
>> On 27/08/2020 14:27, Christophe Lyon via Gcc-patches wrote:
>>> In comment 14 from PR94538, it was suggested to switch off jump tables
>>> on thumb-1 cores when using -mpure-
On 8/28/20 4:24 PM, Andrew Stubbs wrote:
Should I just add "true" to fix it? That's enough to make it build.
Yes, please and push it as obvious.
Thanks,
Martin
On 11/08/2020 12:36, Martin Liška wrote:
Hello.
All right, I did it in 3 steps:
1) - new exact argument is added (no default value) - I tested the on
x86_64-linux-gnu
and I build all cross targets.
2) set default value of exact = false
3) change places which calculate its own growth to use the
Hey.
The patch is about VEC_COND_EXP comparison of a SSA_NAME with a constant
that is artifact of -fno-tree-ccp.
Patch can bootstrap on x86_64-linux-gnu and survives regression tests.
Ready to be installed?
Thanks,
Martin
gcc/ChangeLog:
PR tree-optimization/96466
* gimple-fold
This PR is about LRA cycling for a reload of the form:
Changing pseudo 196 in operand 1 of insn 103 on equiv [r105:DI*0x8+r140:DI]
Creating newreg=287, assigning class ALL_REGS to slow/invalid mem r287
Creatin
On Thu, Aug 27, 2020 at 10:00 AM Uros Bizjak wrote:
>
> On Thu, Aug 27, 2020 at 4:45 PM H.J. Lu wrote:
>
> > > > > > > How about target("baseline-isas-only")? All CPUID functions are
> > > > > > > inlined.
> > > > > >
> > > > > > No, I don't think this is a good idea. Now consider the situation
On Fri, 28 Aug 2020 at 14:00, Richard Earnshaw
wrote:
>
> On 27/08/2020 14:27, Christophe Lyon via Gcc-patches wrote:
> > In comment 14 from PR94538, it was suggested to switch off jump tables
> > on thumb-1 cores when using -mpure-code, like we already do for thumb-2.
> >
> > This is what this pa
On 8/28/20 7:25 AM, Alan Modra wrote:
On Fri, Aug 28, 2020 at 01:17:27AM -0500, Segher Boessenkool wrote:
1) Very many unnecessary moves are generated during expand *anyway*, a
few more will not hurt;
2) In practice we always generate a move from a pseudo into r12 here,
never a copy from r12 int
On Fri, Aug 28, 2020 at 01:17:27AM -0500, Segher Boessenkool wrote:
> 1) Very many unnecessary moves are generated during expand *anyway*, a
> few more will not hurt;
> 2) In practice we always generate a move from a pseudo into r12 here,
> never a copy from r12 into r12;
> 3) Why generate dead cod
Hi all,
This patch introduces DWARF CFI support for architectures that require
multiple registers to hold pointers, such as the stack pointer, frame
pointer, and return address. The motivating case is the AMD GCN
architecture which has 64-bit address pointers, but 32-bit registers.
The curre
On 27/08/2020 14:27, Christophe Lyon via Gcc-patches wrote:
> In comment 14 from PR94538, it was suggested to switch off jump tables
> on thumb-1 cores when using -mpure-code, like we already do for thumb-2.
>
> This is what this patch does, and also restores the previous value of
> CASE_VECTOR_PC
Hi Tobias,
the patch looks ok to me.
Thanks for the patch.
Regards,
Andre
On Wed, 26 Aug 2020 18:29:40 +0200
Tobias Burnus wrote:
> This fixes an issue caused by the patch for PR 94672, which
> affects both GCC 10 and GCC 11.
>
> Only 'sVal' of 'subroutine foo' was affected, the rest
On Fri, Aug 28, 2020 at 01:06:40PM +0200, Richard Biener wrote:
> > On Fri, Aug 28, 2020 at 12:36:00PM +0200, Richard Biener wrote:
> > > Guess this would work indeed. It's probably quite common to have
> > > both vector and non-vector constants because of vectorization
> > > and scalar epilogues.
On Fri, Aug 28, 2020 at 12:47 PM Jakub Jelinek wrote:
>
> On Fri, Aug 28, 2020 at 12:36:00PM +0200, Richard Biener wrote:
> > Guess this would work indeed. It's probably quite common to have
> > both vector and non-vector constants because of vectorization
> > and scalar epilogues. But note that
On Fri, Aug 28, 2020 at 12:36:00PM +0200, Richard Biener wrote:
> Guess this would work indeed. It's probably quite common to have
> both vector and non-vector constants because of vectorization
> and scalar epilogues. But note that elsewhere we're using
> the largest component mode to emit vecto
> Sorry for the micromanagement, but I think this is easier to read if it flows
> as a
> single paragraph:
[snip...]
> I should have realised this would be the case, sorry, but now that there's
> only
> one rewrite, this should simply be:
>
> "&& reload_completed
>&& register_operand (op
On Fri, Aug 28, 2020 at 10:52 AM Jakub Jelinek wrote:
>
> On Fri, Aug 28, 2020 at 08:47:06AM +0200, Richard Biener via Gcc-patches
> wrote:
> > IIRC elsewhere it was discussed to use ld to perform merging by
> > emitting separate rodata sections for constant sizes (4, 8, 16, 32, 64
> > byte sizes
Hi,
attached patch fixes PR96418 where the code in the testsuite when compiled with
-fcoarray=single lead to an ICE. The reason was that the coarray object was
derefed as an array, but it was no array. Introducing the test for the
descriptor removes the ICE.
Regtests ok on x86_64-linux/FC31. Ok
Alex Coplan writes:
> Hello,
>
> Following on from the earlier patch to fix up the syntax for
> add/sub/adds/subs and friends with a sign/zero-extended operand [0],
> this patch removes the "mult" variants of these patterns which are
> all redundant.
>
> This patch removes the following patterns f
Thanks for doing this. In addition to what Segher said:
Jojo R writes:
> gcc/ChangeLog:
>
> * genemit.c (main): Print 'split line'.
> * Makefile.in (insn-emit.c): Define split count and file
>
> ---
> gcc/Makefile.in | 15 +
> gcc/genemit.c | 87 +++
Wei Wentao writes:
> Hi,
>
> This patch fix a typo in rtl.texi.
>
> Regards!
>
> Weiwt
>
> ---
> gcc/doc/rtl.texi | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gcc/doc/rtl.texi b/gcc/doc/rtl.texi
> index 501fa1a31da..f8e1f950823 100644
> --- a/gcc/doc/rtl.texi
> +++ b/g
Hu Jiangping writes:
> Hi,
>
> This patch add 'cd' command before 'make check-gcc' command
> when run the testsuite on selected tests.
>
> I think the implicit meaning of the original text is to
> execute the cd command to move to the gcc subdirectory of
> the object directory before executing the
Re: [PATCH] lra: Canonicalize mult to shift in address reloads
Hi Christophe,
On 28/08/2020 10:16, Christophe Lyon wrote:
> Hi Alex,
>
>
> On Wed, 26 Aug 2020 at 17:15, Alex Coplan wrote:
> >
> > Thanks for the review, both.
> >
> > On 26/08/2020 09:19, Vladimir Makarov wrote:
> > >
> > > On 2
On Fri, 28 Aug 2020, Christophe Lyon wrote:
> Hi,
>
>
> On Thu, 27 Aug 2020 at 13:07, Richard Biener wrote:
> >
> > The following streamlines TARGET_MEM_REF dumping building
> > on what we do for MEM_REF and thus dumping things like
> > access type, TBAA type and base/clique. I've changed it
>
On Fri, Aug 28, 2020 at 08:47:06AM +0200, Richard Biener via Gcc-patches wrote:
> IIRC elsewhere it was discussed to use ld to perform merging by
> emitting separate rodata sections for constant sizes (4, 8, 16, 32, 64
> byte sizes).
ld does that already, and gcc too.
> ld could always direct 8 b
Hi,
On Thu, 27 Aug 2020 at 13:07, Richard Biener wrote:
>
> The following streamlines TARGET_MEM_REF dumping building
> on what we do for MEM_REF and thus dumping things like
> access type, TBAA type and base/clique. I've changed it
> to do semantic dumping aka base + offset + step * index
> ra
Hi Alex,
On Wed, 26 Aug 2020 at 17:15, Alex Coplan wrote:
>
> Thanks for the review, both.
>
> On 26/08/2020 09:19, Vladimir Makarov wrote:
> >
> > On 2020-08-26 5:06 a.m., Richard Sandiford wrote:
> > > Alex Coplan writes:
> > >
> > > Minor nit, should be formatted as:
> > >
> > > static rtx
>
Hi,
On Thu, 27 Aug 2020 at 10:04, Richard Biener wrote:
>
> This makes sure to put special-ops expanded rhs left where
> expression rewrite expects it.
>
> Bootstrapped and tested on x86_64-unknown-linux-gnu, pushed.
>
> 2020-08-27 Richard Biener
>
> PR tree-optimization/96579
>
On Aug 26, 2020, Qing Zhao wrote:
> There are two issues I can see with adding a default generator in middle end:
> 1. In order to determine where a target should not use the generic
> code to emit the zeroing sequence,
> a new target hook to determine this has to be added;
Yeah, a target hook
On Fri, Aug 28, 2020 at 3:26 AM Austin Morton via Gcc-patches
wrote:
>
> #pragma region is a feature introduced by Microsoft in order to allow
> manual grouping and folding of code within Visual Studio. It is
> entirely ignored by the compiler. Clang has supported this feature
> since 2012 when
Actually ChangeLog also uses tabs, so it should be:
libstdc++-v3/ChangeLog:
* include/std/variant: Fix -Wignored-qualifiers
in system headers.
On Fri, 28 Aug 2020 at 08:55, Krystian Kuźniarek <
krystian.kuznia...@gmail.com> wrote:
> > So then you need to produce a changelog ent
63 matches
Mail list logo