On 03/14/2016 06:15 PM, Sandra Loosemore wrote:
> On 03/14/2016 12:40 PM, Carlos O'Donell wrote:
>> Using the 'leaf' attribute is difficult in certain use cases, and
>> the documentation rightly points out that signals is one such
>> problem.
>>
>> We should additionally document the following cav
On 03/15/2016 12:24 PM, Jakub Jelinek wrote:
Bernd E. mentioned in the PR the problem that if some subobject ctor throws,
if for -fsanitize=vptr we clear again the vtable pointers even for virtual
bases then they won't be properly destructed.
So, here is an incremental patch to the earlier pat
On 03/15/2016 08:25 PM, Joseph Myers wrote:
On Tue, 15 Mar 2016, H.J. Lu wrote:
On Tue, Mar 15, 2016 at 3:34 PM, Joseph Myers wrote:
On Tue, 15 Mar 2016, H.J. Lu wrote:
On Tue, Mar 15, 2016 at 2:39 PM, Joseph Myers wrote:
I'm not sure if the zero-size arrays (a GNU extension) are consider
On Tue, Mar 15, 2016 at 5:25 PM, Joseph Myers wrote:
> On Tue, 15 Mar 2016, H.J. Lu wrote:
>
>> On Tue, Mar 15, 2016 at 3:34 PM, Joseph Myers
>> wrote:
>> > On Tue, 15 Mar 2016, H.J. Lu wrote:
>> >
>> >> On Tue, Mar 15, 2016 at 2:39 PM, Joseph Myers
>> >> wrote:
>> >> > I'm not sure if the zer
On Tue, 15 Mar 2016, H.J. Lu wrote:
> On Tue, Mar 15, 2016 at 3:34 PM, Joseph Myers wrote:
> > On Tue, 15 Mar 2016, H.J. Lu wrote:
> >
> >> On Tue, Mar 15, 2016 at 2:39 PM, Joseph Myers
> >> wrote:
> >> > I'm not sure if the zero-size arrays (a GNU extension) are considered to
> >> > make a str
On Tue, Mar 15, 2016 at 3:34 PM, Joseph Myers wrote:
> On Tue, 15 Mar 2016, H.J. Lu wrote:
>
>> On Tue, Mar 15, 2016 at 2:39 PM, Joseph Myers
>> wrote:
>> > I'm not sure if the zero-size arrays (a GNU extension) are considered to
>> > make a struct non-empty, but in any case I think the tests sh
Another test where we need to avoid the limited alignment of common on
hppa*-*-hpux*.
Committed to trunk.
Dave
--
John David Anglin dave.ang...@bell.net
2016-03-15 John David Anglin
* gcc.c-torture/execute/pr68532.c: Add -fno-common option on
hppa*-*-hpux*.
Index: gcc
> At this point we usually have a PR to go with all stage4
> changes. But a meaningful PR is difficult to create, since
> the attachment would be too large. Perhaps a generator could
> be created, but since it wouldn't go in the testsuite it seems
> like a waste of time.
>
> Thoughts?
CPP macr
See bug testsuite/68232 for justification. Committed to trunk.
Dave
--
John David Anglin dave.ang...@bell.net
2016-03-15 John David Anglin
* gcc.dg/ifcvt-4.c: Add hppa*64*-*-* to skip list.
Index: gcc.dg/ifcvt-4.c
==
This patch fixes failure of coarray_allocate_5.f08 on hppa. Tested on
hppa2.0w-hp-hpux11.11 and
hppa64-hp-hpux11.11. Committed to trunk.
Dave
--
John David Anglin dave.ang...@bell.net
2016-03-15 John David Anglin
PR libfortran/69799
* gfortran.dg/coarray_allocate_5.f
On Tue, Mar 15, 2016 at 03:31:44PM -0700, Richard Henderson wrote:
> On 03/10/2016 08:20 PM, DJ Delorie wrote:
> >I'm moving on to Plan C but I put a copy of the file on
> >.../dj/foo.c.gz (195Mb) if anyone wants to find out
> >why there's a 16Gb limit compiling it...
>
> With just the following,
On Tue, 15 Mar 2016, H.J. Lu wrote:
> On Tue, Mar 15, 2016 at 2:39 PM, Joseph Myers wrote:
> > I'm not sure if the zero-size arrays (a GNU extension) are considered to
> > make a struct non-empty, but in any case I think the tests should cover
> > such arrays as elements of structs.
>
> There ar
On Tue, Mar 15, 2016 at 2:39 PM, Joseph Myers wrote:
> I'm not sure if the zero-size arrays (a GNU extension) are considered to
> make a struct non-empty, but in any case I think the tests should cover
> such arrays as elements of structs.
There are couple tests for structs with members of array
On 03/10/2016 08:20 PM, DJ Delorie wrote:
I'm moving on to Plan C but I put a copy of the file on
.../dj/foo.c.gz (195Mb) if anyone wants to find out
why there's a 16Gb limit compiling it...
With just the following, we successfully compile your file.
It takes about 25 minutes and memory use to
I'm not sure if the zero-size arrays (a GNU extension) are considered to
make a struct non-empty, but in any case I think the tests should cover
such arrays as elements of structs.
--
Joseph S. Myers
jos...@codesourcery.com
OK.
Jason
On 03/15/2016 07:13 AM, Richard Biener wrote:
On Tue, Mar 15, 2016 at 4:44 AM, Richard Henderson wrote:
The problem here is that
void* labels[] = {
&&l0, &&l1, &&l2
};
gets gimplified to
labels = *.LC0;
but .LC0 is not in the set of local decls, so that when copy_forbidden is
Let's factor out that duplicated code into a separate function.
Jason
On 03/15/2016 12:00 PM, H.J. Lu wrote:
On Tue, Mar 15, 2016 at 8:35 AM, Jason Merrill wrote:
I'm concerned about how this patch changes both target-independent code and
target-specific code, with a passing remark that other targets might need to
make similar changes. I'm also concerned about t
The code in for_each_template_parm_r to walk into the RHS of
TYPENAME_TYPE only when there isn't a predicate seemed nonsensical, and
removing the condition didn't break anything in the testsuite.
Tested x86_64-pc-linux-gnu, applying to trunk.
commit 364983121fbd1a0c79185a5d0291bcef72970613
Auth
On Tue, 15 Mar 2016, Andrey Belevantsev wrote:
> On 15.03.2016 20:44, Alexander Monakov wrote:
> > On Tue, 15 Mar 2016, Marek Polacek wrote:
> > > This test fails for me due to
> > > cc1plus: warning: var-tracking-assignments changes selective scheduling
> >
> > Thanks for the heads-up Marek, and s
On 03/14/2016 06:15 PM, Sandra Loosemore wrote:
> On 03/14/2016 12:40 PM, Carlos O'Donell wrote:
>> Using the 'leaf' attribute is difficult in certain use cases, and
>> the documentation rightly points out that signals is one such
>> problem.
>>
>> We should additionally document the following cav
On 15.03.2016 20:44, Alexander Monakov wrote:
On Tue, 15 Mar 2016, Marek Polacek wrote:
This test fails for me due to
cc1plus: warning: var-tracking-assignments changes selective scheduling
Thanks for the heads-up Marek, and sorry for the trouble. Like I said in the
adjacent reply, the warnin
On Tue, 15 Mar 2016, Marek Polacek wrote:
> This test fails for me due to
> cc1plus: warning: var-tracking-assignments changes selective scheduling
Thanks for the heads-up Marek, and sorry for the trouble. Like I said in the
adjacent reply, the warning is expected (I didn't realize the testsuite
On Mon, Mar 14, 2016 at 12:31:24PM +0300, Andrey Belevantsev wrote:
> Hello,
>
> Here we're looping because we decrease the counter of the insns we still can
> issue on a DEBUG_INSN thus rendering the counter negative. The fix is to
> not count debug insns in the corresponding code. The selectiv
Recently, strip_typedefs was updated to use DECL_ORIGINAL_TYPE on typedefs
because TYPE_MAIN_VARIANT wasn't sufficient in getting the underlying type.
In this case even that wasn't enough: for the attached test DECL_ORIGINAL_TYPE
of Ta [REAL_TYPE] yielded F [REAL_TYPE], but we want to get down to "
> Consider the attached test program. When built with -g in sparc64-*-*
> the resulting binary contains:
>
> - A .eh_frame segment containing CFA information for __libc_csu_init and
> __libc_csu_fini.
>
> - A .debug_frame segment containing CFA information for func
Hi!
Bernd E. mentioned in the PR the problem that if some subobject ctor throws,
if for -fsanitize=vptr we clear again the vtable pointers even for virtual
bases then they won't be properly destructed.
So, here is an incremental patch to the earlier patch, which will clear
the virtual base vtbl p
2016-03-10 16:46 GMT+03:00 Senthil Kumar Selvaraj
:
> Hi,
>
>This patch fixes ~230 internal compiler errors that showed up after
>the fix for PR 69764. After the patch, target backends need to
>explicitly specify mode for operand 2 of shift and rotate patterns -
>see md.texi mod at
Hi!
As mentioned in the PR, the problem is that we might grow the vector
without clearing new entries, while we overwrite the last entry, there might
be gaps containing garbage pointers and cause lots of weird issues.
The testcase is unfortunately too large (creduced it down to 26100 bytes)
for t
On Tue, Mar 15, 2016 at 09:50:44AM -0500, Segher Boessenkool wrote:
> On Tue, Mar 15, 2016 at 02:18:33PM +0100, Jakub Jelinek wrote:
> > So do you prefer this instead?
> >
> > 2016-03-15 Jakub Jelinek
> >
> > PR rtl-optimization/70222
> > * combine.c (simplify_shift_const_1): For A >>
On Tue, Mar 15, 2016 at 8:35 AM, Jason Merrill wrote:
> I'm concerned about how this patch changes both target-independent code and
> target-specific code, with a passing remark that other targets might need to
> make similar changes. I'm also concerned about the effect of this on other
> languag
Hello,
On 14.03.2016 12:52, Andrey Belevantsev wrote:
Hello,
The problem here is readonly dependence contexts in selective scheduler.
We're trying to cache the effect of initializing a dependence context with
remembering that context and setting a readonly bit on it. When first
moving the insn
Hello,
On 14.03.2016 19:45, Bernd Schmidt wrote:
On 03/14/2016 05:23 PM, Alexander Monakov wrote:
On Mon, 14 Mar 2016, Andrey Belevantsev wrote:
In this case, we get an inconsistency between the sched-deps interface,
saying
we can't move an insn writing the si register through a vector insn, a
I'm concerned about how this patch changes both target-independent code
and target-specific code, with a passing remark that other targets might
need to make similar changes. I'm also concerned about the effect of
this on other languages that might not want the same change. So, here's
an alte
On Mon, Mar 07, 2016 at 10:54:25PM -0800, Andrew Pinski wrote:
> On Mon, Mar 7, 2016 at 8:12 PM, Yangfei (Felix) wrote:
> >> On Mon, Mar 7, 2016 at 7:27 PM, Yangfei (Felix)
> >> wrote:
> >> > Hi,
> >> >
> >> > As discussed in LKML:
> >> http://lists.infradead.org/pipermail/linux-arm-kernel/2
On 03/15/2016 02:26 AM, Andreas Schwab wrote:
Richard Henderson writes:
diff --git a/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
b/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
new file mode 100644
index 000..741d311
--- /dev/null
+++ b/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
@@ -0,0 +1,9 @@
+/* {
On Tue, Mar 15, 2016 at 02:18:33PM +0100, Jakub Jelinek wrote:
> So do you prefer this instead?
>
> 2016-03-15 Jakub Jelinek
>
> PR rtl-optimization/70222
> * combine.c (simplify_shift_const_1): For A >> B >> C LSHIFTRT
> optimization if mode is different from result_mode, qu
* include/private/gcconfig.h [AARCH64] (ALIGNMENT, CPP_WORDSZ):
Define for __ILP32__.
---
boehm-gc/include/private/gcconfig.h | 9 +++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/boehm-gc/include/private/gcconfig.h
b/boehm-gc/include/private/gcconfig.h
inde
On Mon, Mar 14, 2016 at 11:32 PM, Jeff Law wrote:
> On 03/11/2016 03:02 AM, Richard Biener wrote:
>>
>>
>>
>> For the other part I noticed a few things
>> 1) having a bitmap_count_ior_bits () would be an improvement
>
> Yea, I almost built one. That's easy enough to add.
>
>> 2) you might end
Like x32, aarch64 ILP32 needs to define FFI_SIZEOF_JAVA_RAW. This fixes
the java interpreter.
Andreas.
* src/aarch64/ffitarget.h (FFI_SIZEOF_JAVA_RAW) [__ILP32__]:
Define.
---
libffi/src/aarch64/ffitarget.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/libffi/src/aarch64/f
On Tue, Mar 15, 2016 at 4:44 AM, Richard Henderson wrote:
> The problem here is that
>
> void* labels[] = {
> &&l0, &&l1, &&l2
> };
>
> gets gimplified to
>
> labels = *.LC0;
>
> but .LC0 is not in the set of local decls, so that when copy_forbidden is
> called during sra versioning we f
On Mon, Mar 14, 2016 at 4:23 PM, Pat Haugen wrote:
> As stated in https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68232, this test
> needs -misel on powerpc to pass. Verified the following fixes the test on
> both powerpc64/powerpc64le. Ok for trunk?
>
> -Pat
>
> testsuite/ChangeLog:
> 2016-03-14 Pa
On Tue, Mar 15, 2016 at 01:08:50PM +0100, Bernd Schmidt wrote:
> This looks really specialized, and I'd be worrying about whether it really
> is the right condition. Where exactly was the constant shifted by 31 and
> count set to 0? Must be here, right?
Yes, it is that spot.
>
>/* If we have
Hi,
I've translated the goacc/kernels-alias{,-2}.c testcases to fortran.
Committed to trunk.
Thanks,
- Tom
Add goacc/kernels-alias{,-2}.f95
2016-03-15 Tom de Vries
* gfortran.dg/goacc/kernels-alias-2.f95: New test.
* gfortran.dg/goacc/kernels-alias.f95: New test.
---
.../gfortran.dg/go
On 03/15/2016 03:27 AM, Alan Modra wrote:
On Mon, Mar 14, 2016 at 01:00:39PM -0600, Jeff Law wrote:
Right. Tolerant as in not crash.
So can someone please approve my ira.c:indirect_jump_optimize patch?
I'm not quite audacious enough to claim it is obvious.
Looks good to me.
Bernd
On Tue, Mar 15, 2016 at 11:56:18AM +0100, Jakub Jelinek wrote:
> From compile time perspective, I wonder if it wouldn't be better to do
> the cheap tests early, like:
> if (warn_address
> && (complain & tf_warning)
> && c_inhibit_evaluation_warnings == 0
> && !TR
On 03/15/2016 12:14 PM, Jakub Jelinek wrote:
- if (orig_code == LSHIFTRT && result_mode != shift_mode)
+ turn off all the bits that the shift would have turned off.
+ Similarly do this if we've optimized varop so that we don't perform
+ any shift. */
+ if (orig_code == LSHIFTRT
+
Another C++17 feature that's trivial to implement, since it was already
supported: hex floating-point literals. We just need to define the
feature-test macro and correctly remove it from strict C++11/14 modes.
Tested x86_64-pc-linux-gnu, applying to trunk.
commit 7fc42c9d978983956029b2b401682d
Hi.
As emission of a HSAIL function can fail for various reason (-Whsa),
we must guarantee that a global variable is declared and at maximum once.
Following patch does that, patch can survive make check-target-libgomp and
HSAILAsm is happy with BRIG output of declare_target-5.c source file.
Curr
On Mon, 14 Mar 2016, Tom de Vries wrote:
> Hi,
>
> this patch fixes PR70161, a 4.9/5/6 regression.
>
> Currently when using -fdump-ipa-all-graph, the compiler ICEs in
> execute_function_dump when testing for pass->graph_dump_initialized, because
> pass == NULL.
>
> The patch fixes:
> - the ICE
On Tue, 15 Mar 2016, Eric Botcazou wrote:
> Hi,
>
> this is the failure of the LTO bootstrap with profile-directed optimization
> when compiling gnat1 with debug info. The issue is that flush_limbo_die_list
> doesn't actually fully flush the limbo list because it calls get_context_die,
> whic
Hi!
As mentioned in the PR, if we have
simplify_shift_const_1 (code=LSHIFTRT, result_mode=SImode,
varop=0x7184de70, orig_count=31)
where varop is:
(subreg:SI (lshiftrt:DI (const_int -1 [0x])
(subreg:QI (reg:SI 100) 0)) 0),
we optimize the inner shift (mode == DImode) i
On Tue, Mar 15, 2016 at 11:41:20AM +0100, Marek Polacek wrote:
> This is to fix missing "address of %qD will never be NULL" warning that went
> away since the delayed folding merge. The problem was that cp_build_binary_op
> was getting unfolded ops so in the constexpr case it saw "(int *) p" inste
Hi,
this is the failure of the LTO bootstrap with profile-directed optimization
when compiling gnat1 with debug info. The issue is that flush_limbo_die_list
doesn't actually fully flush the limbo list because it calls get_context_die,
which calls force_decl_die, which can put new DIEs on the l
On Tue, 15 Mar 2016, Andreas Schwab wrote:
> Richard Henderson writes:
>
> > diff --git a/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
> > b/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
> > new file mode 100644
> > index 000..741d311
> > --- /dev/null
> > +++ b/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
This is to fix missing "address of %qD will never be NULL" warning that went
away since the delayed folding merge. The problem was that cp_build_binary_op
was getting unfolded ops so in the constexpr case it saw "(int *) p" instead of
"&i" (in this particular testcase). Fixed by calling fold_non_
> It looks like it might catch a few extra cases where the address of the
> decl is required. But it also looks like it's somewhat overly broad like
>
> /* Function types that are TREE_ADDRESSABLE force return in memory. */
> if (fntype && TREE_ADDRESSABLE (fntype))
> return 1;
>
> with
I've recently been pointed at PR target/38239, where trivial programs
compiled/linked with -pg SEGV on 32-bit Solaris/x86 since _mcount
clobbers %ecx. It was initially reported for gcc 4.3, but I couldn't
reproduce it there and the testcase works fine up to and including gcc
4.8. Since 4.9, the S
Richard Henderson writes:
> diff --git a/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
> b/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
> new file mode 100644
> index 000..741d311
> --- /dev/null
> +++ b/gcc/testsuite/gcc.dg/tree-ssa/pr68714.c
> @@ -0,0 +1,9 @@
> +/* { dg-do compile } */
> +/* { dg-opt
* Jason Merrill:
> On 03/14/2016 05:30 PM, Florian Weimer wrote:
>> * Jason Merrill:
>>
>>> P08184R0: Generalizing the Range-Based For Loop
>>
>> How can one resolve this reference? It's obviously not a PR number in
>> GCC Bugzilla.
>>
>> I found this after some searching:
>>
>>
61 matches
Mail list logo