Re: [PATCH, libgfortran] PR68867 numeric formatting problem in the fortran library

2015-12-12 Thread Steve Kargl
On Sat, Dec 12, 2015 at 08:14:39PM -0800, Jerry DeLisle wrote: > case 16: > + /* Adjust decimal precision depending on binary precision, 103 or 113. > */ s/103/106 I suspect that this is simply a bandaid on a much bigger problem. Namely, few of the intrinsic functions for REAL(16)

[PATCH, libgfortran] PR68867 numeric formatting problem in the fortran library

2015-12-12 Thread Jerry DeLisle
Hi all, This PR is about different binary precision of quad floats on different platforms. X86 uses libquadmath with 113 bits, PowerPC uses IBM 106 bits. For list directed output we set the default decimal precision to use. Because the PowerPC has fewer significant bits, we need to adjust the

[PATCH] Fix PR c++/21802 (two-stage name lookup fails for operators)

2015-12-12 Thread Patrick Palka
On Fri, 11 Dec 2015, Jason Merrill wrote: > On 12/11/2015 02:43 PM, Patrick Palka wrote: >> + if (processing_template_decl >> + && result != NULL_TREE >> + && result != error_mark_node >> + && DECL_HIDDEN_FRIEND_P (cand->fn)) >> +{ >> + tree call =

Re: Prune TYPE_FIELDS lists more in free_lang_data

2015-12-12 Thread Jan Hubicka
> On Fri, 11 Dec 2015, Jan Hubicka wrote: > > > > > > > We explicitely do not use debug-info-level tests in free-lang-data > > > to allow mixing -g and -g0 objects. Are you sure doing the above > > > doesn't mess up tree merging enough to effectively enlarge WPA > > > memory use and the merged d

[SPARC] Enable wide-int support

2015-12-12 Thread Eric Botcazou
On the heels of s390, this enables wide-int support in the SPARC back-end and removes all the obsolete code conditionalized on HOST_BITS_PER_WIDE_INT == 32. Boostrapped/regtested on SPARC/Solaris, applied on the mainline. 2015-12-12 Eric Botcazou * config/sparc/sparc.h (TARGET_SUPPO

Re: [PATCH v2] Do not sanitize left shifts for -fwrapv (PR68418)

2015-12-12 Thread Eric Botcazou
> gcc: > PR sanitizer/68418 > * c-family/c-ubsan.c (ubsan_instrument_shift): Disable > sanitization of left shifts for wrapping signed types as well. That's incorrect, it should be put into c-family/ChangeLog without prefix. -- Eric Botcazou

[v3 PATCH] Document the implementation of Logical Operator Type Traits.

2015-12-12 Thread Ville Voutilainen
2015-11-12 Ville Voutilainen Document the implementation of Logical Operator Type Traits. * doc/html/index.html: Regenerate. * doc/html/manual/status.html: Likewise. * doc/xml/manual/status_cxx2017.xml: Add P0013R1 to C++ 201z and to Library Fundamentals 2 TS. diff --git a/

Re: Do not decompress functions sections when copying them to ltrans

2015-12-12 Thread Richard Biener
On December 12, 2015 7:47:39 PM GMT+01:00, Jan Hubicka wrote: >> > So would the patch be a lot more difficult if you go down either of >> > the routes above? (I think I prefer changing lto_header rather >> > than making main_size a bitfield) >> >> Agreed ;) >Hmm, actually it seems things are dif

Re: Transparent alias suport part 7 (lto-symtab support)

2015-12-12 Thread H.J. Lu
On Tue, Dec 8, 2015 at 2:30 PM, Jan Hubicka wrote: > Hi, > this patch adds support to lto-symtab.c to prevent merging of certain > declarations. The new predicate lto_symtab_merge_p can be used to decide > about this. The change is pretty straigforward. lto_symtab_merge_decls_2 > makes the dec

Re: Do not decompress functions sections when copying them to ltrans

2015-12-12 Thread Jan Hubicka
> > So would the patch be a lot more difficult if you go down either of > > the routes above? (I think I prefer changing lto_header rather > > than making main_size a bitfield) > > Agreed ;) Hmm, actually it seems things are difficult. All the headers are already compressed by zlib: Contents of

Re: PING^1: [PATCH] Add TYPE_EMPTY_RECORD for C++ empty class

2015-12-12 Thread Marc Glisse
On Sat, 12 Dec 2015, Jakub Jelinek wrote: On Sat, Dec 12, 2015 at 09:51:23AM -0500, Jason Merrill wrote: On 12/11/2015 06:52 PM, H.J. Lu wrote: On Thu, Dec 10, 2015 at 3:24 AM, Richard Biener wrote: On Wed, Dec 9, 2015 at 10:31 PM, Markus Trippelsdorf wrote: On 2015.12.09 at 10:53 -0800, H

Re: [PATCH] v2 Re: [PATCH] RFC: Use Levenshtein spelling suggestions in Fortran FE

2015-12-12 Thread Bernhard Reutner-Fischer
On December 9, 2015 2:07:05 AM GMT+01:00, David Malcolm wrote: >I can't comment on Mikael's observations, but here's an updated version >of Bernhard's patch which moves the duplicated code into a new >"find_closest_string" function in gcc/spellcheck.c. >With that, the lookup_*_fuzzy functions

Re: [Patch, Fortran] PR45859 - Permit array elements to coarray dummy arguments

2015-12-12 Thread Steve Kargl
On Wed, Dec 09, 2015 at 08:24:39AM +0100, Tobias Burnus wrote: > PING > OK. -- Steve

Re: PING^1: [PATCH] Add TYPE_EMPTY_RECORD for C++ empty class

2015-12-12 Thread H.J. Lu
On Sat, Dec 12, 2015 at 7:27 AM, Jakub Jelinek wrote: > On Sat, Dec 12, 2015 at 09:51:23AM -0500, Jason Merrill wrote: >> On 12/11/2015 06:52 PM, H.J. Lu wrote: >> >On Thu, Dec 10, 2015 at 3:24 AM, Richard Biener >> > wrote: >> >>On Wed, Dec 9, 2015 at 10:31 PM, Markus Trippelsdorf >> >> wrote: >>

Re: [PATCH 6/6] [DJGPP] configure.ac: enable LTO

2015-12-12 Thread Andris Pavenis
On 12/11/2015 12:32 AM, Jeff Law wrote: On 12/05/2015 10:25 AM, Andris Pavenis wrote: Patch enables LTO support for DJGPP in top level configure.ac Andris 2015-12-05 Andris Pavenis * configure.ac: enable LTO for *-*-msdosdjgpp OK once prereqs have gone in. Note you should to the autoconf da

Re: [PATCH 5/6] [DJGPP] gcc/config/i386: update DJGPP configuration related files

2015-12-12 Thread Andris Pavenis
On 12/11/2015 12:43 AM, Jeff Law wrote: On 12/05/2015 10:22 AM, Andris Pavenis wrote: Patch include updates to DJGPP related files in gcc/config/i386. There are too many changes to gcc/config/i386/djgpp.h and gcc/config/i386/xm-djgpp.h to list them completely in changelog entry. Andris 2015-1

Re: PING^1: [PATCH] Add TYPE_EMPTY_RECORD for C++ empty class

2015-12-12 Thread Jakub Jelinek
On Sat, Dec 12, 2015 at 09:51:23AM -0500, Jason Merrill wrote: > On 12/11/2015 06:52 PM, H.J. Lu wrote: > >On Thu, Dec 10, 2015 at 3:24 AM, Richard Biener > > wrote: > >>On Wed, Dec 9, 2015 at 10:31 PM, Markus Trippelsdorf > >> wrote: > >>>On 2015.12.09 at 10:53 -0800, H.J. Lu wrote: > > E

Re: PING^1: [PATCH] Add TYPE_EMPTY_RECORD for C++ empty class

2015-12-12 Thread Jason Merrill
On 12/11/2015 06:52 PM, H.J. Lu wrote: On Thu, Dec 10, 2015 at 3:24 AM, Richard Biener wrote: On Wed, Dec 9, 2015 at 10:31 PM, Markus Trippelsdorf wrote: On 2015.12.09 at 10:53 -0800, H.J. Lu wrote: Empty C++ class is a corner case which isn't covered in psABI nor C++ ABI. There is no menti

Re: [PATCH][ARC] Refurbish emitting DWARF2 for epilogue.

2015-12-12 Thread Joern Wolfgang Rennecke
On 11/12/15 10:29, Claudiu Zissulescu wrote: I did some testing here. For size, I used CSiBE testbench, and for speed, I used coremark and dhrystone. Using a blockage or not, doesn't affect the size or speed figures. However, using TARGET_NO_SPECULATION_IN_DELAY_SLOTS_P hook betters the size

Re: update_vtable_references segfault

2015-12-12 Thread Nathan Sidwell
On 12/11/15 13:15, Jan Hubicka wrote: Jan, b) augment can_replace_by_local_alias_in_vtable to check whether aliases can be created? I think this is best: can_replace_by_local_alias_in_vtable exists to prevent the body walk in cases we are not going to create the alias. This is because in LT

[PATCH] g++.dg/cpp1y/pr58708.C testcase fix for AIX

2015-12-12 Thread David Edelsohn
I previously updated the assignment to correct the compile-time error, but the runtime check of values also needs to be updated for 16 bit wchar_t. Tested on powerpc-ibm-aix7.1.0.0. Committed. Thanks, David * g++.dg/cpp17/pr58708.C: Test appropriate value for size of wchar_t. Index: pr58708.C

RE: [Patch, MIPS] Remove definition of TARGET_PROMOTE_PROTOTYPES

2015-12-12 Thread Matthew Fortune
Steve Ellcey writes: > On Tue, 2015-11-10 at 15:57 -0800, Steve Ellcey wrote: > > 2015-11-10 Steve Ellcey > > > > * config/mips/mips.c (mips_promote_function_mode): New function. > > (TARGET_PROMOTE_FUNCTION_MODE): Define as above function. > > (TARGET_PROMOTE_PROTOTYPES): Remove.