Andi's patch broke bootstrap on all FreeBSD platforms, which took me
a bit to realize since he did not update the ChangeLog:
2013-03-23 Andi Kleen
* local_atomic (__always_inline): Add.
(__calculate_memory_order, atomic_thread_fence,
atomic_signal_fence, test_and_se
Remove unused symbols related to ivtype_map. This map does not appear to
exist and I see no evidence of its removal in the ChangeLog.
Tested on x86_64.
Okay for trunk?
Index: gcc/ChangeLog
2013-03-31 Lawrence Crowl
* sese.h (struct ivtype_map_elt_s): Remove unused.
(extern
> From: Gerald Pfeifer
> Date: Sun, 31 Mar 2013 23:17:59 +0200
> One of these days I ought to write a blog about the oddities
> I have been encountering over the years.
>
> In this case ftp.axis.se does not serve its original contents
> via the ftp protocol, but still does via http.
Weird; I'l
One of these days I ought to write a blog about the oddities
I have been encountering over the years.
In this case ftp.axis.se does not serve its original contents
via the ftp protocol, but still does via http.
Committed.
Gerald
Index: readings.html
This patch readd TARGET_H that was removed with revision 188166
IPA_PROP_H is in use by PLUGIN_HEADERS and did depend on GIMPLE_H that
did have TARGET_H before it was removed and it was not added to IPA_PROP_H or
PLUGIN_HEADERS. See the bug for more info.
/Magnus
gcc:
2013-03-30 Magnus Granber
On 31 March 2013 22:11, Andrew Pinski wrote:
>
> A couple of things. I think should be able to control the coloring by
> a real environment variable like LS_COLOR allows.
> fdiagnostics-show-color should be controllable by an env variable so
> you don't have to pass an argument to gcc all the tim
On Sun, Mar 31, 2013 at 1:01 PM, Manuel López-Ibáñez
wrote:
> The following patch implements an option that allows printing the
> diagnostics markers ("error:", "warning:", "note:") in different
> colors (red, magenta, and green, respectively).
>
> I followed the implementation of GNU grep but we
Am 31.03.2013 05:53, schrieb Jerry DeLisle:
The attached patch fixes this PR by removing a spurious call to next_char which
threw off the parsing sequence. In addition, I audited the file for other tests
of EOF and corrected the error handling. This eliminated some wrong error
messages or undef
The following patch implements an option that allows printing the
diagnostics markers ("error:", "warning:", "note:") in different
colors (red, magenta, and green, respectively).
I followed the implementation of GNU grep but we cannot directly use
their code, since they only care about printing to
Trolltech went the way of the Nokia^WDodo, but some mirror sites
still care the tarballs.
Applied, though I don't think those testing instructions are all
that useful any more (while they were a good idea).
Gerald
Index: testing-qt.html
===
richard,
I was able to add everything except for the checking asserts.While I
think that this is a reasonable idea, it is difficult to add that to a
function that is defined in hwint.h because of circular includes. I
could move this another file (though this appears to be the logical
co
On Sun, 31 Mar 2013, Andrew Pinski wrote:
On Sun, Mar 31, 2013 at 6:31 AM, Marc Glisse wrote:
Hello,
this adds constant folding of VEC_COND_EXPR at the tree level by forwarding
to the VEC_PERM_EXPR code (a merge is a special case of a permutation). The
CONSTRUCTOR case may be unreachable for
This updates five Ada-related links, four borken ones to adaic.org
and the libre.adacore.com that redirects now.
Applied.
Gerald
Index: readings.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/readings.html,v
retrieving revision 1.228
di
On Sun, Mar 31, 2013 at 6:31 AM, Marc Glisse wrote:
> Hello,
>
> this adds constant folding of VEC_COND_EXPR at the tree level by forwarding
> to the VEC_PERM_EXPR code (a merge is a special case of a permutation). The
> CONSTRUCTOR case may be unreachable for now (it will probably need an extra
>
On Sun, Mar 31, 2013 at 1:36 AM, Andrew Pinski wrote:
> On Sun, Mar 31, 2013 at 12:10 AM, Teresa Johnson wrote:
>> This patch allows the unused attribute to be used without warning
>> on C++ class members, which are of type FIELD_DECL. This is for
>> compatibility with clang, which allows the att
ok.
thanks,
David
On Sat, Mar 30, 2013 at 11:44 PM, Teresa Johnson wrote:
> This patch restores part of r196176, which was subsequently reverted
> due to issues with the other part of that patch that dealt with
> module info updates. This patch restores the option -femit-function-names
> to emi
On Sun, 31 Mar 2013, minux wrote:
> the link for "CompactRISC CR16CP Architecture" on that page is also broken.
> As TI says document for CR16 is only available to existing customers, i'm
> afraid we have to remove that link.
You mean the fact that the page redirects to the TI home page and
after
Applied. www.swarm.org appears very, hmm, shallow these days, but
I kept it. iRATE does not seem to have a suitable page any more?
Gerald
2013-03-31 Gerald Pfeifer
* done.html: Remove broken link to iRATE.
Adjust link to Swarm.
Index: done.html
=
Applied.
Gerald
Index: readings.html
===
RCS file: /cvs/gcc/wwwdocs/htdocs/readings.html,v
retrieving revision 1.226
diff -u -3 -p -r1.226 readings.html
--- readings.html 30 Mar 2013 18:04:28 - 1.226
+++ readings.html
On Sun, Mar 31, 2013 at 5:26 AM, Paolo Carlini wrote:
> Hi,
>
> just more straightforward uses of existing predicates. I'm going to boot &
> test and commit as obvious.
>
> Thanks,
> Paolo.
>
>
souns good to me.
Marc Glisse writes:
| On Thu, 28 Mar 2013, Gabriel Dos Reis wrote:
|
| > C++ has a much more predictable semantics for inline functions, so we no
| > longer need to define them (especially in header files) with the
| > 'static' specifier. The upshot is that when the compiler fails to
| > inline
Hello,
this adds constant folding of VEC_COND_EXPR at the tree level by
forwarding to the VEC_PERM_EXPR code (a merge is a special case of a
permutation). The CONSTRUCTOR case may be unreachable for now (it will
probably need an extra piece of code in tree-ssa-forwprop.c), but it seems
better
A dozen changes. There are some more, but it's hard to find those
amidst all those changes already made (and the mess that ext/lwg-*
is), so I went ahead and committed what I have.
Jonathan, Benjamin, it would be great could you regenerate the HTML
files in the tree and update onlinedocs/ on gcc.
Hi,
I've committed the attached patch as a followup for the recent
JUMP_TABLE_DATA change. Without this, SH fails to build during
compiling libgcc.
Regards,
kaz
--
2013-03-31 Kaz Kojima
* config/sh/sh.md (casesi_worker_1): Use next_active_insn instead
of next_real_ins
This patch fixes a merge issue (trans-expr.c code was moved to
trans-intrinsic.c on the trunk, and the branch was slightly different).
One teststuite failure turned out to be due to debugging code on the
branch - and I moved to the trunk version.
Tobias
Index: gcc/fortran/ChangeLog.fortran-de
Hello, gentle maintainer.
This is a message from the Translation Project robot.
A revised PO file for textual domain 'gcc' has been submitted
by the German team of translators. The file is available at:
http://translationproject.org/latest/gcc/de.po
(This file, 'gcc-4.8.0.de.po', has just
I have committed (Rev.197282) the attached patch as obvious to the
Fortran-dev branch.
It add the "int version" field to the array constructor and moved "size"
up, renaming it to "elem_len" and changing its type to size_t (which is
effectively the same). This brings the array descriptor a bit
Hi,
just more straightforward uses of existing predicates. I'm going to boot
& test and commit as obvious.
Thanks,
Paolo.
2013-03-31 Paolo Carlini
* decl2.c (collect_candidates_for_java_method_aliases): Use
DECL_CLASS_SCOPE_P.
* name-lookup.c (
On Thu, 28 Mar 2013, Gabriel Dos Reis wrote:
C++ has a much more predictable semantics for inline functions, so we no
longer need to define them (especially in header files) with the
'static' specifier. The upshot is that when the compiler fails to
inline a call in a given translation unit, it
Jordan Ads jordanads2...@gmail.com has added you to the jordanads2029 group
with this message:
The group's name, description, and address will automatically be included in
the email.
Here is the group's description:
Jordan Ads for Advertising And Marketing
Email: jordanads2...@gmail.com
Mo
On Sun, Mar 31, 2013 at 12:10 AM, Teresa Johnson wrote:
> This patch allows the unused attribute to be used without warning
> on C++ class members, which are of type FIELD_DECL. This is for
> compatibility with clang, which allows the attribute to be specified on
> class members and struct fields.
On Sat, Mar 30, 2013 at 3:47 PM, Marc Glisse wrote:
>> OK, modulo a few nits:
>
>
> Thanks, here is a version taking into account all your comments, and which
> still passes bootstrap+testsuite on x86_64-linux-gnu. I am not completely
> sure if there is a point checking !side_effects_p (op1) af
This patch allows the unused attribute to be used without warning
on C++ class members, which are of type FIELD_DECL. This is for
compatibility with clang, which allows the attribute to be specified on
class members and struct fields. It looks like more work would need to
be done to implement the a
33 matches
Mail list logo