Go patch committed: Don't use memcmp for struct == if trailing padding

2012-11-24 Thread Ian Lance Taylor
The Go frontend was using memcmp for struct equality if there was no internal padding but there was trailing padding. This doesn't work when the struct values are on the stack, because there is nothing that explicitly zeroes out the trailing padding. This patch fixes the bug. The patch is larger

Re: [PATCH] Remove unused DELAY_SLOTS_FOR_EPILOGUE target macro

2012-11-24 Thread Steven Bosscher
On Sun, Nov 25, 2012 at 12:54 AM, Hans-Peter Nilsson wrote: > On Sat, 24 Nov 2012, Steven Bosscher wrote: >> Hello, >> >> The DELAY_SLOTS_FOR_EPILOGUE target macro, and the related >> ELIGIBLE_FOR_EPILOGUE_DELAY macro, are unused. The attached patch >> removes them. >> >> OK for trunk? > > Obviousl

Re: [PATCH] Remove unused DELAY_SLOTS_FOR_EPILOGUE target macro

2012-11-24 Thread Hans-Peter Nilsson
On Sat, 24 Nov 2012, Steven Bosscher wrote: > Hello, > > The DELAY_SLOTS_FOR_EPILOGUE target macro, and the related > ELIGIBLE_FOR_EPILOGUE_DELAY macro, are unused. The attached patch > removes them. > > OK for trunk? Obviously; Jeff Law preapproved their removal long ago. (I forgot about it.) Bu

Re: RFA: contribute Synopsis DesignWare ARC port

2012-11-24 Thread Steven Bosscher
On Thu, Nov 22, 2012 at 9:22 PM, Joern Rennecke wrote: (nothing but a ChangeLog :-) Looking at the ARC port a bit, and IMHO it doesn't look very messy... First some general comments: This target apparently wants to play tricks with reload (e.g. arc_preserve_reload_p). IMHO at this point ports th

[RFA 8/8] validate_failures.py: New directives @include, @remove.

2012-11-24 Thread Doug Evans
Hi. This eighth patch adds new directives to manifests: @include, @remove. These are useful when needing to handle a multi-dimensional matrix of test configurations, and not wanting to maintain the otherwise necessary duplication across all of the axes. [@remove should be used sparingly, but I've f

[RFA 7/8] validate_failures.py: New options --manifest_subdir, --manifest_name

2012-11-24 Thread Doug Evans
Hi. This seventh patch adds new options --manifest_subdir, --manifest_name. Useful when using validate_failures.py with a different tool, instead of gcc. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: New options --manifest_subdir, --manife

[RFA 6/8] validate_failures.py: remove pass/fail from GetBuildData

2012-11-24 Thread Doug Evans
Hi. This sixth patch simplifies calls to GetBuildData. It never returns false and always terminates the process with an error message (which is fine by me). Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Remove pass/fail indicator from resu

[RFA 5/8] validate_failures.py: make options a global

2012-11-24 Thread Doug Evans
Hi. This fifth patch makes options a global variable. As validate_failures.py becomes more complex, passing it around everywhere becomes cumbersome with no real gain. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Make options a global variable. -

[RFA 4/8] validate_failures.py: rename --manifest to --manifest_path

2012-11-24 Thread Doug Evans
Hi. This fourth patch renames option --manifest to --manifest_path. I have a later patch that adds a --manifest_name option, making "--manifest" too confusing/ambiguous. Ok to check in? [I still have to update invocations that use --manifest, but that's a separate patch.] 2012-11-24 Doug Evans

[RFA 3/8] validate_failures.py: pass options.results for clean build case

2012-11-24 Thread Doug Evans
Hi. This third patch passes options.results to GetSumFiles when fetching the results for the clean build. It is useful in my use cases, but I'm not sure it's useful for upstream. [An alternative is to add another option to specify the results file(s) for the clean build, but I'm being conservative

[RFA 2/8] validate_failures.py: use target_alias

2012-11-24 Thread Doug Evans
Hi. This second patch uses "target_alias" instead of "target" in the help text, and makes some minor whitespace changes. Ok to check in? 2012-11-24 Doug Evans * testsuite-management/validate_failures.py: Use instead of . Minor whitespace changes. --- validate_failures.py=

[RFA 1/8] validate_failures.py: add TestResult ordinal

2012-11-24 Thread Doug Evans
Hi. This set of 8 patch makes some minor tweaks to validate_failures.py, and provides some new functionality. They are relatively independent, but the patches are intended to be applied in order. This first patch adds an ordinal to TestResult so that the sorting keeps the tests in order of appear

[PATCH] Remove unused DELAY_SLOTS_FOR_EPILOGUE target macro

2012-11-24 Thread Steven Bosscher
Hello, The DELAY_SLOTS_FOR_EPILOGUE target macro, and the related ELIGIBLE_FOR_EPILOGUE_DELAY macro, are unused. The attached patch removes them. OK for trunk? Ciao! Steven dbr_sched_janitor.diff Description: Binary data

libgo patch committed: Fix handling of Unix domain @ addresses

2012-11-24 Thread Ian Lance Taylor
This patch to libgo fixes the handling of Unix domain @ addresses, a GNU/Linux feature. The library was computing the length incorrectly. I actually fixed this in the master library in January 2011, but somehow failed to propagate the fix into the gccgo library. Bootstrapped and ran Go testsuite

Re: [www-docs] Add note to gcc-4.8/changes.html that DWARF4 is now the default.

2012-11-24 Thread Gerald Pfeifer
On Wed, 21 Nov 2012, Mark Wielaard wrote: > As mentioned in some bug reports it should be documented that DWARF4 is > now the default for 4.8 when -g is used (and that one might need a newer > version of debugger/profiling/tracing tools to use it). So I added the > following: I applied the followi

PR 55438: Incorrect use of BIGGEST_ALIGNMENT

2012-11-24 Thread Richard Sandiford
In http://gcc.gnu.org/ml/gcc-patches/2012-11/msg00257.html I said: get_best_mode has various checks to decide what counts as an acceptable bitfield mode. It actually has two copies of them, with slightly different alignment checks: MIN (unit, BIGGEST_ALIGNMENT) > align vs. unit

Re: [C++ Patch] PR 55446

2012-11-24 Thread Jason Merrill
OK. Jason

[patch] Fix x32 multiarch name (x86_64-linux-gnux32)

2012-11-24 Thread Matthias Klose
For x86_64-linux-gnux32 I used 'x32-linux-gnu' as the multiarch name, which is wrong, should be 'x86_64-linux-gnux32' instead (see [1]). Pointed out by Daniel Schepler. Committed as obvious. Matthias [1] http://bugs.debian.org/667037 * gcc/config/i386/t-linux64 (MULTILIB_OSDIRNAMES):

Re: [patch, fortran] Fix PR 55314, rejects-valid regression

2012-11-24 Thread Janus Weil
Hi Thomas, > the attached patch fixes a 4.6/4.7/4.8 rejects-valid regression. > OK for trunk? looks good to me. Thanks for the patch. Ok for trunk and also for the 4.6/4.7 branches ... Cheers, Janus > 2012-11-24 Thomas Koenig > > PR fortran/55314 > * resolve.c (resolve_all

[patch, fortran] Fix PR 55314, rejects-valid regression

2012-11-24 Thread Thomas Koenig
Hello world, the attached patch fixes a 4.6/4.7/4.8 rejects-valid regression. OK for trunk? Thomas 2012-11-24 Thomas Koenig PR fortran/55314 * resolve.c (resolve_allocate_deallocate): Compare all subscripts when deciding if to reject a (de)allocate s

Re: Ping / update: Re: RFA: hookize ADJUST_INSN_LENGTH

2012-11-24 Thread Joern Rennecke
Quoting Joern Rennecke : Quoting Richard Sandiford : 1) As Richard B says, having "locked lengths" with the comment "care must be taken to avoid cycles" doesn't sound like good design. So the question was: without this, why would the length be going up and down "arbitrarily", even thou

Re: Ping / update: Re: RFA: hookize ADJUST_INSN_LENGTH

2012-11-24 Thread Joern Rennecke
Quoting Richard Sandiford : [responding because you kept me on cc:] Joern Rennecke writes: This uses the same interface as my previous patch: http://gcc.gnu.org/ml/gcc-patches/2012-11/msg00473.html , but I refined the algorithm for the get_insn_variants mechanism to work properly with the rew

Re: [tsan] Instrument atomics

2012-11-24 Thread Dmitry Vyukov
On Fri, Nov 23, 2012 at 8:39 PM, Jakub Jelinek wrote: > On Fri, Nov 23, 2012 at 08:10:39PM +0400, Dmitry Vyukov wrote: >> > This patch attempts to instrument __atomic_* and __sync_* builtins. >> > Unfortunately for none of the builtins there is 1:1 mapping to the tsan >> > replacements, tsan uses

Re: [PATCH] Allocate extra 16 bytes for -fsanitize=address

2012-11-24 Thread Hans-Peter Nilsson
On Fri, 23 Nov 2012, H.J. Lu wrote: > On Fri, Nov 23, 2012 at 9:38 AM, Jakub Jelinek wrote: > > On Fri, Nov 23, 2012 at 09:23:37AM -0800, H.J. Lu wrote: > >> This patch allocates extra 16 bytes for -fsanitize=address so that > >> asan won't report read beyond memory buffer. It is used by > >> boot

Re: [Patch,testsuite] ad PR52641: More fixes for not-so-common targets

2012-11-24 Thread Hans-Peter Nilsson
On Fri, 23 Nov 2012, Georg-Johann Lay wrote: > Here are some more fixes for 16-bit int and similar. > * gcc.c-torture/execute/20120919-1.x: New file (int32plus). No, you should be able to use dg-directives in the main file these days. (The .x files are obsolete since a few years, IIRC.) br

Committed: handle negative numbers in gcc-gdb-test.exp

2012-11-24 Thread Hans-Peter Nilsson
Without this, I got weird ERRORs and those Tcl backtraces you come to hate, instead of the expected FAILs. Committed as obvious after running a failing guality test and obvserving the intended change. (Well ok, *adding an explanatory comment* is apparently not obvious, but I'll take that liberty..

Re: Ping / update: Re: RFA: hookize ADJUST_INSN_LENGTH

2012-11-24 Thread Richard Sandiford
[responding because you kept me on cc:] Joern Rennecke writes: > This uses the same interface as my previous patch: > http://gcc.gnu.org/ml/gcc-patches/2012-11/msg00473.html , > but I refined the algorithm for the get_insn_variants > mechanism to work properly with the reworked ARC port - > http:

Re: [tsan] Instrument atomics

2012-11-24 Thread Dmitry Vyukov
On Fri, Nov 23, 2012 at 9:07 PM, Xinliang David Li wrote: > On Fri, Nov 23, 2012 at 8:39 AM, Jakub Jelinek wrote: >> On Fri, Nov 23, 2012 at 08:10:39PM +0400, Dmitry Vyukov wrote: >>> > This patch attempts to instrument __atomic_* and __sync_* builtins. >>> > Unfortunately for none of the builtin

Re: [tsan] Instrument atomics

2012-11-24 Thread Dmitry Vyukov
On Sat, Nov 24, 2012 at 12:11 PM, Jakub Jelinek wrote: > On Fri, Nov 23, 2012 at 08:10:39PM +0400, Dmitry Vyukov wrote: >> I've just committed a patch to llvm with failure_memory_order (r168518). > > Shouldn't it be something like this instead? > > --- tsan_interface_atomic.cc.jj 2012-11-23 17:20:

Re: [tsan] Instrument atomics

2012-11-24 Thread Jakub Jelinek
On Fri, Nov 23, 2012 at 08:10:39PM +0400, Dmitry Vyukov wrote: > I've just committed a patch to llvm with failure_memory_order (r168518). Shouldn't it be something like this instead? --- tsan_interface_atomic.cc.jj 2012-11-23 17:20:49.0 +0100 +++ tsan_interface_atomic.cc2012-11-23 19: