On Thu, Mar 15, 2012 at 01:52, Jerry DeLisle wrote:
> I like the idea behind this patch. I confess, I have not studied the two
> test cases that you are modifying, but the changes seem to stick out with
> too many digits there. Is this really correct?
> When I get another moment, I will look clo
OK.
Jason
On Wed, Mar 14, 2012 at 6:56 PM, Sriraman Tallam wrote:
> Made the following changes:
>
> * -ffunction-sections turned on with -freorder-functions=
> * Change name from cgedge to callgraph.
> * The plugin should not dump final layout to file by default.
>
>
> * cgraphbuild.c (remove_cgraph_
Made the following changes:
* -ffunction-sections turned on with -freorder-functions=
* Change name from cgedge to callgraph.
* The plugin should not dump final layout to file by default.
* cgraphbuild.c (remove_cgraph_callee_edges): Replace
flag_callgraph_profiles_sections with
Add a GC root for the lexer.
This GC root is required to support running the garbage collector
during lexing. This happens when the lexer loads pre-parsed headers.
Loading these headers calls into the middle-end, which may run the
garbage collector.
This was triggering in some of the bigger tran
On 03/08/2012 05:40 PM, Janne Blomqvist wrote:
Hi,
the attached patch implements some improvements for formatted writes
of floating point values. Currently libgfortran uses snprintf() to
fill a buffer with a fixed amount of digits, regardless of the digits
required, and then rounding or zero ext
Detect one class of invalid merges.
When merging two different EXPRs, we are currently merging some trees
that should not be merged. This patch tries to identify one case
where we can certainly detect that a bad merge is about to happen.
This fixes no tests, but diagnoses quite a few bad merges
Oleg Endo wrote:
>>> I'd like to add an SH target testcase which is supposed to check the
>>> usage of the FPUL register when float values are treated as int and vice
>>> versa. Does this make sense?
>>>
>>> Tested against rev 185360 with the usual
>>>
>>> make -k check RUNTESTFLAGS="--target_
On 03/12/2012 05:28 PM, Janne Blomqvist wrote:
Hi,
currently when writing a value of type real or complex using
list-directed output, the G0 edit descriptor, or namelist output,
gfortran chooses the number of significant digits such that a
binary->ascii->binary roundtrip recovers the original va
On Thu, 2012-03-15 at 08:12 +0900, Kaz Kojima wrote:
> Oleg Endo wrote:
> > I'd like to add an SH target testcase which is supposed to check the
> > usage of the FPUL register when float values are treated as int and vice
> > versa. Does this make sense?
> >
> > Tested against rev 185360 with th
Oleg Endo wrote:
> I'd like to add an SH target testcase which is supposed to check the
> usage of the FPUL register when float values are treated as int and vice
> versa. Does this make sense?
>
> Tested against rev 185360 with the usual
>
> make -k check RUNTESTFLAGS="--target_board=sh-sim
>
On Wed, Mar 14, 2012 at 2:57 PM, Gerald Pfeifer wrote:
> On Wed, 14 Mar 2012, Uros Bizjak wrote:
>> I have also added Gerald to CC, to check if everything is OK with
>> added documentation.
>
> Joseph is better with that than I am, but I'll give it a try. :-)
>
> +@item -maddress-mode=long
> +@opi
thanks. This greatly improves the usability of the plugin based
function reordering feature and is in a shape that can be pushed to
trunk.
Regarding the sub-options, cgedge does not seem user friendly. How
about just -freorder-functions=callgraph or
-freorder-function=clustering?
What is the inte
Hi,
I'd like to add an SH target testcase which is supposed to check the
usage of the FPUL register when float values are treated as int and vice
versa. Does this make sense?
Tested against rev 185360 with the usual
make -k check RUNTESTFLAGS="--target_board=sh-sim
\{-m2/-ml,-m2/-mb,-m2a-singl
On Tue, 13 Mar 2012, Richard Guenther wrote:
> Goes back to rev. 5880 by rms, at which time tsystem.h did not exist.
>
> I'm going to remove those two lines, bootstrap & test it and commit as
> obvious.
Thanks, Richard. I could not do the tests you suggested yesterday
before seeing this other ma
On Wed, 14 Mar 2012, Uros Bizjak wrote:
> I have also added Gerald to CC, to check if everything is OK with
> added documentation.
Joseph is better with that than I am, but I'll give it a try. :-)
+@item -maddress-mode=long
+@opindex maddress-mode=long
+Generate code for long address mode. It is
On Wed, Mar 14, 2012 at 1:56 PM, Sriraman Tallam wrote:
> This patch overloads GCC option -freorder-functions with -freoder-functions=*
> which will invoke the linker plugin libfunction_reordering_plugin.so. For
> now, the only accepted option is -freoder-functions=cgedge, where the
> functions
This patch overloads GCC option -freorder-functions with -freoder-functions=*
which will invoke the linker plugin libfunction_reordering_plugin.so. For now,
the only accepted option is -freoder-functions=cgedge, where the functions
which are connected by hot callgraph edges are placed closer. W
Hi,
Manuel provided this patchlet improving his template instantiation notes
work to use a template_backtrace_limit parameter, as requested in
c++/44783. I booted and tested it on x86_64-linux.
Is it Ok for mainline? Anything else we want to do here?
Thanks,
Paolo.
///
/c-fa
Hello, gentle maintainer.
This is a message from the Translation Project robot.
A revised PO file for textual domain 'gcc' has been submitted
by the Swedish team of translators. The file is available at:
http://translationproject.org/latest/gcc/sv.po
(This file, 'gcc-4.7-b20120128.sv.po',
On Mar 14, 2012, at 10:21 AM, Doug Evans wrote:
> The results of running the testsuite in parallel should match the
> results when run serially. This patch adds KFAIL counts so that happens.
> [There's still a nit that the order of the results don't precisely match,
> but that's a separate issue.]
On Wed, 14 Mar 2012, Uros Bizjak wrote:
> The patch is technically OK for mainline, Joseph - can you please
> review option stuff?
The option changes look fine to me.
--
Joseph S. Myers
jos...@codesourcery.com
On 2012/03/14 18:15:25, Cary wrote:
This is for the google/gcc-4_6 branch only.
Fix output_indirect_string so that it does not output strings that
have already been written to the .debug_str.dwo section.
This is a backport of part of an unrelated change from upstream 4.7:
http://gcc.gnu.or
On Mon, Mar 12, 2012 at 6:48 PM, H.J. Lu wrote:
> Trunk can now use SImode or DImode for Pmode with -mx32. Pmode == SImode
> will avoid many conversions from SImode to DImode:
>
> http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50797
>
> It will use 0x67 address size prefix instead. This patch adds
This is for the google/gcc-4_6 branch only.
Fix output_indirect_string so that it does not output strings that
have already been written to the .debug_str.dwo section.
This is a backport of part of an unrelated change from upstream 4.7:
http://gcc.gnu.org/ml/gcc-cvs/2011-05/msg00130.html
Tested
On Tue, Mar 13, 2012 at 9:42 PM, Diego Novillo wrote:
> On 08/03/12 20:47 , Sandeep Soni wrote:
>
>> +/* Splits the token TOKEN into two tokens FIRST_TOKEN and SECOND_TOKEN.
>> + Note that the split should work only if the type of the TOKEN is
>> + either CPP_RSHIFT or CPP_LSHIFT which gets sp
"Joseph S. Myers" writes:
> On Mon, 5 Mar 2012, Rainer Orth wrote:
>
>> The only two users of MIPS_DEBUGGING_INFO are on their way out: I've
>> just submitted a patch to remove the OpenBSD/MIPS configuration, and
>> IRIX removal will follow soon. There seems to be no point in retaining
>> what s
Richard Henderson writes:
> On 03/14/12 09:09, Rainer Orth wrote:
>
> Nearly ok.
>
>> + targetm.asm_file_start_file_directive = 0;
>
> This is default and may be deleted.
Or would be if alpha.c didn't override the default.
This is what I actually committed after retesting.
Rainer
20
Ian Lance Taylor writes:
>> Unfortunately, this patch introduced several go and/or libgo testsuite
>> failures on both Solaris/SPARC and x86 on the 4.7 branch while the
>> results were clean before. I've filed PR go/52583 for this, but not yet
>> investigated in detail.
>
> Hmmm, the patch just
OK.
Jason
Rainer Orth writes:
> Ian Lance Taylor writes:
>
>> I would like to update the Go support on the 4.7 branch. As I've
>> mentioned before, Go is working toward a stable Go 1 release. That
>> release is not complete, but it is quite close. The 4.7 branch was made
>> at a slightly unstable point
Hi!
This patch adds ASSERT_EXPRs derived from
tmp_N = var_M & cst2;
if (tmp_N cmp val)
where cst2 and val are constants. Bootstrapped/regtested
on x86_64-linux and i686-linux, ok for trunk?
2012-03-14 Jakub Jelinek
PR tree-optimization/52267
* tree-vrp.c (masked_increment
The results of running the testsuite in parallel should match the
results when run serially. This patch adds KFAIL counts so that happens.
[There's still a nit that the order of the results don't precisely match,
but that's a separate issue.]
I will check this into the gdb tree if there are no ob
On 03/14/12 09:09, Rainer Orth wrote:
Nearly ok.
> + targetm.asm_file_start_file_directive = 0;
This is default and may be deleted.
r~
"Joseph S. Myers" writes:
> On Wed, 14 Mar 2012, Rainer Orth wrote:
>
>> Jason Merrill writes:
>>
>> > On 03/12/2012 01:41 PM, Joseph S. Myers wrote:
>> >> As a *target macro* it makes sense to remove it - reomve it from
>> >> defaults.h, make it purely internal to dwarf2out.c. But I think it
On Wed, 14 Mar 2012, Rainer Orth wrote:
> Jason Merrill writes:
>
> > On 03/12/2012 01:41 PM, Joseph S. Myers wrote:
> >> As a *target macro* it makes sense to remove it - reomve it from
> >> defaults.h, make it purely internal to dwarf2out.c. But I think it makes
> >> sense to have it inside d
Paolo Bonzini writes:
> Yes, the # comment is actually part of the macro argument. If you want
> to write a "real" comment (i.e. at the m4 rather than shell level) use
> "dnl" instead of "#".
Actually both are part of the macro argument and act like comment
introducers at the m4 level, but they
On Wed, 14 Mar 2012, Tristan Gingold wrote:
> Hi,
>
> it happens that some system headers on VMS have #pragma between parameters.
> This is spotted by building the Ada runtime.
>
> This patch simply handles them.
>
> Manually tested by building for ia64-hp-openvms.
> No regressions for c on x
Hi,
On Mon, Mar 12, 2012 at 03:09:04PM +0100, Martin Jambor wrote:
> Hi,
>
> this patch is very similar to the one I posted before
> (http://gcc.gnu.org/ml/gcc-patches/2012-02/msg01377.html) except that
> it is now adjusted to sit on top of the new one before this and does
> not ignore complex nu
On Mar 14, 2012, at 5:08 PM, Richard Guenther wrote:
> On Wed, 14 Mar 2012, Tristan Gingold wrote:
>
>> Hi,
>>
>> the code to call expand_main_function currently only checks DECL_NAME. This
>> leads
>> to a hack in ada/gcc-interface/utils.c to handle the gnatbind generated file
>> that could
On Fri, Mar 2, 2012 at 10:00 AM, H.J. Lu wrote:
> Hi,
>
> This patch adds --with-abi= support to x86_64-*-* to configure GCC with
>
> --with-abi=x32
> --with-abi=mx32
> --with-multilib-list=mx32
>
> to set the default ABI to x32. In i386 backend, ISA_64BIT is used to
> generate i386 code or x86-6
Richard Henderson writes:
> On 03/12/12 09:22, Rainer Orth wrote:
>> There are only two issues:
>>
>> * In alpha.c (alpha_option_override), it's unclear if the optimize > 0
>> test can be removed completely.
>
> Yeah, I guess leave that for now.
>
>> * During testing, I ran into this error:
>>
On Wed, 14 Mar 2012, Tristan Gingold wrote:
> Hi,
>
> the code to call expand_main_function currently only checks DECL_NAME. This
> leads
> to a hack in ada/gcc-interface/utils.c to handle the gnatbind generated file
> that could
> declare:
>
> package ada_main is
> …
>function my_main
>
Jason Merrill writes:
> On 03/12/2012 01:41 PM, Joseph S. Myers wrote:
>> As a *target macro* it makes sense to remove it - reomve it from
>> defaults.h, make it purely internal to dwarf2out.c. But I think it makes
>> sense to have it inside dwarf2out.c
>
> Agreed.
Here's the revised patch. Bo
Hi,
the code to call expand_main_function currently only checks DECL_NAME. This
leads
to a hack in ada/gcc-interface/utils.c to handle the gnatbind generated file
that could
declare:
package ada_main is
…
function my_main
(argc : Integer;
argv : System.Address;
envp : Syste
Il 14/03/2012 16:37, Ramana Radhakrishnan ha scritto:
> Empirically I spotted this odd behaviour with
> gcc_GAS_CHECK_FEATURE and comments - Attached are the 2 alternate
> patches that I tried and the difference in the configure scripts
> themselves . I am no m4 expert but it does look like the m4
Hi,
it happens that some system headers on VMS have #pragma between parameters.
This is spotted by building the Ada runtime.
This patch simply handles them.
Manually tested by building for ia64-hp-openvms.
No regressions for c on x86_64-darwin.
Ok for trunk ?
Tristan.
2012-03-14 Tristan Gi
Hi,
the dwarf3 DW_OP_call_frame_cfa implicitly refers to .debug_frame section. But
if we aren't
emitting dwarf unwinding info, it isn't anymore well defined.
There is one target that doesn't emit dwarf unwind info: ia64. And gdb is not
able to deal
with DW_OP_call_frame_cfa on ia64, thus brea
On 12 March 2012 18:10, DJ Delorie wrote:
>
> Looks OK to me.
I was about to commit this into my svn checkout and then realized the
patch p4 didn't have the changes to configure - So I regenerated it
again and then began a journey into the depths of m4 and autoconf for
a bit before I gave up. Emp
I noticed when trying to fix PR52584 that vector lowering always
creates unsigned vector types. The following fixes that, also
getting rid of the weird use of a langhook.
Bootstrapped and tested on x86_64-unknown-linux-gnu.
Richard.
2012-03-14 Richard Guenther
PR middle-end/52584
Hi!
I've committed the following workaround for PR52582 to 4.7 branch (acked
on IRC by David and Richard) after bootstrapping/regtesting it on
powerpc64-linux (--with-cpu=default32 as well as -m64 defaulted build),
and for trunk committed just the testcase. Richard committed some fix to
the trunk
Hi,
highly misleading. Committed to mainline (suitable for 4.7.1 too of course)
Thanks,
Paolo.
///
2012-03-14 Paolo Carlini
* include/bits/forward_list.h: Fix comments.
Index: include/bits/forward_list.h
===
On Wed, 14 Mar 2012, Richard Guenther wrote:
>
> This fixes PR52571, we should not align DECL_COMMON variables as
> they might be pre-empted by a definition with lower alignment.
>
> At LTO/WPA level we might recover from missed optimizations by
> promoting DECL_COMMON variables to non-common.
I suppose after a decade of being gone, it's time to stop referencing it.
OK for *ALL* active branches.
On Wed, Mar 14, 2012 at 2:36 AM, Tristan Gingold wrote:
> Hi,
>
> fixinc.sh is not anymore in gcc/ directory. So I propose to adjust
> fixincludes/README.
>
> Ok for trunk ?
>
> Tristan.
>
>
This fixes part of PR52582, we need to create a cgraph node when
folding from an initializer.
Bootstrapped on x86_64-unknown-linux-gnu, testing in progress.
Richard.
2012-03-14 Richard Guenther
PR middle-end/52582
* gimple-fold.c (canonicalize_constructor_val): Make sure
This fixes PR52571, we should not align DECL_COMMON variables as
they might be pre-empted by a definition with lower alignment.
At LTO/WPA level we might recover from missed optimizations by
promoting DECL_COMMON variables to non-common. Not sure if we
do that already.
Bootstrapped on x86_64-un
Ian Lance Taylor writes:
> I would like to update the Go support on the 4.7 branch. As I've
> mentioned before, Go is working toward a stable Go 1 release. That
> release is not complete, but it is quite close. The 4.7 branch was made
> at a slightly unstable point in the process. I've update
Hi,
> On Tue, Mar 13, 2012 at 7:31 PM, Andrew Pinski wrote:
> > Ping? Rebootstrapped on x86_64-linux-gnu with no regressions.
>
> Zdenek, can you have a look here? I think the patch is reasonable, but
> you should have a better idea ;)
I do not understand the patch very well. In the comment
On Tue, Mar 13, 2012 at 7:31 PM, Andrew Pinski wrote:
> Ping? Rebootstrapped on x86_64-linux-gnu with no regressions.
Zdenek, can you have a look here? I think the patch is reasonable, but
you should have a better idea ;)
Thanks,
Richard.
> Thanks,
> Andrew Pinski
>
> On Sat, Jan 21, 2012 at
Hi,
fixinc.sh is not anymore in gcc/ directory. So I propose to adjust
fixincludes/README.
Ok for trunk ?
Tristan.
fixincludes/
2012-03-14 Tristan Gingold
* README (EXAMPLES OF FIXES): Update.
diff --git a/fixincludes/README b/fixincludes/README
index 07a3964..c7144a0 100644
---
On Wed, Mar 14, 2012 at 12:13 AM, H.J. Lu wrote:
>> Similar to tls_symbolic_operand and tls_modbase_operand, we are not
>> interested in the mode of the operand in the predicate.
>>
>> 2012-03-13 Uros Bizjak
>>
>> * config/i386/predicates.md (constant_call_address_operand): Declare
>>
On Mar 13, 2012, at 9:57 PM, Gary Funck wrote:
> On 03/06/12 14:09:23, Tristan Gingold wrote:
>> The patch is simple: the C front-end will now calls
>> c_build_pointer_type (instead of build_pointer_type), which in
>> turn calls build_pointer_type_for_mode using the right mode.
> [...]
>
> Joini
62 matches
Mail list logo