Re: Please support Coroutines TS in C++

2017-08-31 Thread Ramón García
(repeated, forgot to reply to mailing list) Xi Ruoyao misses completely the point! The amount of error prone boilerplate code, that the programmer would have to write, is huge. See examples in the excellent presentation "C++ coroutines: a negative overhead abstraction" https://www.slideshare.net/

can we rename vec<>.safe_push() to vec<>.push()?

2017-08-31 Thread Aldy Hernandez
I understand the need for .quick_push(), when we know the size of the allocated elements before hand, but do we really need to call the common variant safe_push? Can't we just call it push()? Or is there some magic C++ rule/idiom that prohibits us from doing this? I volunteer to provide a patch

Re: can we rename vec<>.safe_push() to vec<>.push()?

2017-08-31 Thread Richard Biener
On Thu, Aug 31, 2017 at 1:31 PM, Aldy Hernandez wrote: > I understand the need for .quick_push(), when we know the size of the > allocated elements before hand, but do we really need to call the > common variant safe_push? Can't we just call it push()? > > Or is there some magic C++ rule/idiom th

Re: can we rename vec<>.safe_push() to vec<>.push()?

2017-08-31 Thread Aldy Hernandez
So ok to default to a lazy one, or are suggesting we leave things as they are? Aldy On Thu, Aug 31, 2017 at 7:38 AM, Richard Biener wrote: > On Thu, Aug 31, 2017 at 1:31 PM, Aldy Hernandez wrote: >> I understand the need for .quick_push(), when we know the size of the >> allocated elements

Re: can we rename vec<>.safe_push() to vec<>.push()?

2017-08-31 Thread Richard Biener
On Thu, Aug 31, 2017 at 1:41 PM, Aldy Hernandez wrote: > So ok to default to a lazy one, or are suggesting we leave things > as they are? Either leave as-is or default to the lazy one. Richard. > Aldy > > On Thu, Aug 31, 2017 at 7:38 AM, Richard Biener > wrote: >> On Thu, Aug 31, 2017 at 1

Re: can we rename vec<>.safe_push() to vec<>.push()?

2017-08-31 Thread Nathan Sidwell
On 08/31/2017 07:49 AM, Richard Biener wrote: On Thu, Aug 31, 2017 at 1:41 PM, Aldy Hernandez wrote: So ok to default to a lazy one, or are suggesting we leave things as they are? Either leave as-is or default to the lazy one. Agreed. -- Nathan Sidwell

Re: gcc torture test pr52286.c

2017-08-31 Thread Georg-Johann Lay
Paul S schrieb: I've ported gcc to a 16 bit CPU and have all torture tests passing bar one, pr52286.c The offending lines of code are long a, b = 0; asm ("" : "=r" (a) : "0" (0)); which should cause zero to be assigned to the "a" SI sized variable. Inspecting the generated code revealed t

Re: can we rename vec<>.safe_push() to vec<>.push()?

2017-08-31 Thread Richard Sandiford
Richard Biener writes: > On Thu, Aug 31, 2017 at 1:41 PM, Aldy Hernandez wrote: >> So ok to default to a lazy one, or are suggesting we leave things >> as they are? > > Either leave as-is or default to the lazy one. FWIW, I think we should leave it. The risk isn't just laziness: it could ma

gcc-7-20170831 is now available

2017-08-31 Thread gccadmin
Snapshot gcc-7-20170831 is now available on ftp://gcc.gnu.org/pub/gcc/snapshots/7-20170831/ and on various mirrors, see http://gcc.gnu.org/mirrors.html for details. This snapshot has been generated from the GCC 7 SVN branch with the following options: svn://gcc.gnu.org/svn/gcc/branches/gcc-7