Hi,
Hongyu Wang via Gcc wrote:
I've adjust the testcase and now it only contains constant offset, since
with -fPIC the mov target address does not contain any symbol in the
assembler.
Could you help to check the attached changes on darwin and see if they
all get passed?
LGTM.
OK from a
Hi,
I've adjust the testcase and now it only contains constant offset, since
with -fPIC the mov target address does not contain any symbol in the assembler.
Could you help to check the attached changes on darwin and see if they
all get passed?
(I still can not build darwin target currently)
Tha
Hi.
Hongyu Wang wrote:
3. are you intending to update the tests?
Yes, so could you tell me what does missing “_” means? I have some
trouble building darwin target for now.
Darwin uses a USER_LABEL_PREFIX of ‘_’ (there are a small number of targets
that do this).
So public symbols begin wi
Hi,
> 1. might I suggest using the {} form of quoting these regexes - it makes
> them much more readable.
Sure.
> 2. I think there are some syntax errors in the regexes for these tests
> (because it’s very hard to check them when using the “” quotes).
>
> "(?:movdqu|movups)\[ \\t\]+\[^\n\]
Hi,
Hongyu Wang via Gcc wrote:
Maybe those scan-asm regexp are too strict and should be relaxed a
bit.
I agree with this, since with -fPIC the code produced would be different,
just use symbol + constant may be too strict.
I think the scan-assembler could be reduced to
/* { dg-final { scan-
> Maybe those scan-asm regexp are too strict and should be relaxed a
> bit.
I agree with this, since with -fPIC the code produced would be different,
just use symbol + constant may be too strict.
I think the scan-assembler could be reduced to
/* { dg-final { scan-assembler "(?:movdqu|movups)\[
\\
On Sun, Nov 1, 2020 at 2:04 PM Iain Sandoe wrote:
>
> Hi Uros,
>
> I was looking into the test fails for the new keylocker-* testcases.
>
> Many are because of missing “_” (which seems to happen more often than
> not). These I can fix trivially.
>
> But some are because we have:
>
> name+constant
Hi Uros,
I was looking into the test fails for the new keylocker-* testcases.
Many are because of missing “_” (which seems to happen more often than
not). These I can fix trivially.
But some are because we have:
name+constant(%rip) being emitted on Linux
and
constant+name(%rip) being emi