Hi,
For readability (and correctness) I'm interested in rewriting a bunch of:
(define_insn_reservation "insn1" 0 (eq_attr "attr1" "val1,val2"))
into something like:
(define attr "consattr1" "val1,val2"
(const (cond [
(eq_attr "attr1" "val1") (const_string "cvaly")
(eq_attr "
On Mon, Dec 12, 2011 at 3:20 PM, Jonathan Wakely wrote:
> On 12 December 2011 21:13, Quentin Neill wrote:
>>
>> I think an improvement could be made in automated downloading of GCC
>> and dependencies (I looked in the wiki and the document and didn't see
>>
On Tue, Dec 6, 2011 at 2:49 PM, Diego Novillo wrote:
> At the last developer's meeting in London, Joseph and I agreed to work
> on an architectural definition for GCC. We now have something that,
> while incomplete, should be enough to discuss.
>
> Our main intent is to define new conventions and
I wrote http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49411, and I have
some general questions:
1. I left it as normal P3, is that appropriate for an obvious ICE like this?
2. Should I open another bug for 4.6?
3. What's the best/right way to specify testcases in GCC bugs?
And the specific question
On Thu, Feb 10, 2011 at 3:13 AM, Jonathan Wakely wrote:
> On 10 February 2011 05:18, Quentin Neill wrote:
>> On Wed, Feb 9, 2011 at 2:42 AM, Jonathan Wakely
>> wrote:
>>> On 9 February 2011 08:34, Sebastian Pop wrote:
>>>>
>>>> For example x264
On Wed, Feb 9, 2011 at 2:42 AM, Jonathan Wakely wrote:
> On 9 February 2011 08:34, Sebastian Pop wrote:
>>
>> For example x264 defines CFLAGS="-O4 -ffast-math $CFLAGS", and so
>> building this benchmark with CFLAGS="-O2" would have no effect.
>
> Why not?
>
> Ignoring the fact -O3 is the highest l
On Mon, Jun 14, 2010 at 11:05 AM, Manuel López-Ibáñez
wrote:
> On 10 June 2010 22:05, Quentin Neill wrote:
>> I have a python script which crawls, caches, and parses the gcc-cvs
>> (and binutils-cvs) email archive pages. I wrote it to help another
>> script that correlates
roducing such assembler functionality and want to avoid if
possible, instead leveraging the existing binutils infrastructure.
--
Quentin Neill (with some input from Reza Yazdani)
On Fri, Jun 11, 2010 at 10:58 AM, Daniel Jacobowitz
wrote:
> On Thu, Jun 10, 2010 at 09:48:24PM -0500, Quentin Neill wrote:
[snip]
>> Does this qualify as a form of what you are suggesting? Because this
>> is exactly what is being proposed:
>>
>> .balign 8
e output by the compiler", not "the
output produced by the assembler".
Does this qualify as a form of what you are suggesting? Because this
is exactly what is being proposed:
.balign 8 # start window
insn op, op # 67 67 XX YY ZZ - padded with 2 prefixes to make 8
insn2 op, op# AA BB CC
.padalign 8 # window boundary
insn4 op
. . .
--
Quentin Neill
On Thu, Jun 10, 2010 at 3:03 PM, Jeff Law wrote:
> On 06/10/10 13:52, H.J. Lu wrote:
>> On Thu, Jun 10, 2010 at 11:05 AM, Quentin Neill
>> wrote:
>>> Cross-posting Reza's call for feedback to the binutils list since it
>>> is relevant - s ee the last few
On Thu, Jun 10, 2010 at 4:08 PM, H.J. Lu wrote:
> On Thu, Jun 10, 2010 at 1:59 PM, Quentin Neill
> wrote:
>> On Thu, Jun 10, 2010 at 3:03 PM, Jeff Law wrote:
>>> On 06/10/10 13:52, H.J. Lu wrote:
>>>> On Thu, Jun 10, 2010 at 11:05 AM, Quentin Neill
>>>
odified to scrape most of
the information above into a single monthly report.
Any interest?
--
Quentin Neill
Cross-posting Reza's call for feedback to the binutils list since it
is relevant -
see the last few paragraphs regarding how to "solve the alignment problem".
Original thread: http://gcc.gnu.org/ml/gcc/2010-06/threads.html#00402
Not sure if followups should occur on one list or b
On Tue, May 11, 2010 at 6:39 AM, Marc Glisse
wrote:
> On Tue, 11 May 2010, Jakub Jelinek wrote:
>
>> And you can use -Wl,-O1 (pass -O1 to the linker) to let the linker
>> determine optimal size of the hash table (minimum number of collisions
>> for reasonably sized section).
>
> Was it considered
On Tue, Feb 9, 2010 at 5:02 PM, Richard Sandiford
wrote:
> Daniel Jacobowitz writes:
>> On Wed, Feb 03, 2010 at 06:23:19AM -0800, Ian Lance Taylor wrote:
>>> fanqifei writes:
>>>
>>> > According to the internal manual, insn length attribute can be used to
>>> > to calculate the length of emitted
16 matches
Mail list logo