Hi, all
I was reading 'RTEMS file system design guide' document and found there are
many figures missing. (for example figure 3 and many.)
I see "figure of ... goes here " texts in places for the figures.
I tried generating the document from the source under doc directory, but it's
the same and
---
cpukit/score/include/rtems/score/interr.h | 13 +
1 file changed, 13 insertions(+)
diff --git a/cpukit/score/include/rtems/score/interr.h
b/cpukit/score/include/rtems/score/interr.h
index 2100c13..e0cedaf 100644
--- a/cpukit/score/include/rtems/score/interr.h
+++ b/cpukit/score/i
---
cpukit/sapi/Makefile.am| 1 +
cpukit/sapi/include/rtems/test.h | 109 ++
cpukit/sapi/src/testparallel.c | 151 +++
testsuites/smptests/smpatomic01/init.c | 264 ++---
4 files changed, 375 insertions(+), 150
OK to apply if it looks correct in generated doxygen. (Some
instructions are buried in https://devel.rtems.org/wiki/GCI/Projects
look for do_doxygen)
Gedare
On Wed, Mar 4, 2015 at 7:07 AM, Alexander Krutwig
wrote:
> ---
> cpukit/score/include/rtems/score/interr.h | 13 +
> 1 file ch
It seems that these changes to test.h and the new testparallel.c
belong in the testsuites/smptests area, perhaps in a shared/
subdirectory. Certainly I don't see why testparallel.c is in sapi. (I
don't recall why we have testing framework in the sapi though...)
On Wed, Mar 4, 2015 at 7:33 AM, Alex
On 04/03/15 15:17, Gedare Bloom wrote:
It seems that these changes to test.h and the new testparallel.c
belong in the testsuites/smptests area, perhaps in a shared/
subdirectory. Certainly I don't see why testparallel.c is in sapi. (I
don't recall why we have testing framework in the sapi though
Deliver the POSIX signals after the thread state was updated to avoid
race-conditions on SMP configurations.
Update #2273.
---
cpukit/posix/src/psignalunblockthread.c | 22 +++
cpukit/rtems/src/signalsend.c | 1 -
cpukit/score/include/rtems/score/threadimpl.h | 54 +
Previously, the _Thread_Heir was updated unconditionally in case a new
heir was determined. The _Thread_Dispatch_necessary was only updated in
case the executing thread was preemptible or an internal thread was
unblocked. Change this to update the _Thread_Heir and
_Thread_Dispatch_necessary only
Use the ISR lock of the thread object to protect the event state and
use the Giant lock only for the blocking operations.
Update #2273.
---
cpukit/rtems/Makefile.am | 1 -
cpukit/rtems/include/rtems/rtems/eventimpl.h | 49 +++---
cpukit/rtems/src/event.c
This enables per-object SMP locks on SMP configurations and is the first
step to support fine-grained locking. On uni-processor configuration
there will be no overhead. The _Objects_Acquire() is intended to
replace _Objects_Get_isr_disable().
Update #2273.
---
cpukit/score/Makefile.am
Update #2273.
---
cpukit/score/include/rtems/score/threaddispatch.h | 104 +-
1 file changed, 82 insertions(+), 22 deletions(-)
diff --git a/cpukit/score/include/rtems/score/threaddispatch.h
b/cpukit/score/include/rtems/score/threaddispatch.h
index 80de19d..037cf27 100644
---
Update #2273.
---
cpukit/score/include/rtems/score/thread.h | 30 +
cpukit/score/include/rtems/score/threadimpl.h | 161 ++
cpukit/score/src/threadinitialize.c | 2 +
3 files changed, 193 insertions(+)
diff --git a/cpukit/score/include/rtems/score/thre
The _Thread_Dispatch() function is quite complex and the time to set up
and tear down the stack frame is significant. Split this function into
two parts. The complex part is now in _Thread_Do_dispatch(). Call
_Thread_Do_dispatch() in _Thread_Enable_dispatch() only if necessary.
This increases th
Update #2273.
---
cpukit/score/include/rtems/score/threadimpl.h | 18 ++
cpukit/score/src/threadget.c | 85 +++
2 files changed, 79 insertions(+), 24 deletions(-)
diff --git a/cpukit/score/include/rtems/score/threadimpl.h
b/cpukit/score/include/rtems/
This patch set adds basic support for fine-grained locking on a per-object
scope. The Giant lock is only used for the blocking operations (thread state,
scheduler, watchdog). It uses the RTEMS events do demonstrate the basic
functionality. The basic idea is to store the intermediate thread block
Hello,
why is CPU_INLINE_ENABLE_DISPATCH defined to TRUE on SPARC? You can say
a lot about SPARC, but not that function calls are slow. Is it not
better to reduce the code size and don't inline the
_Thread_Enable_dispatch()?
--
Sebastian Huber, embedded brains GmbH
Address : Dornierstr. 4,
---
cpukit/score/cpu/arm/rtems/score/cpu.h | 2 --
cpukit/score/cpu/avr/rtems/score/cpu.h | 24
cpukit/score/cpu/bfin/rtems/score/cpu.h| 23 ---
cpukit/score/cpu/h8300/rtems/score/cpu.h | 24
cpukit/score/cpu/i386
OK.
On Wed, Mar 4, 2015 at 9:22 AM, Sebastian Huber
wrote:
>
> On 04/03/15 15:17, Gedare Bloom wrote:
>>
>> It seems that these changes to test.h and the new testparallel.c
>> belong in the testsuites/smptests area, perhaps in a shared/
>> subdirectory. Certainly I don't see why testparallel.c is
Would it at least make sense to add a subdirectory with a different name
in cpukit?
You could add libmisc/test_support and only have to add a few lines to
libmisc/Makefile.am. That would contain this stuff better.
On 3/4/2015 9:41 AM, Gedare Bloom wrote:
> OK.
>
> On Wed, Mar 4, 2015 at 9:22 AM,
On 3/4/2015 9:07 AM, Sebastian Huber wrote:
> Previously, the _Thread_Heir was updated unconditionally in case a new
> heir was determined. The _Thread_Dispatch_necessary was only updated in
> case the executing thread was preemptible or an internal thread was
> unblocked. Change this to update
On Wed, Mar 4, 2015 at 10:42 AM, Joel Sherrill
wrote:
>
>
> On 3/4/2015 9:07 AM, Sebastian Huber wrote:
>> Previously, the _Thread_Heir was updated unconditionally in case a new
>> heir was determined. The _Thread_Dispatch_necessary was only updated in
>> case the executing thread was preemptible
Because it has been that way since 1999?
The only reason I can think would be to curtail register window
side-effects if there are any. I doubt there would be.
Gedare
On Wed, Mar 4, 2015 at 10:10 AM, Sebastian Huber
wrote:
> Hello,
>
> why is CPU_INLINE_ENABLE_DISPATCH defined to TRUE on SPARC?
On 3/4/2015 9:52 AM, Gedare Bloom wrote:
Because it has been that way since 1999?
The only reason I can think would be to curtail register window
side-effects if there are any. I doubt there would be.
I doubt there would be any side-effects either. It can't add to the
maximum stack depth and it
On 04/03/15 16:43, Joel Sherrill wrote:
Would it at least make sense to add a subdirectory with a different name
in cpukit?
You could add libmisc/test_support and only have to add a few lines to
libmisc/Makefile.am. That would contain this stuff better.
Ok, good idea. We move the stuff to this
On 04/03/15 16:44, Gedare Bloom wrote:
On Wed, Mar 4, 2015 at 10:42 AM, Joel Sherrill
wrote:
On 3/4/2015 9:07 AM, Sebastian Huber wrote:
Previously, the _Thread_Heir was updated unconditionally in case a new
heir was determined. The _Thread_Dispatch_necessary was only updated in
case the exe
Joel, I think we're talking about removing inlining here for SPARC. -Gedare
On Wed, Mar 4, 2015 at 11:07 AM, Joel Sherrill
wrote:
> On 3/4/2015 9:52 AM, Gedare Bloom wrote:
>>
>> Because it has been that way since 1999?
>>
>> The only reason I can think would be to curtail register window
>> side
On 3/4/2015 1:01 PM, Gedare Bloom wrote:
> Joel, I think we're talking about removing inlining here for SPARC. -Gedare
Agreed. And I thought the first paragraph said it was OK on the SPARC.
The SPARC does have fast calls and we should not trigger a register
window overflow since we likely called
On 3/4/2015 12:55 PM, Sebastian Huber wrote:
> On 04/03/15 16:44, Gedare Bloom wrote:
>> On Wed, Mar 4, 2015 at 10:42 AM, Joel Sherrill
>> wrote:
>>> On 3/4/2015 9:07 AM, Sebastian Huber wrote:
Previously, the _Thread_Heir was updated unconditionally in case a new
heir was determined.
Ticket #1394 [1] has been fixed in newlib since 2013. A simple
workaround patch is also available on the ticket and can be applied to
the 4.10 toolchain if we need to fix this for the 4.10 release branch.
Does anyone want this ticket fixed for 4.10?
Gedare
[1] https://devel.rtems.org/ticket/1394
We have ticket #2265 requesting to deprecate notepads. It was also
suggested we deprecate per-task variables. Do we have an established
procedure for how to deprecate an API? Does anyone have any
objections?
Gedare
___
devel mailing list
devel@rtems.org
4e3d9a4d6c76fba8e31138d503f736405dafc213 broke or1k, cpuatomic.h has to
be added to all architectures.
---
cpukit/score/cpu/or1k/Makefile.am | 3 +--
cpukit/score/cpu/or1k/preinstall.am | 4
cpukit/score/cpu/or1k/rtems/score/cpuatomic.h | 14 ++
3 files cha
Hi ,
I am a chinese student learning RTEMS ,I meet an error when I compile the
RTEMS source code under the cygwin .
bellowed is the detail of the problem
error
and
I think there also has something wrong in this place
I hope you can fixed this problem for me and I will be very grateful,thank y
Hi ,
I meet error257 when I compile the RTEMS source code.I want to know the error
type and how to handle this error
best regards ,
Asher
___
devel mailing list
devel@rtems.org
http://lists.rtems.org/mailman/listinfo/devel
You are going to have to provide more details. Host, target, configure command,
cut and paste of the error with some context around it.
On March 4, 2015 9:09:15 PM CST, zhengyazhou wrote:
>Hi ,
>I meet error257 when I compile the RTEMS source code.I want to know the
>error type and how to hand
Thank you for answering me,here is the details
Host : MS windows and I use Cygwin for RTEMS development
device : ARM based target
I installed the Prebuild Toolset on Cygwin,then uncompress the RTEMS source
code in the file C/Cygwin64/
then execute the following command in the Cygwi
On 04/03/15 20:24, Joel Sherrill wrote:
This same pattern is in other places so please do it globally across
>>>this patch.
>>>I think I spotted a total of four places.
>>>
>>>Also since this indicates that the thread is at the pseudo-interrupt
>>>priority,
>>>maybe a macro/static inline with a
---
cpukit/rtems/src/timerserver.c | 2 +-
cpukit/score/include/rtems/score/priority.h | 7 +++
cpukit/score/src/mpci.c | 2 +-
3 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/cpukit/rtems/src/timerserver.c b/cpukit/rtems/src/timerserver.c
index
37 matches
Mail list logo