Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-30 Thread Pavel Pisa
Hello Sebastian, On Friday 24 of March 2023 11:43:02 Sebastian Huber wrote: > it seems we have two different MDIO services: not not nice to have two different APIs... In general it would be great to have actual MDIO PHY chips drivers in a separate folder(s) and actual NIC driver should provide o

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-29 Thread Sebastian Huber
Hello Pavel, thanks for your information. On 29.03.23 13:40, Pavel Pisa wrote: We need to resolve license update in the files and get rid of uLAN directory and I hope that it can be cleaned up. I would like to test code on TMS570LS3137 when I find time and on TMS570LC43 one day... I work curr

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-29 Thread Pavel Pisa
Hello Sebastian, On Friday 24 of March 2023 11:21:57 Sebastian Huber wrote: > Hello Pavel, > > On 18.03.23 01:04, Pavel Pisa wrote: > > As for > > > > +static inline void > > +tms570_data_sync_barier(void) > > +{ > > +#ifdef __arm__ > > + _ARM_Data_synchronization_barrier(); > > +#endif > > +} >

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-24 Thread Sebastian Huber
Hello Pavel, it seems we have two different MDIO services: cpsw/src/include/mdio.h:extern unsigned int MDIOPhyRegRead(unsigned int baseAddr, unsigned int phyAddr, uLan/ports/driver/tms570_emac/ti_drv_mdio.h:MDIOPhyRegRead(volatile tms570_mdio_t *baseAddr, uint32_t phyAddr, I get these warn

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-24 Thread Sebastian Huber
Hello Pavel, On 18.03.23 01:04, Pavel Pisa wrote: As for +static inline void +tms570_data_sync_barier(void) +{ +#ifdef __arm__ + _ARM_Data_synchronization_barrier(); +#endif +} it is OK but may it be not ideal, because more drivers could require write buffers and instructions memory access or

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-17 Thread Pavel Pisa
Hello Kinsey and Sebastian, On Thursday 09 of March 2023 14:46:28 Kinsey Moore wrote: > Normally with rtems-lwip I would complain that this doesn't follow the > convention of using #ifdef __rtems__ to modify files from upstream sources > (each root directory except rtemslwip has an upstream source

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-09 Thread Kinsey Moore
On Thu, Mar 9, 2023 at 7:48 AM Sebastian Huber < sebastian.hu...@embedded-brains.de> wrote: > On 09.03.23 14:46, Kinsey Moore wrote: > > Normally with rtems-lwip I would complain that this doesn't follow the > > convention of using #ifdef __rtems__ to modify files from upstream > > sources (each r

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-09 Thread Sebastian Huber
On 09.03.23 14:46, Kinsey Moore wrote: Normally with rtems-lwip I would complain that this doesn't follow the convention of using #ifdef __rtems__ to modify files from upstream sources (each root directory except rtemslwip has an upstream source), but the uLan authors have given permission to f

Re: [lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-09 Thread Kinsey Moore
Normally with rtems-lwip I would complain that this doesn't follow the convention of using #ifdef __rtems__ to modify files from upstream sources (each root directory except rtemslwip has an upstream source), but the uLan authors have given permission to fully integrate this code into the rtemslwip

[lwip 2/2] Move and rename sys_arch_data_sync_barier()

2023-03-09 Thread Sebastian Huber
This function is not present in the lwIP mainline. Move it to the only user and rename it to tms570__data_sync_barier(). --- uLan/ports/driver/tms570_emac/tms570_netif.c | 16 uLan/ports/os/rtems/arch/sys_arch.h | 5 - 2 files changed, 12 insertions(+), 9 deletions(