Hi
**ALL** BSPs but three PowerPC BSPs which use the STARTUP directive
in linkcmds have start.o as the STARTUP file:
$ find . -name linkcmds* | xargs -e grep STARTUP | grep -v "(start.o)"
./powerpc/beatnik/startup/linkcmds:STARTUP(motld_start.o)
./powerpc/mvme5500/startup/linkcmds:STARTUP(mvme550
On Thu, Dec 21, 2017 at 5:59 PM, Chris Johns wrote:
> On 22/12/2017 08:21, Joel Sherrill wrote:
>> Gedare posted a patch about GNU inlines as I recall. It was needed with newer
>> GCC version compiling the old cross version. Just wanted to make sure it got
>> reviewed and pushed also
>
> Is this h
The commit message: s/one/nano?
On Fri, Dec 22, 2017 at 8:16 AM, Sebastian Huber
wrote:
> This simplifies the CLOCK_MONOTONIC based time services. It is
> potentially important for libbsd.
>
> Close #3265.
> ---
> cpukit/posix/src/clockgettime.c | 5 +++--
> 1 file changed, 3 insertions(+), 2 d
This simplifies the CLOCK_MONOTONIC based time services. It is
potentially important for libbsd.
Close #3265.
---
cpukit/posix/src/clockgettime.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/cpukit/posix/src/clockgettime.c b/cpukit/posix/src/clockgettime.c
index 4f6c5
Rename _Watchdog_Realtime_from_*() to _Watchdog_Ticks_from_*().
Update #3264.
---
cpukit/rtems/src/taskwakewhen.c | 2 +-
cpukit/rtems/src/timercreate.c | 2 +-
cpukit/score/include/rtems/score/watchdogimpl.h | 6 +++---
cpukit/score/src/coretodset.c
Rename PER_CPU_WATCHDOG_MONOTONIC to PER_CPU_WATCHDOG_TICKS. Add new
PER_CPU_WATCHDOG_MONOTONIC which is based on the system uptime (measured
by timecounter).
Close #3264.
---
cpukit/posix/src/alarm.c| 4 +-
cpukit/posix/src/nanosleep.c| 6 +-
cpuk
On 21/12/17 08:15, Chris Johns wrote:
On 21/12/17 5:47 pm, Sebastian Huber wrote:
Hello,
we should try to understand better why the things are how they are currently.
Agreed.
In Newlib we have this ctr0.c:
https://sourceware.org/git/gitweb.cgi?p=newlib-cygwin.git;a=blob;f=newlib/libc/sys/rt