Re: Null[C]String() has been renamed Void[C]String()

2017-09-22 Thread Boris Zbarsky
On 9/22/17 1:31 PM, Eric Rahm wrote: The problem is these were never a null string, they're a voided empty string. Sure. In the DOM usage, it's "a string that will convert to JS null when converting to 'DOMString?'", and not anything about the string itself being null. Arguably that API s

Re: Null[C]String() has been renamed Void[C]String()

2017-09-22 Thread Eric Rahm
The problem is these were never a null string, they're a voided empty string. If you do a `str.get()` it gives you a valid pointer, not nullptr. Regardless, while this was primarily a string change, we probably should have pinged a dom peer; I had forgotten the weirdness that is DOMString [1]. Argu

Re: Null[C]String() has been renamed Void[C]String()

2017-09-22 Thread Boris Zbarsky
On 9/22/17 2:41 AM, Nicholas Nethercote wrote: This probably won't affect most people, because void strings are a niche feature. Not in the DOM. They're used anytime you see "DOMString?" in webidl. http://searchfox.org/mozilla-central/search?q=DOMString%3F&path=webidl shows several hundred h

Null[C]String() has been renamed Void[C]String()

2017-09-21 Thread Nicholas Nethercote
Hi, I just landed patches from bug 1401813 that rename Null[C]String() as Void[C]String(). The commit message has the rationale: > XPCOM's string API doesn't have the notion of a "null string". But it does have > the notion of a "void string" (or "voided string"), and that's what these > function