https://bugzilla.mozilla.org/show_bug.cgi?id=1093480
Comment 0:
I think I will break this patch up into several incremental patches:
* Inline API documentation, errors and basic infrastructure (stack of
transactions, PromiseAction, isInTransaction)
* doTransaction
* undoTransaction
* redoTransac
On Sunday, November 2, 2014 11:45:52 AM UTC-8, David Rajchenbach-Teller wrote:
> This looks like toolkit/ stuff.
> If you can segment this in small patches, I can try and review it.
>
> Cheers,
> David
How small are we talking? Other than making the tests a separate patch, I'm
not sure splitti
On Saturday, November 1, 2014 12:50:24 PM UTC-7, Kyle Huey wrote:
> On Sat, Nov 1, 2014 at 12:42 PM, wrote:
> > The reviewer should understand asynchronous Promise operations, preferably
> > the OS.File promises
>
> We shouldn't be landing new code that uses Promise.jsm in mozilla-central.
>
>
In a couple weeks I'll be doing some work on Firefox-as-a-platform-SDK
(replacement for XULRunner) and addon infrastructure work. Part of that latter
bit would be support for asynchronous file operations in the AddonManager.
The file operations, however, have to be revertable in the face of an
Current source code:
http://sourceforge.net/p/verbosio/templates/code/ci/default/tree/src/transactions/
___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform
On Monday, May 19, 2014 11:19:33 AM UTC-7, Jason Orendorff wrote:
> But I'm not the one you have to convince.
Who is? :-)
___
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform
Re: readability, that's something to think about, but when I write code like
this:
if ((typeof num != "number") ||
(Math.floor(num) != num) ||
isNaN(num) ||
(num < 0) ||
Math.abs(num) == Infinity) {
throw new Error("This need to be a non-negative whole nu
I've been thinking a bit about writing a JSM for validating arguments coming
into a function.
The first part would be the set of assertion functions:
* a non-empty string
* a whole number
* a positive number
* a non-negative number
* a function
* instanceof
* typeof
* member of
Hi, everyone. There's general consensus that we want to terminate XULRunner as
a project and replace it with a Firefox Platform SDK (name to be determined).
[1] However, what precisely we want that SDK to do, and to support, we haven't
figured out yet.
I recently submitted a bug and patch to
On Sunday, January 12, 2014 4:34:54 PM UTC-8, Mike Hommey wrote:
> - We could include the xulrunner and xulrunner-stub executables as part
> of firefox. xulrunner-stub is small and self-contained, and xulrunner
> could be replaced by something that calls firefox -app. Or we could
> make the f
Wow. All this just as I'm trying to get XULRunner repaired and stabilized for
good with automated tests. I put a lot of effort into reviving the damn thing,
and I'm close to getting it working again on the Mac. (More to the point, I'm
obsessed with getting it working on the Mac again - and I
11 matches
Mail list logo