Hi,
I've implemented Axis2 Web Services in Tomcat 5.5.26 and at times of high
load (when there are several web service client requests coming in to
Tomcat), Tomcat starts throwing following NPE:
java.lang.NullPointerException
at
org.apache.tomcat.util.http.MimeHeaders.clear(MimeHeaders.j
Author: jfclere
Date: Thu Aug 13 07:58:04 2009
New Revision: 803803
URL: http://svn.apache.org/viewvc?rev=803803&view=rev
Log:
Add detection of the macosx jvm.
BTW: Where r801544 was going...
Modified:
tomcat/native/trunk/native/build/tcnative.m4
Modified: tomcat/native/trunk/native/build/tc
Post discussion between Tomcat PMC and Jakarta PMC (with myself as the
go between), the Jakarta Taglibs subproject is going to move over to
Tomcat land. Chiefly this means:
* The JSTL implementations: 1.0, 1.1 and unreleased 1.2.
* RDC Taglib.
* An in development 'extended' taglib.
The Jakarta Ta
Hi.
I use tomcat tribes to develop my application resently, and I find
this line in the source code of the class,
org.apache.catalina.tribes.membership.McastServiceImpl, at line 202 (I
use apache-tomcat-6.0.20 source code):
socket.setLoopbackMode(true);//hint that we don't need loop back messages
On 08/13/2009 10:48 AM, Henri Yandell wrote:
Post discussion between Tomcat PMC and Jakarta PMC (with myself as the
go between), the Jakarta Taglibs subproject is going to move over to
Tomcat land. Chiefly this means:
* The JSTL implementations: 1.0, 1.1 and unreleased 1.2.
* RDC Taglib.
* An in
Rastogi Nikhil wrote:
> Hi,
>
> I've implemented Axis2 Web Services in Tomcat 5.5.26 and at times of high
> load (when there are several web service client requests coming in to
> Tomcat), Tomcat starts throwing following NPE:
>
> java.lang.NullPointerException
> at
> org.apache.tomcat.ut
Henri Yandell wrote:
> Post discussion between Tomcat PMC and Jakarta PMC (with myself as the
> go between), the Jakarta Taglibs subproject is going to move over to
> Tomcat land. Chiefly this means:
> site/ [subsite -> tomcat.apache.org/taglibs/]
> Anyway - all open to discussion + d
+1
welcome aboard,
Filip
On 08/13/2009 02:48 AM, Henri Yandell wrote:
Post discussion between Tomcat PMC and Jakarta PMC (with myself as the
go between), the Jakarta Taglibs subproject is going to move over to
Tomcat land. Chiefly this means:
* The JSTL implementations: 1.0, 1.1 and unrelease
Author: kkolinko
Date: Thu Aug 13 17:20:27 2009
New Revision: 803951
URL: http://svn.apache.org/viewvc?rev=803951&view=rev
Log:
vote
Modified:
tomcat/tc5.5.x/trunk/STATUS.txt
tomcat/tc6.0.x/trunk/STATUS.txt
Modified: tomcat/tc5.5.x/trunk/STATUS.txt
URL:
http://svn.apache.org/viewvc/tomc
On Thu, Aug 13, 2009 at 4:48 AM, Henri Yandell wrote:
> Post discussion between Tomcat PMC and Jakarta PMC (with myself as the
> go between), the Jakarta Taglibs subproject is going to move over to
> Tomcat land. Chiefly this means:
>
> * The JSTL implementations: 1.0, 1.1 and unreleased 1.2.
> * R
>
> Other option is to use required.secret instead requiredSecret
> Much easier because requiredSecret isn't document, so one
> can only find it browsing the source code.
>
> However dunno how to make it using current property set/get methods
>
I have just noticed - the following patch (as current
And I just added myself back in, but with my employer-independent email...
On Thu, Aug 13, 2009 at 1:37 PM, Rahul Akolkar wrote:
> On Thu, Aug 13, 2009 at 4:48 AM, Henri Yandell wrote:
>> Post discussion between Tomcat PMC and Jakarta PMC (with myself as the
>> go between), the Jakarta Taglibs sub
On 13/08/09 19:43, Konstantin Kolinko wrote:
Other option is to use required.secret instead requiredSecret
Much easier because requiredSecret isn't document, so one
can only find it browsing the source code.
However dunno how to make it using current property set/get methods
I have just notic
Here is why I think its good
1. Current pools can't shrink, so when peak has been hit, that's where
were at
2. Current pools are unfair, synchronized (workers) { workers.wait() },
executors are a bit more fair since they only hold a lock for a short period
3. Reduce duplicate code
4. Executors
On 13.08.2009 20:31, Mladen Turk wrote:
> On 13/08/09 19:43, Konstantin Kolinko wrote:
>>> Other option is to use required.secret instead requiredSecret
>>> Much easier because requiredSecret isn't document, so one
>>> can only find it browsing the source code.
>>>
>>> However dunno how to make it
Author: fhanik
Date: Thu Aug 13 23:10:40 2009
New Revision: 804057
URL: http://svn.apache.org/viewvc?rev=804057&view=rev
Log:
Deserialize with the webapp classloader as the context classloader
Modified:
tomcat/trunk/java/org/apache/catalina/ha/session/DeltaSession.java
Modified: tomcat/trun
Author: fhanik
Date: Thu Aug 13 23:12:36 2009
New Revision: 804058
URL: http://svn.apache.org/viewvc?rev=804058&view=rev
Log:
proposal
Modified:
tomcat/tc6.0.x/trunk/STATUS.txt
Modified: tomcat/tc6.0.x/trunk/STATUS.txt
URL:
http://svn.apache.org/viewvc/tomcat/tc6.0.x/trunk/STATUS.txt?rev=80
2009/8/13 Mladen Turk :
> On 13/08/09 19:43, Konstantin Kolinko wrote:
>>>
>>> Other option is to use required.secret instead requiredSecret
>>> Much easier because requiredSecret isn't document, so one
>>> can only find it browsing the source code.
>>>
>>> However dunno how to make it using curren
18 matches
Mail list logo