Author: mturk
Date: Sun Oct 5 00:05:51 2008
New Revision: 701754
URL: http://svn.apache.org/viewvc?rev=701754&view=rev
Log:
Rename retry_wait to retry_interval. It means exactly that; 'the interval
between retries'
Modified:
tomcat/connectors/trunk/jk/native/common/jk_ajp_common.c
tomca
Author: mturk
Date: Sun Oct 5 01:13:50 2008
New Revision: 701758
URL: http://svn.apache.org/viewvc?rev=701758&view=rev
Log:
For getting the free endpoint from the worker in load balancer, use that
workers retries/retry_interval setting.
Modified:
tomcat/connectors/trunk/jk/native/common/jk_
Author: mturk
Date: Sun Oct 5 01:29:06 2008
New Revision: 701759
URL: http://svn.apache.org/viewvc?rev=701759&view=rev
Log:
Use correct var name
Modified:
tomcat/connectors/trunk/jk/native/common/jk_lb_worker.c
Modified: tomcat/connectors/trunk/jk/native/common/jk_lb_worker.c
URL:
http://s
Author: mturk
Date: Sun Oct 5 01:31:10 2008
New Revision: 701760
URL: http://svn.apache.org/viewvc?rev=701760&view=rev
Log:
Fix typo
Modified:
tomcat/connectors/trunk/jk/native/common/jk_ajp_common.c
Modified: tomcat/connectors/trunk/jk/native/common/jk_ajp_common.c
URL:
http://svn.apache.
Author: markt
Date: Sun Oct 5 02:09:35 2008
New Revision: 701762
URL: http://svn.apache.org/viewvc?rev=701762&view=rev
Log:
Fix xml - stop gump complaining
Modified:
tomcat/connectors/trunk/jk/xdocs/miscellaneous/changelog.xml
Modified: tomcat/connectors/trunk/jk/xdocs/miscellaneous/changel
https://issues.apache.org/bugzilla/show_bug.cgi?id=43800
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
https://issues.apache.org/bugzilla/show_bug.cgi?id=44522
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
https://issues.apache.org/bugzilla/show_bug.cgi?id=45242
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
https://issues.apache.org/bugzilla/show_bug.cgi?id=44769
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
https://issues.apache.org/bugzilla/show_bug.cgi?id=44283
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
https://issues.apache.org/bugzilla/show_bug.cgi?id=43153
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
These have been created and I have moved bugs from Tomcat 4/5/6 to these
products based on component and/or presence of strings like isapi in the
summary.
I haven't checked the closed bugs to see if the results were sensible.
I have checked the open bugs. I have also set the component (mod_jk/isa
Author: markt
Date: Sun Oct 5 03:47:06 2008
New Revision: 701773
URL: http://svn.apache.org/viewvc?rev=701773&view=rev
Log:
Add links to new bugzilla components
Modified:
tomcat/site/trunk/docs/bugreport.html
tomcat/site/trunk/xdocs/bugreport.xml
Modified: tomcat/site/trunk/docs/bugrepo
https://issues.apache.org/bugzilla/show_bug.cgi?id=43479
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Component|Native:Integration |Library
Mark Thomas wrote:
These have been created and I have moved bugs from Tomcat 4/5/6 to these
products based on component and/or presence of strings like isapi in the
summary.
Cool.
I have checked the open bugs. I have also set the component (mod_jk/isapi
etc) where I thought it was sensible t
https://issues.apache.org/bugzilla/show_bug.cgi?id=40534
Mark Thomas <[EMAIL PROTECTED]> changed:
What|Removed |Added
Status|ASSIGNED|RESOLVED
Author: mturk
Date: Sun Oct 5 04:28:58 2008
New Revision: 701777
URL: http://svn.apache.org/viewvc?rev=701777&view=rev
Log:
Add and use retry_interval for load balancer. Like with ajp worker retries and
retry_interval are used to create multiple calls to get_worker. On retry the
internal tables
Mark Thomas schrieb:
> These have been created and I have moved bugs from Tomcat 4/5/6 to these
> products based on component and/or presence of strings like isapi in the
> summary.
>
> I haven't checked the closed bugs to see if the results were sensible.
>
> I have checked the open bugs. I have
Hi,
since we committed some changes to retry handling in mod_jk I try to
sort out our various aspects of retries and how to do them best.
1) Retries when retrieving an endpoint for an AJP 13 worker
===
Getting an endpoint might fail, if the
Hi Mladen,
[EMAIL PROTECTED] schrieb:
> +/* Pull shared memory if something changed during sleep */
> +jk_shm_lock();
> +if (p->worker->sequence != p->worker->s->h.sequence)
> +jk_lb_pull(p->worker, l);
> +jk_shm_unlock();
I think th
Rainer Jung wrote:
a) Refactor
---
I would suggest we move the retry handling of get_endpoint into
ajp_get_endpoint() and derive any configuration options of the retry
behaviour from the AJP 13 worker, not the LB worker.
That makes sense. It's a logical place for it.
Also the logical
Author: rjung
Date: Sun Oct 5 08:01:50 2008
New Revision: 701806
URL: http://svn.apache.org/viewvc?rev=701806&view=rev
Log:
Init retry, change semantics, s.t. the first
attempt is counted as retry #1, like we do with
AJP 13 workers.
Modified:
tomcat/connectors/trunk/jk/native/common/jk_lb_wo
Author: rjung
Date: Sun Oct 5 08:56:42 2008
New Revision: 701811
URL: http://svn.apache.org/viewvc?rev=701811&view=rev
Log:
Allow showing only a single member of a load balancer
in the status worker.
Modified:
tomcat/connectors/trunk/jk/native/common/jk_status.c
tomcat/connectors/trunk/j
Author: rjung
Date: Sun Oct 5 09:30:37 2008
New Revision: 701823
URL: http://svn.apache.org/viewvc?rev=701823&view=rev
Log:
Add display of request rates and byte transfer rates
to status worker.
Modified:
tomcat/connectors/trunk/jk/native/common/jk_status.c
Modified: tomcat/connectors/trunk
Author: rjung
Date: Sun Oct 5 10:50:14 2008
New Revision: 701837
URL: http://svn.apache.org/viewvc?rev=701837&view=rev
Log:
Update changelog.
Modified:
tomcat/connectors/trunk/jk/xdocs/miscellaneous/changelog.xml
Modified: tomcat/connectors/trunk/jk/xdocs/miscellaneous/changelog.xml
URL:
h
https://issues.apache.org/bugzilla/show_bug.cgi?id=42419
--- Comment #3 from André-John Mas <[EMAIL PROTECTED]> 2008-10-05 11:06:21 PST
---
If a change was made, I believe the simplest approach would be allow a system
property to override this. I believe JBOSS already does this. Would a patc
https://issues.apache.org/bugzilla/show_bug.cgi?id=42419
André-John Mas <[EMAIL PROTECTED]> changed:
What|Removed |Added
CC||[EMAIL PROTECT
https://issues.apache.org/bugzilla/show_bug.cgi?id=42419
--- Comment #4 from André-John Mas <[EMAIL PROTECTED]> 2008-10-05 15:03:25 PST
---
Created an attachment (id=22672)
--> (https://issues.apache.org/bugzilla/attachment.cgi?id=22672)
Diff to add support for changing the value of JSESSIO
https://issues.apache.org/bugzilla/show_bug.cgi?id=45951
Summary: Provide support for renaming JSESSIONID
Product: Tomcat 6
Version: 6.0.18
Platform: All
OS/Version: Mac OS X 10.4
Status: NEW
Severity: normal
Prior
https://issues.apache.org/bugzilla/show_bug.cgi?id=42419
--- Comment #5 from André-John Mas <[EMAIL PROTECTED]> 2008-10-05 15:16:44 PST
---
Note that I have opened bug 45951 to deal with Tomcat 6. An equivalent patch
has been added there.
--
Configure bugmail: https://issues.apache.org/bu
Author: billbarker
Date: Sun Oct 5 16:43:00 2008
New Revision: 701902
URL: http://svn.apache.org/viewvc?rev=701902&view=rev
Log:
Add support for full client-cert chains to AJP
Modified:
tomcat/trunk/java/org/apache/coyote/ajp/AjpAprProcessor.java
tomcat/trunk/java/org/apache/coyote/ajp/A
+---+
| Bugzilla Bug ID |
| +-+
| | Status: UNC=Unconfirmed NEW=New ASS=Assigned
+---+
| Bugzilla Bug ID |
| +-+
| | Status: UNC=Unconfirmed NEW=New ASS=Assigned
+---+
| Bugzilla Bug ID |
| +-+
| | Status: UNC=Unconfirmed NEW=New ASS=Assigned
+---+
| Bugzilla Bug ID |
| +-+
| | Status: UNC=Unconfirmed NEW=New ASS=Assigned
Mladen Turk wrote:
Costin Manolache wrote:
There are few issues and questions, I'm not sure its as simple as it
looks
:-)
For new development - are you going to make changes in both branches ? I
assume there will be
features that can only be done in 1.3.
Right.
1.1.x will be in bug fixing m
Hi.
I think that retry_interval can be set also with LB.
Is it correct?
> + required="false">
regards.
On Sun, Oct 5, 2008 at 4:05 PM, <[EMAIL PROTECTED]> wrote:
> Author: mturk
> Date: Sun Oct 5 00:05:51 2008
> New Revision: 701754
>
> URL: http://svn.apache.org/viewvc?rev=701754&view=rev
>
37 matches
Mail list logo