"Iain Buclaw via D.gnu" wrote in message
news:mailman.6598.1424298906.9932.d@puremagic.com...
The answer would still be no because of calling convention differences
- another reason why GDC and DMD are not ABI compatible.
However, if you used an extern(C) API, then that should be at least
"Johannes Pfau" wrote in message news:m5enbm$2t0e$1...@digitalmars.com...
The linker scripts also know about some details of the C/C++ codegen.
For example attribute(constructor) needs support from linker scripts.
(KEEP, SORT_NONE, PROVIDE_HIDDEN or similar) Without this support
constructor cal
"Mike" wrote in message news:cqzazaqxpwezignix...@forum.dlang.org...
If my theory is correct, GDC may have to make an internal linker script
specifically for D's code generation that marks such code as KEEP.
There was some discussion of this at dconf, and a custom linker script is
both strai
"Iain Buclaw via D.gnu" wrote in message
news:mailman.4028.1405352460.2907.d@puremagic.com...
It's not that which I'm worried about, it's tracking down gluey
changes before/after the conversion that will take the longest.
Maybe it would be worth getting a list of all pull requests in the
"Iain Buclaw" wrote in message news:phejgytsbkojsczbp...@forum.dlang.org...
Hi,
Looks like its that time of the year again.
Same as last time, will be raising a pull and struggling through the last
6 months of dmd development.
Apologies in advance.
Daniel, do you have a list of gluey-
"Johannes Pfau" wrote in message news:lhp8h4$2j38$1...@digitalmars.com...
But we'd want this to work/inline nevertheless, right?:
void test(const(char)[] a)
{
}
char[] abc;
test(abc);
Then we still need to tell GCC that const(char)[] is a variant of
char[] or it won'
"Iain Buclaw" wrote in message
news:mailman.306.1393348468.6445.d@puremagic.com...
> And give them better names while you're at it?
Visitor names? I was thinking IRVisitor, and build_ir (). ;)
I mean, you have todt.c with all the toDt methods, which you are now free to
call something
"Iain Buclaw" wrote in message
news:mailman.286.1393282527.6445.d@puremagic.com...
OK, rather than all at once, I'll move each file with each visitor
conversion. First one is d-toir.cc -> toir.cc in the 2.065 merge. :)
And give them better names while you're at it?
"Mike" wrote in message news:lxusmgyievzioacmg...@forum.dlang.org...
What bothers me is the branch at . It looks like it's checking the
struct instance to see if it is null. Is it even possible for it to be
null? Can this be improved?
It's checking if the 'this' pointer is null. Syntactical