[PATCH] D151741: [Lex] Only warn on defining or undefining language-defined builtins

2023-05-30 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. This patch cleared up all the warnings I reported, thank you for the fix! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D151741/new/ https://reviews.llvm.org/D151741 ___ cfe-

[PATCH] D152180: [Sema] Do not emit -Wunused-variable for variables declared with cleanup attribute

2023-06-05 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance created this revision. nathanchance added reviewers: aaron.ballman, nickdesaulniers, erichkeane. Herald added a project: All. nathanchance requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. A variable declared with `__attribute__(

[PATCH] D152180: [Sema] Do not emit -Wunused-variable for variables declared with cleanup attribute

2023-06-05 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance updated this revision to Diff 528510. nathanchance added a comment. Change `f4()`'s return type to `void` (Nick) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D152180/new/ https://reviews.llvm.org/D152180 Files: clang/lib/Sema/SemaDecl.cpp clang/test/Sema/warn-unused-va

[PATCH] D152180: [Sema] Do not emit -Wunused-variable for variables declared with cleanup attribute

2023-06-05 Thread Nathan Chancellor via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG877210faa447: [Sema] Do not emit -Wunused-variable for variables declared with cleanup… (authored by nathanchance). Repository: rG LLVM Github Mon

[PATCH] D152186: [Clang] Add release note for 877210faa447

2023-06-05 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance created this revision. nathanchance added reviewers: erichkeane, nickdesaulniers. Herald added a project: All. nathanchance requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. Repository: rG LLVM Github Monorepo https://reviews.

[PATCH] D152186: [Clang] Add release note for 877210faa447

2023-06-05 Thread Nathan Chancellor via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGdeecf89a1361: [Clang] Add release note for 877210faa447 (authored by nathanchance). Changed prior to commit: https://reviews.llvm.org/D152186?vs=5

[PATCH] D152186: [Clang] Add release note for 877210faa447

2023-06-05 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. Thanks, I landed it with those nits addressed. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D152186/new/ https://reviews.llvm.org/D152186 ___ cfe-commits mailing list cfe-co

[PATCH] D138179: MIPS: fix build from IR files, nan2008 and FpAbi

2022-12-16 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added subscribers: nickdesaulniers, nathanchance. nathanchance added a comment. For what it's worth, this breaks building the Linux kernel's `ARCH=mips 32r1_defconfig` with clang and GNU as, with thousands of messages along the line of: /tmp/mmc_ops-d329c3.s: Assembler messages:

[PATCH] D117717: [clang] Ignore -fconserve-stack

2022-01-19 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance created this revision. nathanchance added reviewers: aaron.ballman, MaskRay, srhines. Herald added a subscriber: dang. nathanchance requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. This flag is used when building the Linux kerne

[PATCH] D117717: [clang] Ignore -fconserve-stack

2022-01-19 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D117717#3256180 , @MaskRay wrote: > Clang has a long list of ignored options but most were added during the > catch-up phase when Clang strove to be a competitor compiler. > I think for new ignored options there needs to

[PATCH] D117717: [clang] Ignore -fconserve-stack

2022-01-19 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D117717#3256293 , @MaskRay wrote: > Assuming scan-build is clang/tools/scan-build, which is in tree and can be > fixed instead. Yes, that is the one. > I am not familiar with it, but from > >> However, this caused issue

[PATCH] D117717: [clang] Ignore -fconserve-stack

2022-01-27 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance abandoned this revision. nathanchance added a comment. As discussed, this is not the right fix for the issue. I have just gone ahead and told the original reporter to use `scan-build` with the `--use-cc=clang` flag to avoid these issues. Repository: rG LLVM Github Monorepo CHAN

[PATCH] D94355: [Passes] Add relative lookup table converter pass

2021-04-26 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. This patch breaks a two stage build with LTO: $ git bisect log # bad: [f0bc2782f281ca05221d2f1735bbaff6c4b81ebb] [TTI] NFC: Remove unused 'OptSize' parameter from shouldMaximizeVectorBandwidth # good: [9829f5e6b1bca9b61efc629770d28bb9014dec45] [CVP] @llvm.[us

[PATCH] D94355: [Passes] Add relative lookup table converter pass

2021-04-26 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D94355#2717813 , @gulfem wrote: > Thanks for the report @nathanchance, and I'm looking at it now. Thanks! > Is this failure from one of the bots? No, this was discovered by a user of my LLVM build script: https://github

[PATCH] D94355: [Passes] Add relative lookup table converter pass

2021-04-27 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D94355#2717958 , @gulfem wrote: > @nathanchance do you prefer me to revert the patch first as it might take me > a while to investigate it? > Btw, I was able to reproduce the issue by following your steps. I would say if

[PATCH] D100581: [Clang] -Wunused-but-set-parameter and -Wunused-but-set-variable

2021-04-28 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D100581#2721430 , @nickdesaulniers wrote: > Huh, maybe not: https://godbolt.org/z/PnE1fMGWo This difference has caused some confusion already for the Linux kernel: https://lore.kernel.org/r/202104280827.lsczw8xg-...@int

[PATCH] D116059: [Clang][CFG] check children statements of asm goto

2022-01-07 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. The two false positive warnings in the kernel are fixed with this patch and there were no new warnings introduced. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D116059/new/ https://reviews.llvm.org/D116059 __

[PATCH] D105169: [Clang/Test]: Rename enable_noundef_analysis to disable-noundef-analysis and turn it off by default

2022-01-12 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D105169#3236484 , @hyeongyukim wrote: > @nathanchance > > I tried to reproduce the last warning (intelfbhw_validate_mode), but I failed > to produce it. > I think my reproducer is correct, but it does not make any warnin

[PATCH] D105169: [Clang/Test]: Rename enable_noundef_analysis to disable-noundef-analysis and turn it off by default

2022-01-14 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a subscriber: nickdesaulniers. nathanchance added a comment. In D105169#3242949 , @hyeongyukim wrote: > @nathanchance Hi, I analyzed all four warnings. Thanks a lot for doing this! > Warning #1: can be handled by x86-backend. filled

[PATCH] D105169: [Clang/Test]: Rename enable_noundef_analysis to disable-noundef-analysis and turn it off by default

2022-01-15 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D105169#3246378 , @nlopes wrote: > In D105169#3244624 , @nathanchance > wrote: > >> I can reduce all of these down for you and/or I can start an email thread >> with the `objtool

[PATCH] D116128: [clang][driver] Warn when '-mno-outline-atomics' is used with a non-AArch64 triple

2021-12-21 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance created this revision. nathanchance added reviewers: melver, nickdesaulniers, t.p.northover. Herald added subscribers: pengfei, kristof.beyls. nathanchance requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. The Linux kernel has a

[PATCH] D116128: [clang][driver] Warn when '-mno-outline-atomics' is used with a non-AArch64 triple

2021-12-21 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. If there are more qualified people to review and accept this, please add them, I was unsure of who else to add. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D116128/new/ https://reviews.llvm.org/D116128 _

[PATCH] D116128: [clang][driver] Warn when '-mno-outline-atomics' is used with a non-AArch64 triple

2021-12-21 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added inline comments. Comment at: clang/test/Driver/x86-outline-atomics.c:1-7 +// RUN: %clang -target x86_64 -moutline-atomics -S %s -### 2>&1 | FileCheck %s -check-prefix=CHECK-OUTLINE-ATOMICS +// CHECK-OUTLINE-ATOMICS: warning: 'x86_64' does not support '-moutli

[PATCH] D116128: [clang][driver] Warn when '-mno-outline-atomics' is used with a non-AArch64 triple

2021-12-22 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance updated this revision to Diff 395879. nathanchance added a comment. Herald added subscribers: luke957, s.egerton, simoncook. - Move test from x86-outline-atomics.c to unsupported-outline-atomics.c (Marco). - Add a test for riscv64 to ensure it works with multiple architectures (Marco

[PATCH] D116128: [clang][driver] Warn when '-mno-outline-atomics' is used with a non-AArch64 triple

2021-12-23 Thread Nathan Chancellor via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGbe8180af5854: [clang][driver] Warn when '-mno-outline-atomics' is used with a non-AArch64… (authored by nathanchance). Repository: rG LLVM Github

[PATCH] D105169: [Clang/Test]: Rename enable_noundef_analysis to disable-noundef-analysis and turn it off by default

2021-12-28 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. @hyeongyukim I am currently offline for the evening but it seems like my reduction might have been too aggressive. It looks like this code comes from `ravb_set_gti()` (https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/net/ethernet/rene

[PATCH] D105169: [Clang/Test]: Rename enable_noundef_analysis to disable-noundef-analysis and turn it off by default

2021-12-29 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. @hyeongyukim I hand reduced a couple of the translation units that I see issues in so apologies if they are a little verbose. The full set of warnings: drivers/net/ethernet/renesas/ravb.lto.o: warning: objtool: .text.ravb_set_gti: unexpected end of section dri

[PATCH] D93164: [AST] Add generator for source location introspection

2021-03-16 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. I am seeing a spew of errors after 19740652c4c4329e2b9e77f96e5e31c360b4e8bb (what appears to be the latest version of this patch): $ cmake \ -G Ninja \ -DCMAKE_BUILD_TYPE=Release \ -DCMAK

[PATCH] D93164: [AST] Add generator for source location introspection

2021-03-16 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. In D93164#2630534 , @steveire wrote: > In D93164#2630203 , @nathanchance > wrote: > >> I am seeing a spew of errors after 19740652c4c4329e2b9e77f96e5e31c360b4e8bb >>

[PATCH] D98881: [RISCV] Fix mcount name for Linux

2021-03-18 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance created this revision. Herald added subscribers: vkmr, evandro, luismarques, sameer.abuasal, s.egerton, Jim, benna, psnobl, PkmX, rogfer01, shiva0217, kito-cheng, simoncook. nathanchance requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-c

[PATCH] D98881: [RISCV] Fix mcount name for Linux

2021-03-18 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. Would it be better to hoist it into `RISCVTargetInfo` and modify the BSD switch statements to respect that in their respective TargetInfo constructors? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98881/new/ https://

[PATCH] D98881: [RISCV] Fix mcount name for Linux

2021-03-18 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. Such a diff does not look too bad: diff --git a/clang/lib/Basic/Targets/OSTargets.h b/clang/lib/Basic/Targets/OSTargets.h index 539466c4f678..c32972c1e04e 100644 --- a/clang/lib/Basic/Targets/OSTargets.h +++ b/clang/lib/Basic/Targets/OSTargets.h @@ -256,6

[PATCH] D99220: [RISCV] Fix mcount name

2021-03-23 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance created this revision. Herald added subscribers: vkmr, frasercrmck, evandro, luismarques, apazos, sameer.abuasal, s.egerton, Jim, benna, psnobl, jocewei, PkmX, the_o, brucehoult, MartinMosbeck, rogfer01, edward-jones, zzheng, jrtc27, shiva0217, kito-cheng, niosHD, sabuasal, simoncoo

[PATCH] D98881: [RISCV] Fix mcount name

2021-03-23 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance updated this revision to Diff 332811. nathanchance retitled this revision from "[RISCV] Fix mcount name for Linux" to "[RISCV] Fix mcount name". nathanchance edited the summary of this revision. nathanchance added a comment. Herald added subscribers: frasercrmck, apazos, jocewei, the_

[PATCH] D98881: [RISCV] Fix mcount name

2021-03-24 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance updated this revision to Diff 333185. nathanchance added a comment. Drop "riscv32" and "riscv64" from list of checked triples (thanks to Fangrui for catching it with a good explanation). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98

[PATCH] D98881: [RISCV] Fix mcount name

2021-03-24 Thread Nathan Chancellor via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGef58ae86ba77: [RISCV] Fix mcount name (authored by nathanchance). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews

[PATCH] D108003: [Clang] Extend -Wbool-operation to warn about bitwise and of bools with side effects

2021-08-19 Thread Nathan Chancellor via Phabricator via cfe-commits
nathanchance added a comment. I am still running a series of builds against the Linux kernel but I already see one instance of this warning where the suggestion would change the meaning of the code in an incorrect way: drivers/input/touchscreen.c:81:17: warning: use of bitwise '|' with boolea

<    1   2