[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-13 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 436525. GuillaumeGomez added a comment. Fix libcxxabi mangling test Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127460/new/ https://reviews.llvm.org/D127460 Files: libcxxabi/test/test_demangle.pass.

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-13 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 436527. GuillaumeGomez added a comment. Fix libcxxabi mangling test Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127460/new/ https://reviews.llvm.org/D127460 Files: clang/lib/CodeGen/CGBuiltin.cpp

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-13 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added 1 blocking reviewer(s): libc++abi. GuillaumeGomez added a comment. I finally took time to fix the failing test. For some reason, I can't seem to push without marking `libcxxabi/test/test_demangle.pass.cpp` as a binary file with `arc diff HEAD~2 --update D127460`. I hope thi

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. @efriedma It was falling the tests because of that, which is why I updated it. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127460/new/ https://reviews.llvm.org/D127460 _

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added inline comments. Comment at: llvm/lib/IR/Function.cpp:1430 +// This defines the "Intrinsic::getIntrinsicForClangBuiltin()" method. #define GET_LLVM_INTRINSIC_FOR_GCC_BUILTIN #include "llvm/IR/IntrinsicImpl.inc" RKSimon wrote: > Should this

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 436774. GuillaumeGomez added a comment. Update #define as well Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127460/new/ https://reviews.llvm.org/D127460 Files: clang/lib/CodeGen/CGBuiltin.cpp llvm/

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. I applied the changes suggested by @RKSimon and @efriedma. Comment at: llvm/include/llvm/ADT/Triple.h:1031 /// @} /// @name Static helpers for IDs. /// @{ ldionne wrote: > Comment applies to `test_demangle.pass.cpp` (it'

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 436778. GuillaumeGomez added a comment. Rename `IsGCC` function parameter into `IsClang` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127460/new/ https://reviews.llvm.org/D127460 Files: clang/lib/Cod

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. Applied @RKSimon's suggestion. Comment at: llvm/utils/TableGen/IntrinsicEmitter.cpp:883 void IntrinsicEmitter::EmitIntrinsicToBuiltinMap( const CodeGenIntrinsicTable &Ints, bool IsGCC, raw_ostream &OS) { + StringRef CompilerName = (IsGCC ?

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 436876. GuillaumeGomez added a comment. - Update #define name as well - Rename `IsGCC` function parameter into `IsClang` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127460/new/ https://reviews.llvm.org

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-14 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez marked an inline comment as done. GuillaumeGomez added a comment. Fixed @spatel's comment. Comment at: llvm/include/llvm/IR/Intrinsics.td:387 -/// GCCBuiltin - If this intrinsic exactly corresponds to a GCC builtin, this +/// ClangBuiltin - If this intrinsic ex

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-22 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez marked an inline comment as done. GuillaumeGomez added a comment. Is there anything else for me to do in here so it gets merged? (Sorry if I missed it but I couldn't find out the exact merge process in the documentation) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST A

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-22 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. This is my first LLVM contribution so I don't think I do? If I do have a commit access anyway, do you have a link to the documentation where it explains what I'm supposed to do by any chance? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION htt

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-22 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 438989. GuillaumeGomez added a comment. Rename GCCBuiltin into ClangBuiltin. This patch is needeed because developers expect "GCCBuiltin" items to be the GCC intrinsics equivalent and not the Clang internals. Repository: rG LLVM Github Monorepo C

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-22 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. In D127460#3601193 , @xbolva00 wrote: > Patch description needs to be added, especially answer the question why we > should rename it, why we want it.. I updated the description to explain why it is needed. I'm not sure h

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-22 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. So from the documentation: > Prior to obtaining commit access, it is common practice to request that > someone with commit access commits on your behalf. When doing so, please > provide the name and email address you would like to use in the Author > property of

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-22 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez updated this revision to Diff 439115. GuillaumeGomez added a comment. - Rename GCCBuiltin into ClangBuiltin - Update #define name as well - Rename `IsGCC` function parameter into `IsClang` Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/

[PATCH] D127409: Fix GCC intrinsics "round_mask" names

2022-06-09 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. Just to have a vague idea of what this change would look like, I pushed it. It would make our lives much simpler if we could rely on `GCCBuiltin` (aka `ClangBuiltin`) though. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-09 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez created this revision. Herald added subscribers: kosarev, mattd, gchakrabarti, kerbowa, atanasyan, jrtc27, hiraditya, jvesely, nemanjai, sdardis. Herald added a project: All. GuillaumeGomez requested review of this revision. Herald added subscribers: llvm-commits, libcxx-commits, cf

[PATCH] D127460: Rename GCCBuiltin into ClangBuiltin

2022-06-09 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a subscriber: craig.topper. GuillaumeGomez added a comment. As mentioned in https://reviews.llvm.org/D127409, it would avoid confusions to name it `ClangBuiltin` instead of keeping `GCCBuiltin`. cc @craig.topper Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACT

[PATCH] D127409: Fix GCC intrinsics "round_mask" names

2022-06-09 Thread Guillaume Gomez via Phabricator via cfe-commits
GuillaumeGomez added a comment. As you suggested, I opened https://reviews.llvm.org/D127460 to rename `GCCBuiltin` into `ClangBuiltin` to clarify the confusion. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D127409/new/ https://reviews.llvm.org/D12