[PATCH] D94979: [CGExpr] Use getCharWidth() more consistently in CCGExprConstant. NFC

2021-01-22 Thread Bjorn Pettersson via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGea2cfda386f1: [CGExpr] Use getCharWidth() more consistently in CCGExprConstant. NFC (authored by bjope). Changed prior to commit: https://reviews.

[PATCH] D92808: [ObjC][ARC] Annotate calls with attributes instead of emitting retainRV or claimRV calls in the IR

2021-01-22 Thread John McCall via Phabricator via cfe-commits
rjmccall accepted this revision. rjmccall added a comment. This revision is now accepted and ready to land. LGTM. I know you mentioned doing this for more targets in follow-up commits. It would be good to also do this for `-O0`, so that we have a single correct pattern coming out of the fronte

[clang] 4e6ad11 - [RISCV] Add Zba feature and move add.uw and slli.uw to it.

2021-01-22 Thread Craig Topper via cfe-commits
Author: Craig Topper Date: 2021-01-22T12:49:10-08:00 New Revision: 4e6ad11bc6f29eecfbef7f5d5b7e581dd26e2024 URL: https://github.com/llvm/llvm-project/commit/4e6ad11bc6f29eecfbef7f5d5b7e581dd26e2024 DIFF: https://github.com/llvm/llvm-project/commit/4e6ad11bc6f29eecfbef7f5d5b7e581dd26e2024.diff

[PATCH] D94582: [RISCV] Rename mnemonics slliu.w->slli.uw and addu.w->add.uw to match 0.93 bitmanip spec.

2021-01-22 Thread Craig Topper via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGb825278364d9: [RISCV] Rename mnemonics slliu.w->slli.uw and addu.w->add.uw to match 0.93… (authored by craig.topper). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llv

[PATCH] D94617: [RISCV] Add Zba feature and move add.uw and slli.uw to it.

2021-01-22 Thread Craig Topper via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG4e6ad11bc6f2: [RISCV] Add Zba feature and move add.uw and slli.uw to it. (authored by craig.topper). Changed prior to commit: https://reviews.llvm.org/D94617?vs=318217&id=318616#toc Repository: rG LL

[PATCH] D95002: [RISCV] Update B extension version to 0.93.

2021-01-22 Thread Craig Topper via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG20f2e32d2c54: [RISCV] Update B extension version to 0.93. (authored by craig.topper). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTI

[PATCH] D70701: Fix more VFS tests on Windows

2021-01-22 Thread Duncan P. N. Exon Smith via Phabricator via cfe-commits
dexonsmith added a comment. In D70701#2515934 , @amccarth wrote: > BTW, I hope I didn't come across as overly negative in my previous > response. No, not at all! > [...] On Windows, a process can have multiple > current directories: one for each drive.

[PATCH] D95228: Add swift_async_context parameter attribute mapping to IR equivalent

2021-01-22 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land. LGTM with a documentation question and a testing request. Comment at: clang/include/clang/Basic/AttrDocs.td:4404 + +A context parameter must have pointer or ref

[PATCH] D94624: PATCH] [clang-query] Add a --use-color option to clang-query to allow forcing the behavior

2021-01-22 Thread Tom Ritter via Phabricator via cfe-commits
tomrittervg updated this revision to Diff 318632. tomrittervg added a comment. Try rebasing it... Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D94624/new/ https://reviews.llvm.org/D94624 Files: clang-tools-extra/clang-query/Query.cpp clang-too

[PATCH] D95202: ADT: Use 'using' to inherit assign and append in SmallString

2021-01-22 Thread David Blaikie via Phabricator via cfe-commits
dblaikie accepted this revision. dblaikie added a comment. This revision is now accepted and ready to land. Looks good - some optional feedback on the code fixes. Please run clang-format on the changes here (phab lint picked up some cases in the test code that could be cleaned up). ==

[PATCH] D94627: [PowerPC][PC Rel] Implement option to omit P10 instructions from stubs

2021-01-22 Thread Amy Kwan via Phabricator via cfe-commits
amyk added a comment. A few general comments. Comment at: lld/ELF/Config.h:74 +// For --power10-stub +enum class P10Stub { Default, No }; + We have a "yes", but does it need to be here, too? Comment at: lld/ELF/Driver.cpp:763 +static P10Stu

[PATCH] D95187: [DebugInfo][CodeView] Use as the display name for lambdas.

2021-01-22 Thread Amy Huang via Phabricator via cfe-commits
akhuang updated this revision to Diff 318657. akhuang added a comment. -add to comment -Add externally visible lambda to test case Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95187/new/ https://reviews.llvm.org/D95187 Files: clang/include/clan

[PATCH] D95270: [clangd][NFC] Simplify handing on methods with no params

2021-01-22 Thread Nathan James via Phabricator via cfe-commits
njames93 created this revision. njames93 added reviewers: sammccall, kadircet. Herald added subscribers: usaxena95, arphaman. njames93 requested review of this revision. Herald added subscribers: cfe-commits, MaskRay, ilya-biryukov. Herald added a project: clang. Add bind methods handling the case

[clang] d18c3c7 - [CodeComplete] Add ranged for loops code pattern.

2021-01-22 Thread Nathan James via cfe-commits
Author: Nathan James Date: 2021-01-22T23:40:35Z New Revision: d18c3c7b18e9e78145d701c4687682848071ab98 URL: https://github.com/llvm/llvm-project/commit/d18c3c7b18e9e78145d701c4687682848071ab98 DIFF: https://github.com/llvm/llvm-project/commit/d18c3c7b18e9e78145d701c4687682848071ab98.diff LOG:

[PATCH] D95131: [CodeComplete] Add ranged for loops code pattern.

2021-01-22 Thread Nathan James via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGd18c3c7b18e9: [CodeComplete] Add ranged for loops code pattern. (authored by njames93). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95131/new/ https://rev

[clang] e92be7c - PR47682: Merge the DeclContext of a merged FunctionDecl before we inherit

2021-01-22 Thread Richard Smith via cfe-commits
Author: Richard Smith Date: 2021-01-22T15:46:41-08:00 New Revision: e92be7cd9f03ab3eb8c4a21e686743c2575a169a URL: https://github.com/llvm/llvm-project/commit/e92be7cd9f03ab3eb8c4a21e686743c2575a169a DIFF: https://github.com/llvm/llvm-project/commit/e92be7cd9f03ab3eb8c4a21e686743c2575a169a.diff

[PATCH] D95271: [CSSPGO] Passing the clang driver switch -fpseudo-probe-for-profiling to the linker.

2021-01-22 Thread Hongtao Yu via Phabricator via cfe-commits
hoy created this revision. Herald added subscribers: wenlei, dang, steven_wu, hiraditya. Herald added a reviewer: jansvoboda11. hoy requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. As titled. Repository: rG LLVM Github Monorepo https://

[PATCH] D95168: [clang-format] Add InsertBraces option

2021-01-22 Thread MyDeveloperDay via Phabricator via cfe-commits
MyDeveloperDay added a subscriber: djasper. MyDeveloperDay added a comment. I think this is one of those reviews that ultimately I think would be useful if we could ensure it works 100% correctly, but I think it goes against the original ethos of clang-format and I think if @djasper or @klimek t

[PATCH] D95168: [clang-format] Add InsertBraces option

2021-01-22 Thread MyDeveloperDay via Phabricator via cfe-commits
MyDeveloperDay added inline comments. Comment at: clang/unittests/Format/FormatTest.cpp:17921 + " another_function(arg, arg, arg, arg, arg, arg);"; + EXPECT_EQ(IfElseSourceLong, format(IfElseSourceLong, Style)); + can you use verifyFormat() instead of EXPE

[clang] ba5628f - ADT: Use 'using' to inherit assign and append in SmallString

2021-01-22 Thread Duncan P. N. Exon Smith via cfe-commits
Author: Duncan P. N. Exon Smith Date: 2021-01-22T16:17:58-08:00 New Revision: ba5628f2c2a9de049b80b3e276f7e05f481c49e7 URL: https://github.com/llvm/llvm-project/commit/ba5628f2c2a9de049b80b3e276f7e05f481c49e7 DIFF: https://github.com/llvm/llvm-project/commit/ba5628f2c2a9de049b80b3e276f7e05f481c

[PATCH] D95202: ADT: Use 'using' to inherit assign and append in SmallString

2021-01-22 Thread Duncan P. N. Exon Smith via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGba5628f2c2a9: ADT: Use 'using' to inherit assign and append in SmallString (authored by dexonsmith). Changed prior to commit: https://reviews.llvm

[PATCH] D94942: [clangd] Add tweak for implementing abstract class

2021-01-22 Thread Nathan James via Phabricator via cfe-commits
njames93 updated this revision to Diff 318678. njames93 edited the summary of this revision. njames93 added a comment. Fix failing tests. Updated message for tweak from a specified base class. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D94942/new/

[PATCH] D95202: ADT: Use 'using' to inherit assign and append in SmallString

2021-01-22 Thread Duncan P. N. Exon Smith via Phabricator via cfe-commits
dexonsmith marked 2 inline comments as done. dexonsmith added a comment. Thanks for the review! Pushed with suggestions applied in ba5628f2c2a9de049b80b3e276f7e05f481c49e7 . Comment at: llvm/lib/Support/File

[PATCH] D95204: [lld-macho] switch default to new Darwin port

2021-01-22 Thread Greg McGary via Phabricator via cfe-commits
gkm planned changes to this revision. gkm added a comment. Pulling this back from review ... Not ready for prime time. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95204/new/ https://reviews.llvm.org/D95204 ___

[PATCH] D95279: Support: Remove duplicated code in {File,clang::ModulesDependency}Collector, NFC

2021-01-22 Thread Duncan P. N. Exon Smith via Phabricator via cfe-commits
dexonsmith created this revision. dexonsmith added reviewers: dblaikie, JDevlieghere. Herald added subscribers: ributzka, hiraditya. dexonsmith requested review of this revision. Herald added projects: clang, LLVM. Refactor the duplicated canonicalize-path logic in `FileCollector` and `ModulesDepe

[PATCH] D95271: [CSSPGO] Passing the clang driver switch -fpseudo-probe-for-profiling to the linker.

2021-01-22 Thread Hongtao Yu via Phabricator via cfe-commits
hoy updated this revision to Diff 318714. hoy added a comment. Fixing test failure on Windows. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95271/new/ https://reviews.llvm.org/D95271 Files: clang/include/clang/Driver/Options.td clang/lib/Driv

[PATCH] D94745: [OpenMP][WIP] Build the deviceRTLs with OpenMP instead of target dependent language - NOT FOR REVIEW

2021-01-22 Thread Shilei Tian via Phabricator via cfe-commits
tianshilei1992 added inline comments. Comment at: openmp/libomptarget/deviceRTLs/nvptx/CMakeLists.txt:24 + return() +endif() + JonChesterfield wrote: > jdoerfert wrote: > > we need the 32 bit versions as well, I guess? > We could limit to 64 and see if a feature

[PATCH] D95279: Support: Remove duplicated code in {File,clang::ModulesDependency}Collector, NFC

2021-01-22 Thread Jonas Devlieghere via Phabricator via cfe-commits
JDevlieghere accepted this revision. JDevlieghere added a comment. This revision is now accepted and ready to land. LGTM, thanks for cleaning this up! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95279/new/ https://reviews.llvm.org/D95279 ___

[PATCH] D95249: [NFC] Disallow unused prefixes in clang/test/Analysis

2021-01-22 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added a comment. I added those for consistency but i think your effort is worth it so let's ditch them. Comment at: clang/test/Analysis/exploded-graph-rewriter/trimmers.dot:4 // RUN: %exploded_graph_rewriter -s %s \ -// RUN: | FileCheck %s -check-prefixes=ONE,TWO,NOTH

[PATCH] D95161: [Clang][OpenMP][NVPTX] Replace `libomptarget-nvptx-path` with `libomptarget-nvptx-bc-path`

2021-01-22 Thread Shilei Tian via Phabricator via cfe-commits
tianshilei1992 updated this revision to Diff 318717. tianshilei1992 added a comment. Fixed the test issue caused by wrong path seperator on Windows and Linux Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95161/new/ https://reviews.llvm.org/D95161

[PATCH] D95161: [Clang][OpenMP][NVPTX] Replace `libomptarget-nvptx-path` with `libomptarget-nvptx-bc-path`

2021-01-22 Thread Shilei Tian via Phabricator via cfe-commits
tianshilei1992 updated this revision to Diff 318719. tianshilei1992 added a comment. Made test more robust Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D95161/new/ https://reviews.llvm.org/D95161 Files: clang/docs/ClangCommandLineReference.rst

[PATCH] D90329: [PowerPC] Fix va_arg in C++, Objective-C on 32-bit ELF targets

2021-01-22 Thread George Koehler via Phabricator via cfe-commits
kernigh added a comment. I forgot about this diff for a month. Comment at: clang/lib/CodeGen/TargetInfo.cpp:4722 bool isI64 = Ty->isIntegerType() && getContext().getTypeSize(Ty) == 64; - bool isInt = - Ty->isIntegerType() || Ty->isPointerType() || Ty->isAggregateType()

[clang] 018984a - [PowerPC] Fix va_arg in C++, Objective-C on 32-bit ELF targets

2021-01-22 Thread Brad Smith via cfe-commits
Author: George Koehler Date: 2021-01-23T00:13:36-05:00 New Revision: 018984ae6833fae107aa9c502ab5536efceca88e URL: https://github.com/llvm/llvm-project/commit/018984ae6833fae107aa9c502ab5536efceca88e DIFF: https://github.com/llvm/llvm-project/commit/018984ae6833fae107aa9c502ab5536efceca88e.diff

[PATCH] D90329: [PowerPC] Fix va_arg in C++, Objective-C on 32-bit ELF targets

2021-01-22 Thread Brad Smith via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG018984ae6833: [PowerPC] Fix va_arg in C++, Objective-C on 32-bit ELF targets (authored by kernigh, committed by brad). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.ll

<    1   2