[PATCH] D84782: [PGO] Include the mem ops into the function hash.

2020-07-28 Thread Fangrui Song via Phabricator via cfe-commits
MaskRay added inline comments. Comment at: llvm/lib/Transforms/Instrumentation/PGOInstrumentation.cpp:266 +PGOOldCFGHashing("pgo-instr-old-cfg-hashing", cl::init(false), cl::Hidden, + cl::desc("Use the old CFG function hashing.")); + Nit:

[PATCH] D60620: [HIP] Support target id by --offload-arch

2020-07-28 Thread Yaxun Liu via Phabricator via cfe-commits
yaxunl updated this revision to Diff 281465. yaxunl added a comment. separate emitting target-id module flag to a different patch. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D60620/new/ https://reviews.llvm.org/D60620 Files: clang/include/clang/Basic/DiagnosticDriverKinds.td clan

[PATCH] D84824: [HIP] Emit target-id module flag

2020-07-28 Thread Yaxun Liu via Phabricator via cfe-commits
yaxunl created this revision. yaxunl added a reviewer: tra. yaxunl requested review of this revision. Separate this patch from https://reviews.llvm.org/D60620 since it depends on https://reviews.llvm.org/D80750 https://reviews.llvm.org/D84824 Files: clang/lib/CodeGen/CodeGenModule.cpp clan

[PATCH] D84814: [clang-tidy] readability-identifier-naming checks configs for included files

2020-07-28 Thread Dmitri Gribenko via Phabricator via cfe-commits
gribozavr2 added inline comments. Comment at: clang-tools-extra/clang-tidy/readability/IdentifierNamingCheck.cpp:124 +static void +populateNaimgStyle(std::vector &Styles, + const ClangTidyCheck::OptionsView &Options) { I think it would be bette

[PATCH] D84812: [clang-tidy][NFC] Added convienence methods for getting optional options

2020-07-28 Thread Dmitri Gribenko via Phabricator via cfe-commits
gribozavr2 added inline comments. Comment at: clang-tools-extra/clang-tidy/ClangTidyCheck.cpp:224 + else +consumeError(ValueOr.takeError()); + return llvm::None; Is this specialization defined only because parsing a string option can never fail? I'd let th

[PATCH] D84743: [Clang][AMDGCN] Universal device offloading macros header

2020-07-28 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert added a comment. In D84743#2179441 , @tra wrote: > I'm not sure it's particularly useful, to be honest. CUDA code still needs to > be compatible with NVCC so it can't be used in portable code like TF or other > currently used CUDA libraries. >

[clang-tools-extra] 8dbe9b2 - [Clang-tools-extra] Mark override a function which overrides a virtual one

2020-07-28 Thread Anh Tuyen Tran via cfe-commits
Author: Anh Tuyen Tran Date: 2020-07-29T05:30:33Z New Revision: 8dbe9b249846be81bc676543698db14ee37e28e2 URL: https://github.com/llvm/llvm-project/commit/8dbe9b249846be81bc676543698db14ee37e28e2 DIFF: https://github.com/llvm/llvm-project/commit/8dbe9b249846be81bc676543698db14ee37e28e2.diff LOG

[PATCH] D84794: Mark override to a function which overrides a virtual one

2020-07-28 Thread Anh Tuyen Tran via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG8dbe9b249846: [Clang-tools-extra] Mark override a function which overrides a virtual one (authored by anhtuyen). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org

[PATCH] D83281: [OpenMP] Allow traits for the OpenMP context selector `isa`

2020-07-28 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert added a comment. ping :) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D83281/new/ https://reviews.llvm.org/D83281 ___ cfe-commits mailing list cfe-commits@lists.llvm.org https://lists.llvm.org/

[PATCH] D84743: [Clang][AMDGCN] Universal device offloading macros header

2020-07-28 Thread Fangrui Song via Phabricator via cfe-commits
MaskRay added a comment. In D84743#2181031 , @jdoerfert wrote: > In D84743#2179441 , @tra wrote: > >> I'm not sure it's particularly useful, to be honest. CUDA code still needs >> to be compatible with NVCC so it c

[PATCH] D84743: [Clang][AMDGCN] Universal device offloading macros header

2020-07-28 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert added a comment. In D84743#2181044 , @MaskRay wrote: > In D84743#2181031 , @jdoerfert wrote: > >> In D84743#2179441 , @tra wrote: >> >>> I'm not sure it's particula

[PATCH] D84743: [Clang][AMDGCN] Universal device offloading macros header

2020-07-28 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert added inline comments. Comment at: clang/lib/Headers/offload_macros.h:1 +//===--- offload_macros.h - Universal _DEVICE Offloading Macros Header ---===// +// After @MaskRay noticed this, I think this should be `__offload_macros.h` to make it clear this

[PATCH] D83242: [clang][BPF] support type existence/size and enum value relocations

2020-07-28 Thread Yonghong Song via Phabricator via cfe-commits
yonghong-song updated this revision to Diff 281481. yonghong-song retitled this revision from "[clang][BPF] support expr with typedef/record type for TYPE_EXISTENCE reloc" to "[clang][BPF] support type existence/size and enum value relocations". yonghong-song edited the summary of this revision.

[clang] 8924779 - [clang] Fix ConceptSpecializationExpr::getEndLoc()

2020-07-28 Thread Nathan Ridge via cfe-commits
Author: Nathan Ridge Date: 2020-07-29T02:44:26-04:00 New Revision: 89247792c5bdd58500b0e6c5e56532424c2e2ca1 URL: https://github.com/llvm/llvm-project/commit/89247792c5bdd58500b0e6c5e56532424c2e2ca1 DIFF: https://github.com/llvm/llvm-project/commit/89247792c5bdd58500b0e6c5e56532424c2e2ca1.diff

<    1   2   3