SouraVX marked 2 inline comments as done.
SouraVX added a comment.
Will be adding llvm-dwarfdump tests soon.
Comment at: clang/lib/CodeGen/CGDebugInfo.cpp:1608
+ if (CGM.getCodeGenOpts().DwarfVersion >= 5) {
+// DWARF-5 support for, defaulted, deleted member functions
--
Author: stephanemoore
Date: Tue Oct 1 14:18:40 2019
New Revision: 373392
URL: http://llvm.org/viewvc/llvm-project?rev=373392&view=rev
Log:
[clang-tidy] Rename objc-avoid-spinlock check to darwin-avoid-spinlock
Summary:
OSSpinLock* are Apple/Darwin functions, but were previously located with ObjC
This revision was automatically updated to reflect the committed changes.
Closed by commit rL373392: [clang-tidy] Rename objc-avoid-spinlock check to
darwin-avoid-spinlock (authored by stephanemoore, committed by ).
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https://revie
yaxunl created this revision.
yaxunl added a reviewer: tra.
https://reviews.llvm.org/D68300
Files:
include/clang/Driver/Options.td
lib/Driver/ToolChains/HIP.cpp
test/Driver/hip-no-device-libs.hip
Index: test/Driver/hip-no-device-libs.hip
===
hliao added a comment.
PING
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68157/new/
https://reviews.llvm.org/D68157
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-b
Author: rksimon
Date: Tue Oct 1 14:50:30 2019
New Revision: 373396
URL: http://llvm.org/viewvc/llvm-project?rev=373396&view=rev
Log:
CGExprAgg - remove duplicate code. NFCI.
Remove duplicate getAs<> call, avoiding a clang static analyzer null
dereference warning.
Modified:
cfe/trunk/lib/Co
Author: rksimon
Date: Tue Oct 1 15:02:46 2019
New Revision: 373398
URL: http://llvm.org/viewvc/llvm-project?rev=373398&view=rev
Log:
CGVTables - silence static analyzer getAs null dereference
warnings. NFCI.
The static analyzer is warning about potential null dereferences, but we should
be abl
Author: rupprecht
Date: Tue Oct 1 15:30:10 2019
New Revision: 373400
URL: http://llvm.org/viewvc/llvm-project?rev=373400&view=rev
Log:
[clang][OpenMP][NFC] #include GlobalDecl.h to avoid incomplete class type
Modified:
cfe/trunk/lib/CodeGen/CGOpenMPRuntime.h
Modified: cfe/trunk/lib/CodeGen/
bruno added a reviewer: v.g.vassilev.
bruno added a comment.
Ping!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67249/new/
https://reviews.llvm.org/D67249
___
cfe-commits mailing list
cfe-commits@list
bruno added a reviewer: v.g.vassilev.
bruno added a comment.
Ping!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67010/new/
https://reviews.llvm.org/D67010
___
cfe-commits mailing list
cfe-commits@list
tra added a comment.
The functionality looks generic enough. Should it be just
`flink_builtin_bitcode`?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68300/new/
https://reviews.llvm.org/D68300
___
cfe-commits mailing list
cfe-commits@list
tra accepted this revision.
tra added a comment.
LGTM.
Does it produce textual IR if used with `-S`?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68284/new/
https://reviews.llvm.org/D68284
___
cfe-commits mailing list
cfe-commits@lists.ll
Author: rjmccall
Date: Tue Oct 1 16:13:03 2019
New Revision: 373407
URL: http://llvm.org/viewvc/llvm-project?rev=373407&view=rev
Log:
Emit TypeNodes.def with tblgen.
The primary goal here is to make the type node hierarchy available to
other tblgen backends, although it should also make it easie
Author: rjmccall
Date: Tue Oct 1 16:12:57 2019
New Revision: 373406
URL: http://llvm.org/viewvc/llvm-project?rev=373406&view=rev
Log:
Use scope qualifiers in Clang's tblgen backends to get useful
redeclaration checking. NFC.
Modified:
cfe/trunk/utils/TableGen/ClangASTNodesEmitter.cpp
cf
nridge added inline comments.
Comment at: clang-tools-extra/clangd/SemanticHighlighting.cpp:219
+ bool VisitDependentNameTypeLoc(DependentNameTypeLoc L) {
+addToken(L.getNameLoc(), HighlightingKind::DependentType);
+return true;
hokein wrote:
> nit: we h
nridge updated this revision to Diff 222725.
nridge marked 9 inline comments as done.
nridge added a comment.
Address review comments
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67901/new/
https://reviews.llvm.org/D67901
Files:
clang-tools-ext
Author: hliao
Date: Tue Oct 1 17:22:45 2019
New Revision: 373410
URL: http://llvm.org/viewvc/llvm-project?rev=373410&view=rev
Log:
Fix unused variable warning. NFCI.
Modified:
cfe/trunk/lib/CodeGen/CGOpenMPRuntime.cpp
Modified: cfe/trunk/lib/CodeGen/CGOpenMPRuntime.cpp
URL:
http://llvm.org
rsmith accepted this revision.
rsmith added a comment.
This revision is now accepted and ready to land.
LGTM
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67249/new/
https://reviews.llvm.org/D67249
___
rsmith added a comment.
This seems reasonable to me, but a test case would be nice.
A mode to validate that header path changes don't change anything would be nice
(essentially: redo all the header searches with the new set of paths and new
filesystem and make sure they find the same thing), bu
Author: rjmccall
Date: Tue Oct 1 18:02:27 2019
New Revision: 373416
URL: http://llvm.org/viewvc/llvm-project?rev=373416&view=rev
Log:
Remove TypeNodes.def from the modulemap.
We currently just look for files named in the modulemap in its
associated source directory. This means that we can't nam
Author: rsmith
Date: Tue Oct 1 18:13:57 2019
New Revision: 373418
URL: http://llvm.org/viewvc/llvm-project?rev=373418&view=rev
Log:
Fix crash on constant-evaluation of pseudo-destruction of a pointer.
We got confused and thought we might be pseudo-destroying the pointee
instead.
Modified:
c
All other tablegen outputs are called .inc instead of .def. Any reason this
one's different?
On Tue, Oct 1, 2019 at 7:10 PM John McCall via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: rjmccall
> Date: Tue Oct 1 16:13:03 2019
> New Revision: 373407
>
> URL: http://llvm.org/viewvc/l
On 1 Oct 2019, at 21:20, Nico Weber wrote:
All other tablegen outputs are called .inc instead of .def. Any reason
this
one's different?
This was an existing file; it’s just generated now instead of written
in source. I was deliberately not changing anything about the existing
use sites. That
I think that'd be nice; I believe I renamed one .def output with the same
history for the same reason a while ago.
On Tue, Oct 1, 2019 at 9:25 PM John McCall wrote:
> On 1 Oct 2019, at 21:20, Nico Weber wrote:
> > All other tablegen outputs are called .inc instead of .def. Any reason
> > this
>
This broke gnu_pubnames and other forms of DWARF index of C++ code - fixed
in r373420 (feel free to post-comimt review, etc, of course)
On Mon, Sep 23, 2019 at 5:36 PM Adrian Prantl via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: adrian
> Date: Mon Sep 23 17:38:49 2019
> New Revisi
Author: rtrieu
Date: Tue Oct 1 19:32:15 2019
New Revision: 373421
URL: http://llvm.org/viewvc/llvm-project?rev=373421&view=rev
Log:
Revert r368237 - Update fix-it hints for std::move warnings.
r368237 attempted to improve fix-its for move warnings, but introduced some
regressions to -Wpessimizin
yaxunl updated this revision to Diff 222746.
yaxunl retitled this revision from "[HIP] Add option
-fno-hip-link-builtin-bitcode to disable linking device lib" to "[HIP] Add
option -fno-link-builtin-bitcode to disable linking device lib".
yaxunl added a comment.
change the option name
CHANGES S
ymandel created this revision.
ymandel added a reviewer: gribozavr.
Herald added a project: clang.
This revision adds three new Stencil combinators:
- `expression`, which idiomatically constructs the source for an expression,
including wrapping the expression's source in parentheses if needed.
-
compnerd accepted this revision.
compnerd added inline comments.
This revision is now accepted and ready to land.
Comment at: clang/lib/Driver/Driver.cpp:3372
+ if (Phase == phases::IfsMerge) {
+assert(Phase == PL.back() && "merging must be final compilation
step.")
programmerjake added a comment.
The `__GNUG__` macro is defined to be 4 rather than matching `__GNUC__`
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D68055/new/
https://reviews.llvm.org/D68055
___
cfe-
MaskRay accepted this revision.
MaskRay added a comment.
This will make it much easier to test clang's compatibility with GCC,
especially in projects that heavily use `__GNUC__` or its friends, e.g. glibc :)
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm
Author: rjmccall
Date: Tue Oct 1 23:35:23 2019
New Revision: 373425
URL: http://llvm.org/viewvc/llvm-project?rev=373425&view=rev
Log:
Rename TypeNodes.def to TypeNodes.inc for consistency across all
our autogenerated files. NFC.
As requested by Nico Weber.
Modified:
cfe/trunk/include/clang
On 1 Oct 2019, at 21:31, Nico Weber wrote:
I think that'd be nice; I believe I renamed one .def output with the
same
history for the same reason a while ago.
r373425
John.
On Tue, Oct 1, 2019 at 9:25 PM John McCall wrote:
On 1 Oct 2019, at 21:20, Nico Weber wrote:
All other tablegen out
101 - 133 of 133 matches
Mail list logo