Author: vmiklos
Date: Fri Jan 5 15:22:10 2018
New Revision: 321913
URL: http://llvm.org/viewvc/llvm-project?rev=321913&view=rev
Log:
clang-tidy: add IgnoreMacros option to
readability-inconsistent-declaration-parameter-name
And also enable it by default to be consistent with e.g. modernize-use-
This revision was automatically updated to reflect the committed changes.
Closed by commit rL321913: clang-tidy: add IgnoreMacros option to
readability-inconsistent-declaration… (authored by vmiklos, committed by ).
Herald added a subscriber: klimek.
Changed prior to commit:
https://reviews.llv
Author: benhamilton
Date: Fri Jan 5 15:26:06 2018
New Revision: 321914
URL: http://llvm.org/viewvc/llvm-project?rev=321914&view=rev
Log:
[clang-tidy] Function-scoped static variables should not trigger
google-objc-global-variable-declaration
Summary:
google-objc-global-variable-declaration curr
This revision was automatically updated to reflect the committed changes.
Closed by commit rCTE321914: [clang-tidy] Function-scoped static variables
should not trigger google-objc… (authored by benhamilton, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D41789?vs=128814&id=12
mclow.lists added a comment.
> The use of iota targeting vector with an int parameter
> triggers warnings on MSVC++ assigning an into a unsigned char&
I hate your compiler.
Other than that (and the bit about identity), this looks fine to me.
Comment at:
test/std/numerics/nu
rsmith added a comment.
I just tried this on one of our larger builds. The good news is that it appears
to work: the compilation still succeeds, and significantly fewer nodes are
deserialized. The bad news is that the final .cc file compilation got slower,
from 42s to 86s. (There's a lot of noi
Author: rsmith
Date: Fri Jan 5 16:09:23 2018
New Revision: 321916
URL: http://llvm.org/viewvc/llvm-project?rev=321916&view=rev
Log:
When name lookup finds a non-imported declaration and looks back along the
redecl chain for an imported declaration, make sure to check the IDNS of prior
imported de
This revision was automatically updated to reflect the committed changes.
Closed by commit rC321917: [Driver] Suggest correctly spelled driver options
(authored by modocache, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D41733?vs=128736&id=128824#toc
Repository:
rC Clang
Author: modocache
Date: Fri Jan 5 16:25:40 2018
New Revision: 321917
URL: http://llvm.org/viewvc/llvm-project?rev=321917&view=rev
Log:
[Driver] Suggest correctly spelled driver options
Summary:
Depends on https://reviews.llvm.org/D41732.
Utilities such as `opt`, when invoked with arguments that
az created this revision.
az added a reviewer: SjoerdMeijer.
Herald added subscribers: kristof.beyls, javed.absar, mgorny, rengolin,
aemerson.
ARMv8.2-A introduces half-precision floating point data processing. This patch
adds the fp16 scalar intrinsics for this architecture as described in the
MaskRay added a comment.
Ping
Repository:
rC Clang
https://reviews.llvm.org/D41575
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: rsmith
Date: Fri Jan 5 17:07:05 2018
New Revision: 321921
URL: http://llvm.org/viewvc/llvm-project?rev=321921&view=rev
Log:
Serialize the IDNS for a UsingShadowDecl rather than recomputing it.
Attempting to recompute it are doomed to fail because the IDNS of a declaration
is not necessar
NoQ created this revision.
NoQ added reviewers: dcoughlin, xazax.hun, a.sidorin, george.karpenkov, szepet.
Herald added subscribers: cfe-commits, rnkovacs, mehdi_amini.
Similarly to how we allow (since https://reviews.llvm.org/D40560) inlining the
constructor after `operator new` which isn't `ope
NoQ added inline comments.
Comment at: lib/StaticAnalyzer/Core/ExprEngineCallAndReturn.cpp:692-693
+ if (const Stmt *DtorExpr = Dtor.getOriginExpr())
+if (const Stmt *ParentExpr =
+CurLC->getParentMap().getParent(DtorExpr))
+ if (const CXXDel
NoQ created this revision.
NoQ added reviewers: dcoughlin, xazax.hun, a.sidorin, george.karpenkov.
Herald added subscribers: cfe-commits, rnkovacs, szepet.
This continues the series of fine-tuning of how everything behaves in
`-analyzer-config c++-allocator-inlining=true` mode with respects to ca
NoQ created this revision.
NoQ added reviewers: dcoughlin, xazax.hun, a.sidorin, george.karpenkov, szepet.
Herald added subscribers: cfe-commits, rnkovacs.
This one's easy. Under `-analyzer-config c++-allocator-inlining=true`, since
https://reviews.llvm.org/D41406, we've teached `MallocChecker` t
NoQ created this revision.
NoQ added reviewers: dcoughlin, xazax.hun, a.sidorin, george.karpenkov, szepet.
Herald added subscribers: cfe-commits, rnkovacs.
Make use of the new callback introduced in https://reviews.llvm.org/D41406 for
tracking values allocated by `operator new()` in `-analyzer-co
NoQ created this revision.
NoQ added reviewers: dcoughlin, xazax.hun, a.sidorin, george.karpenkov, szepet.
Herald added subscribers: cfe-commits, rnkovacs.
This addresses a TODO from https://reviews.llvm.org/D41406. I re-used
`PostImplicitCall` program point when calling the new callback, but it
NoQ added inline comments.
Comment at: lib/StaticAnalyzer/Core/ExprEngine.cpp:2906-2907
Out << "\\lPostLValue\\l";
+else if (Loc.getAs())
+ Out << "\\lPostAllocatorCall\\l";
{F5743196}
Repository:
rC Clang
https://reviews.llvm.o
NoQ added a comment.
In https://reviews.llvm.org/D35109#968314, @baloghadamsoftware wrote:
> But how to add a flag for this? Is it a flag enabled by the user or is it
> automatically enabled if the checker is enabled?
I guess it'd be an `-analyzer-config` flag. You can add it to the
`Analyzer
BillyONeal updated this revision to Diff 128836.
BillyONeal marked 3 inline comments as done.
BillyONeal added a comment.
Also change predicate from identity to add_ten.
https://reviews.llvm.org/D41748
Files:
test/std/numerics/numeric.ops/exclusive.scan/exclusive_scan.pass.cpp
test/std/nume
BillyONeal added a comment.
> I hate your compiler.
Seems like a valid warning to me :)
Changed predicate to one that adds 10 to each input.
https://reviews.llvm.org/D41748
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.
NoQ accepted this revision.
NoQ added a comment.
This revision is now accepted and ready to land.
This makes sense. @dcoughlin: does this harmonize with your original intent for
adding this suppression in the first place?
https://reviews.llvm.org/D41749
__
Author: bion
Date: Fri Jan 5 18:18:20 2018
New Revision: 321922
URL: http://llvm.org/viewvc/llvm-project?rev=321922&view=rev
Log:
[libcxx] [test] Remove nonstandard things and resolve warnings in Xxx_scan tests
Reviewed as https://reviews.llvm.org/D41748
* These tests use function objects from
NoQ accepted this revision.
NoQ added a comment.
This revision is now accepted and ready to land.
Neat, thank you!
Comment at: lib/StaticAnalyzer/Core/BugReporterVisitors.cpp:992-993
+/// Walk through nodes until we get one that matches the statement exactly.
+/// Alternately,
CaseyCarter added inline comments.
Comment at:
test/std/numerics/numeric.ops/transform.exclusive.scan/transform_exclusive_scan_init_bop_uop.pass.cpp:33
+template
+constexpr auto operator()(T x) const noexcept {
+return static_cast(x + 10);
Altho
rsmith added a comment.
One other test I'd like to see is what happens if you declare a version before
the first use, and define it afterwards, particularly if the version is an
inline function:
inline __attribute__((target("default"))) void f();
inline __attribute__((target("foo"))) void f
Author: bion
Date: Fri Jan 5 18:50:03 2018
New Revision: 321923
URL: http://llvm.org/viewvc/llvm-project?rev=321923&view=rev
Log:
Add casts to prevent narrowing warnings.
Modified:
libcxx/trunk/test/std/numerics/numeric.ops/transform.exclusive.scan/transform_exclusive_scan_init_bop_uop.pass
ahatanak updated this revision to Diff 128838.
https://reviews.llvm.org/D41039
Files:
include/clang/AST/Decl.h
include/clang/AST/DeclCXX.h
include/clang/Basic/Attr.td
include/clang/Basic/AttrDocs.td
include/clang/Basic/DiagnosticSemaKinds.td
include/clang/Sema/Sema.h
lib/AST/DeclCXX
Author: rtrieu
Date: Fri Jan 5 19:20:59 2018
New Revision: 321924
URL: http://llvm.org/viewvc/llvm-project?rev=321924&view=rev
Log:
Test case for r321396
Any hashing for methods should be able to compile this test case without
emitting an error. Since the class and method come from the same hea
ahatanak marked an inline comment as done.
ahatanak added inline comments.
Comment at: lib/CodeGen/MicrosoftCXXABI.cpp:833
// passed in registers, which is non-conforming.
if (RD->hasNonTrivialDestructor() &&
getContext().getTypeSize(RD->getTypeForDecl()) > 64)
ahatanak updated this revision to Diff 128839.
ahatanak marked 3 inline comments as done.
ahatanak added a comment.
Rename variable to HasTrivialABIOverride.
https://reviews.llvm.org/D41039
Files:
include/clang/AST/Decl.h
include/clang/AST/DeclCXX.h
include/clang/Basic/Attr.td
include/c
ahatanak added a comment.
It doesn't look like this patch would break IRGen for functions that receive
fp16 types. fp16 is passed as i32 or float (without promotion) on ARM and as
half on ARM64. It should work fine.
https://reviews.llvm.org/D41311
___
ahatanak added inline comments.
Comment at: clang/lib/CodeGen/CGCall.cpp:2321
+ ArgI.getCoerceToType() ==
+ ConvertType(isPromoted ? Ty : Arg->getType()) &&
ArgI.getDirectOffset() == 0) {
Maybe a comment explaining why different t
rjmccall added a comment.
I'll trust Richard on the tricky Sema/AST bits. The functionality of the patch
looks basically acceptable to me, although I'm still not thrilled about the
idea of actually removing the attribute from the AST rather than just letting
it not have effect. But we could c
101 - 135 of 135 matches
Mail list logo