r310862. Thanks!
On Sun, Aug 13, 2017 at 3:41 PM, Richard Smith wrote:
> Since we took the -std=c++17 change for Clang 5, we should take this one
> too.
>
> On 13 August 2017 at 15:26, Richard Smith via cfe-commits
> wrote:
>>
>> Author: rsmith
>> Date: Sun Aug 13 15:26:53 2017
>> New Revision:
Hi,
Ok that's a progress. Could you figure out which optimizer pass
breaks it. I bet it is the inliner. I assume we could run a reducer on
the ll file.
Cheers, Vassil
On 14/08/17 17:21, Diana Picus wrote:
Hi,
I didn't manage to reproduce this at -O0. Yes, I think the version in
1.8.0, sli
rjmccall added inline comments.
Comment at: include/clang/Basic/SyncScope.h:59
+return "opencl_subgroup";
+ }
+}
yaxunl wrote:
> rjmccall wrote:
> > t-tye wrote:
> > > Should there be a default/assert/static_assert to allow SyncScope enum to
> > > grow due
Author: chh
Date: Mon Aug 14 10:45:48 2017
New Revision: 310863
URL: http://llvm.org/viewvc/llvm-project?rev=310863&view=rev
Log:
[clang-tidy] Add a close-on-exec check on inotify_init1() in Android module.
Summary:
inotify_init1() is better to set IN_CLOEXEC flag to avoid file descriptor
leakag
This revision was automatically updated to reflect the committed changes.
Closed by commit rL310863: [clang-tidy] Add a close-on-exec check on
inotify_init1() in Android module. (authored by chh).
Changed prior to commit:
https://reviews.llvm.org/D35368?vs=110750&id=111033#toc
Repository:
rL
rjmccall added inline comments.
Comment at: lib/Sema/SemaLambda.cpp:959
+ ? diag::ext_equals_this_lambda_capture_cxx2a
+ : diag::warn_cxx1z_compat_equals_this_lambda_capture);
hamzasood wrote:
> faisalv wrote:
> >
Author: abataev
Date: Mon Aug 14 10:56:13 2017
New Revision: 310865
URL: http://llvm.org/viewvc/llvm-project?rev=310865&view=rev
Log:
[OPENMP] Fix for PR33922: New ident_t flags for
__kmpc_for_static_init().
OpenMP 5.0 will include OpenMP Tools interface that requires distinguishing
different wo
yaxunl marked 7 inline comments as done.
yaxunl added inline comments.
Comment at: include/clang/Basic/SyncScope.h:89
+ static std::unique_ptr create(LangOptions &Opt);
+};
+
rjmccall wrote:
> The previous design of this header seems more appropriate to me. Cla
marsupial created this revision.
Easier to read and possibly optimize.
https://reviews.llvm.org/D36701
Files:
include/clang/Parse/Parser.h
Index: include/clang/Parse/Parser.h
===
--- include/clang/Parse/Parser.h
+++ include/cla
hamzasood added inline comments.
Comment at: test/FixIt/fixit-cxx0x.cpp:57
(void)[&, &i, &i]{}; // expected-error 2{{'&' cannot precede a capture when
the capture default is '&'}}
- (void)[=, this]{ this->g(5); }; // expected-error{{'this' cannot be
explicitly captured}}
marsupial created this revision.
The fix in r303372 exposed a problem when using **Parser::ConsumeToken** from
client code in DEBUG.
**ConsumeToken** will assert for all **isTokenSpecial()** cases, but there is
no way to call the proper method.
The isToken methods are just convenient.
https:/
rjmccall added inline comments.
Comment at: include/clang/Basic/SyncScope.h:92
+/// \brief Defines the synch scope ABI for OpenCL.
+class AtomicScopeOpenCLABI : public AtomicScopeABI {
+public:
yaxunl wrote:
> rjmccall wrote:
> > Please correct me if I'm wrong, b
dcoughlin accepted this revision.
dcoughlin added a comment.
This revision is now accepted and ready to land.
Looks good to me! (Please expand the comment, though.)
Comment at: include/clang/Analysis/ProgramPoint.h:658
+class LoopExit : public ProgramPoint {
+public:
rjmccall added inline comments.
Comment at: test/FixIt/fixit-cxx0x.cpp:57
(void)[&, &i, &i]{}; // expected-error 2{{'&' cannot precede a capture when
the capture default is '&'}}
- (void)[=, this]{ this->g(5); }; // expected-error{{'this' cannot be
explicitly captured}}
dcoughlin added a comment.
Also, please mention in the commit message that tests will be added in a
following commit.
https://reviews.llvm.org/D35670
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/list
yaxunl marked 4 inline comments as done.
yaxunl added inline comments.
Comment at: include/clang/Basic/SyncScope.h:92
+/// \brief Defines the synch scope ABI for OpenCL.
+class AtomicScopeOpenCLABI : public AtomicScopeABI {
+public:
rjmccall wrote:
> yaxunl wrote
chh added a comment.
Daniel, Manuel, I will take over this CL since Yan has finished his internship
at Google.,
Yan's latest patch to tryToParseLambda looks acceptable to me.
I think it should take care of new kw_auto in additional to kw_new, ke_delete,
etc.
Could you suggest if there is any be
johannes added a comment.
In https://reviews.llvm.org/D36686#840827, @arphaman wrote:
> It might be useful to have both source and destination in a different
> revision. Maybe something like `-src-git-rev` and `-dst-git-rev`?
Then I'd rather have a revision range such as `-git-revs ..`
and if
It's helpful to mention why a patch is reverted in the commit message that
reverts. Thought for next time! :)
On Tue, Aug 8, 2017 at 9:46 AM Alexey Bataev via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: abataev
> Date: Tue Aug 8 09:45:36 2017
> New Revision: 310379
>
> URL: http:/
rjmccall added inline comments.
Comment at: include/clang/Basic/SyncScope.h:92
+/// \brief Defines the synch scope ABI for OpenCL.
+class AtomicScopeOpenCLABI : public AtomicScopeABI {
+public:
yaxunl wrote:
> rjmccall wrote:
> > yaxunl wrote:
> > > rjmccall wrot
erichkeane created this revision.
A small set of refactors that'll make it easier for me to implement 'target'
support.
First, extract the CPUSupports functionality into its own function. THis has
the advantage of not wasting time in this builtin to deal with arguments.
Second, pulls both CP
Author: epilk
Date: Mon Aug 14 12:49:12 2017
New Revision: 310874
URL: http://llvm.org/viewvc/llvm-project?rev=310874&view=rev
Log:
[Sema] Improve some -Wunguarded-availability diagnostics
rdar://33543523
Differential revision: https://reviews.llvm.org/D36200
Modified:
cfe/trunk/include/clan
This revision was automatically updated to reflect the committed changes.
Closed by commit rL310874: [Sema] Improve some -Wunguarded-availability
diagnostics (authored by epilk).
Changed prior to commit:
https://reviews.llvm.org/D36200?vs=109252&id=111051#toc
Repository:
rL LLVM
https://rev
efriedma added a comment.
I'm not sure this produces the right locations in general. Consider the
following slightly evil testcase:
#\
if 0
#elif \
11\
int a;
#endif
https://reviews.llvm.org/D36642
___
cfe-commits mailing list
cf
eandrews updated this revision to Diff 111064.
eandrews added a comment.
As per review comments, removed extra RUNS in lit test.
https://reviews.llvm.org/D36487
Files:
lib/CodeGen/CodeGenModule.cpp
test/CodeGenCXX/extern-section-attribute.cpp
Index: test/CodeGenCXX/extern-section-attribut
erichkeane updated this revision to Diff 111061.
erichkeane added a comment.
Thinking about it further, the emit functions should be private in this case.
https://reviews.llvm.org/D36707
Files:
lib/CodeGen/CGBuiltin.cpp
lib/CodeGen/CodeGenFunction.h
Index: lib/CodeGen/CodeGenFunction.h
===
eandrews created this revision.
Update IR generated to retain section information for external declarations.
This is related to https://reviews.llvm.org/D36487
https://reviews.llvm.org/D36712
Files:
docs/LangRef.rst
Index: docs/LangRef.rst
==
erichkeane added a comment.
@efriedma : LangRef changed in this review: https://reviews.llvm.org/D36712
https://reviews.llvm.org/D36487
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commit
rnk added a comment.
tests?
Repository:
rL LLVM
https://reviews.llvm.org/D36371
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: alexshap
Date: Mon Aug 14 14:23:08 2017
New Revision: 310887
URL: http://llvm.org/viewvc/llvm-project?rev=310887&view=rev
Log:
[analyzer] Fix SimpleSValBuilder::simplifySVal
This diff fixes a crash (triggered assert) on the newly added test case.
In the method Simplifier::VisitSymbolData
This revision was automatically updated to reflect the committed changes.
Closed by commit rL310887: [analyzer] Fix SimpleSValBuilder::simplifySVal
(authored by alexshap).
Changed prior to commit:
https://reviews.llvm.org/D36564?vs=110502&id=111073#toc
Repository:
rL LLVM
https://reviews.ll
smeenai created this revision.
Herald added a subscriber: mgorny.
Add _LIBCPP_DISABLE_AVAILABILITY to the site config options, and add a
cmake option LIBCXX_DISABLE_AVAILABILITY to control the site config.
This is similar to other options which influence headers and therefore
shold have some way t
dcoughlin added a comment.
Thanks! This looks good to me, with the note about factoring out the duplicated
logic addressed, Would you factor out that logic into a static function and
update phabricator summary to be a commit message. Then I will commit!
Comment at: lib/Static
alexshap created this revision.
1. Add missing explicit.
2. Add missing std::move
(return type is Expected> but we return
std::vector, so cast to && is necessary).
Test plan: make check-all
Repository:
rL LLVM
https://reviews.llvm.org/D36715
Files:
include/clang/Tooling/Refactoring/Rena
efriedma added inline comments.
Comment at: docs/LangRef.rst:629
+corresponding to the LLVM module, section information specified in the
+declaration is retained in LLVM IR to enable OpenCL processes.
+
This doesn't really explain the part that matters. For Lang
mehdi_amini added a comment.
Seems fine to me. Adding @dexonsmith (I don't know who maintain libc++ at Apple
right now)
https://reviews.llvm.org/D36713
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/li
dexonsmith accepted this revision.
dexonsmith added a comment.
This revision is now accepted and ready to land.
LGTM.
https://reviews.llvm.org/D36713
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listi
mclow.lists added a comment.
What's the use case here? What are you trying to accomplish?
https://reviews.llvm.org/D36713
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
smeenai created this revision.
Herald added a subscriber: mgorny.
Some ABI macros affect headers, so it's nice to have a site config
option for them. Add a LIBCXX_ABI_DEFINES cmake macro to allow
specifying a list of ABI macros to define in the site config.
The primary design constraint (as discu
saugustine added a comment.
I've cleaned up this patch a bit. Now the only files that are in the x86_ARCH
group are those that require 80 bits floats and cpu_model.c. Tests for all of
these were already disabled on arm and powerpc (because neither has 80-bit
floats), so we knew these library fu
smeenai created this revision.
Herald added a subscriber: mgorny.
If we define cmake macros that require a site config, and then undefine
all such macros, a stale site config header will be left behind.
Explicitly delete any generate site config if we don't need one to avoid
this.
https://review
smeenai added a comment.
There should probably be some documentation for this, but I couldn't think of
the right place; the Using libc++ documentation only mentions the actual
configuration macros, not their corresponding cmake defines. Any suggestions?
https://reviews.llvm.org/D36719
_
Author: danalbert
Date: Mon Aug 14 16:19:38 2017
New Revision: 310895
URL: http://llvm.org/viewvc/llvm-project?rev=310895&view=rev
Log:
Fix LLVMgold plugin name/path for non-Linux.
Summary:
It's only named LLVMgold.so on Linux. Fix the name for Windows and
Darwin.
Also fix the path for Windows s
This revision was automatically updated to reflect the committed changes.
Closed by commit rL310895: Fix LLVMgold plugin name/path for non-Linux.
(authored by danalbert).
Repository:
rL LLVM
https://reviews.llvm.org/D35739
Files:
cfe/trunk/lib/Driver/ToolChains/CommonArgs.cpp
Index: cfe/t
On 14 August 2017 at 03:27, Diana Picus via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Hi,
>
> Strangely enough, it turns out that if I run
> Asan-armhf-with-calls-Noinst-Test on the command line it fails,
> although it doesn't fail when run with lit.
Looks like the crash is within the "
smeenai added a comment.
In https://reviews.llvm.org/D36713#841478, @mclow.lists wrote:
> What's the use case here? What are you trying to accomplish?
The `_LIBCPP_DISABLE_AVAILABILITY` macro already exists, but since it
influences headers, it's a lot more useful to have it as a site config o
Author: phosek
Date: Mon Aug 14 17:22:00 2017
New Revision: 310901
URL: http://llvm.org/viewvc/llvm-project?rev=310901&view=rev
Log:
[CMake] Include LLVMFuzzer in Fuchsia toolchain
Differential Revision: https://reviews.llvm.org/D36541
Modified:
cfe/trunk/cmake/caches/Fuchsia-stage2.cmake
M
This revision was automatically updated to reflect the committed changes.
Closed by commit rL310901: [CMake] Include LLVMFuzzer in Fuchsia toolchain
(authored by phosek).
Changed prior to commit:
https://reviews.llvm.org/D36541?vs=110452&id=03#toc
Repository:
rL LLVM
https://reviews.llv
Merged in r310902.
Thanks,
Hans
On Mon, Aug 14, 2017 at 4:03 AM, Alex L wrote:
> Sure, I committed r310829 which moves the lexical decl adjustment.
>
> Hans, can you please merge r310706 with r310829.
>
> Cheers,
> Alex
>
> On 12 August 2017 at 01:29, Richard Smith wrote:
>>
>> On 11 August 201
Author: danalbert
Date: Mon Aug 14 17:31:44 2017
New Revision: 310903
URL: http://llvm.org/viewvc/llvm-project?rev=310903&view=rev
Log:
Revert "Fix LLVMgold plugin name/path for non-Linux."
Broke a test. Will fix the test and re-land later.
Modified:
cfe/trunk/lib/Driver/ToolChains/CommonArg
rnk added a subscriber: gbiv.
rnk added a comment.
I looked at the blame, and I added this alignment thing in
https://reviews.llvm.org/rL289575 to deal with some PointerIntPair assertions.
Those probably started in @gbiv's https://reviews.llvm.org/rL270781, which
introduced a `PointerIntPair` f
Author: rnk
Date: Mon Aug 14 18:17:47 2017
New Revision: 310905
URL: http://llvm.org/viewvc/llvm-project?rev=310905&view=rev
Log:
Avoid PointerIntPair of constexpr EvalInfo structs
They are stack allocated, so their alignment is not to be trusted.
32-bit MSVC only guarantees 4 byte stack alignmen
rnk added a comment.
This shouldn't be necessary after https://reviews.llvm.org/rL310905.
https://reviews.llvm.org/D34873
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
hfinkel updated this revision to Diff 09.
hfinkel added a comment.
Rebased.
https://reviews.llvm.org/D32199
Files:
include/clang/Basic/Sanitizers.def
include/clang/Driver/SanitizerArgs.h
lib/CodeGen/BackendUtil.cpp
lib/CodeGen/CGDecl.cpp
lib/CodeGen/CGDeclCXX.cpp
lib/CodeGen/Cod
vsk updated this revision to Diff 13.
vsk added a comment.
Thanks for the review. I've updated the patch so that we do better with "#\"
directives.
https://reviews.llvm.org/D36642
Files:
include/clang/Lex/Preprocessor.h
lib/Lex/PPDirectives.cpp
test/CoverageMapping/preprocessor.c
t
hfinkel added inline comments.
Comment at: lib/CodeGen/CGDecl.cpp:1291
+// where the pointer to the local variable is the key in the map.
+void CodeGenFunction::EmitAutoVarNoAlias(const AutoVarEmission &emission) {
+ assert(emission.Variable && "emission was not valid!");
--
hfinkel updated this revision to Diff 29.
hfinkel added a comment.
Herald added a subscriber: javed.absar.
Rebased and addressing review comments.
https://reviews.llvm.org/D9403
Files:
lib/CodeGen/CGDecl.cpp
lib/CodeGen/CGExpr.cpp
lib/CodeGen/CGStmt.cpp
lib/CodeGen/CodeGenFunction.c
hfinkel updated this revision to Diff 30.
hfinkel added a comment.
Herald added a subscriber: jholewinski.
Rebased.
https://reviews.llvm.org/D22189
Files:
lib/CodeGen/CGDeclCXX.cpp
lib/CodeGen/CGExpr.cpp
lib/CodeGen/CGOpenMPRuntime.cpp
lib/CodeGen/CGOpenMPRuntimeNVPTX.cpp
lib/Code
yaxunl marked 6 inline comments as done.
yaxunl added inline comments.
Comment at: include/clang/Basic/SyncScope.h:92
+/// \brief Defines the synch scope ABI for OpenCL.
+class AtomicScopeOpenCLABI : public AtomicScopeABI {
+public:
rjmccall wrote:
> yaxunl wrote
srhines added a comment.
https://reviews.llvm.org/D36729 similarly fixes a few more instances of this
problem (discovered while running tests for this configuration).
https://reviews.llvm.org/D36728
___
cfe-commits mailing list
cfe-commits@lists.ll
arphaman accepted this revision.
arphaman added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D36728
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
101 - 161 of 161 matches
Mail list logo