mgehre added inline comments.
Comment at: test/clang-tidy/readability-redundant-inline.cpp:6
@@ +5,3 @@
+// CHECK-MESSAGES: :[[@LINE-1]]:14: warning: 'inline' is redundant because
method body is defined inside class [readability-redundant-inline]
+// CHECK-FIXES: {{^}} int f1()
alexfh accepted this revision.
alexfh added a comment.
LG. Thank you!
http://reviews.llvm.org/D18993
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
On Mon, Apr 11, 2016 at 11:15 PM, Martin Probst wrote:
>> > Was/is the 2 correct then? (if it was next(rbegin, 2) that'd be
>> > equivalent
>> > to prev(end, 3), yes?)
>>
>> I think it is from looking at the test case, looping in martin to see
>> whether I'm right :)
>
>
> At that point in the cod
Author: eugenis
Date: Mon Apr 11 17:27:55 2016
New Revision: 266005
URL: http://llvm.org/viewvc/llvm-project?rev=266005&view=rev
Log:
Allow simultaneous safestack and stackprotector attributes.
This is the clang part of http://reviews.llvm.org/D18846.
SafeStack instrumentation pass adds stack pro
rjmccall added a comment.
In the cases where we can emit nonnull, I agree that we should be able to
safely use dereferenceable for the non-virtual data size of of the type. I'm
not too concerned about people calling methods on entirely the wrong type,
especially to the relatively small degree
>
> > Was/is the 2 correct then? (if it was next(rbegin, 2) that'd be
> equivalent
> > to prev(end, 3), yes?)
>
> I think it is from looking at the test case, looping in martin to see
> whether I'm right :)
At that point in the code, we have [..., PrePrev = '@', Prev = 'SomeToken']
and CurrentTok
alexfh added inline comments.
Comment at: clang-tidy/readability/DeletedDefaultCheck.cpp:28
@@ +27,3 @@
+ // - actually deleted
+ // - not in template instantiation.
+ const auto isBadlyDefaulted =
For decls there is `isInstantiated()`, which is defined as
tigerleapgorge closed this revision.
tigerleapgorge added a comment.
Patch committed @r265982.
http://reviews.llvm.org/D18879
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
bruno created this revision.
bruno added a reviewer: doug.gregor.
bruno added subscribers: manmanren, dexonsmith, cfe-commits.
Under certain conditions clang currently fails to properly diagnostic ObjectC
parameter list when type args and protocols are mixed in the same list. This
happens when the
ab created this revision.
ab added reviewers: rjmccall, uweigand, t.p.northover.
ab added a subscriber: cfe-commits.
Herald added a subscriber: aemerson.
Currently, for the ppc64--gnu and aarch64 ABIs, we recognize:
```
typedef __attribute__((__ext_vector_type__(3))) float v3f32;
typedef __attri
rjmccall added a comment.
Seems okay to me. Normally we wouldn't want to remove an attribute from the
DeclSpec because it can apply to multiple declarators, but that's not possible
with a block-literal declarator, so it's fine. Richard should sign off, though.
http://reviews.llvm.org/D18567
Author: dcoughlin
Date: Mon Apr 11 19:53:26 2016
New Revision: 266031
URL: http://llvm.org/viewvc/llvm-project?rev=266031&view=rev
Log:
[analyzer] Fix assertion in ReturnVisitor for body-farm synthesized getters
Don't emit a path note marking the return site if the return statement does not
have a
dyung created this revision.
dyung added reviewers: rsmith, ygao.
dyung added a subscriber: cfe-commits.
On the PS4, the default C standard is C99 which differs from the current
default of C11. This patch makes the default C99 when targeting the PS4. This
change includes the changes previously p
Hi,
r260990 exposed -isystem in clang-cl. -isystem adds a directory to the
front of the system include search path. The idea was to use this to point
to a hermetic msvc install, but as it turns out this doesn't work: -isystem
then adds the hermetic headers in front of clang's builtin headers, and
Author: compnerd
Date: Mon Apr 11 22:05:03 2016
New Revision: 266039
URL: http://llvm.org/viewvc/llvm-project?rev=266039&view=rev
Log:
Basic: fix profiling with GNU EABI
The GNU profiling support indicates that the interface is `_mcount` rather than
`mcount`. Conditionalise the behaviour accordi
rjmccall added a comment.
IIRC, isInSystemHeader isn't a terribly cheap check. Please extract this into
a function that only needs to be called if the other checks succeed.
You should also be able to just ask about the first declaration. There are
contrived situations where isInSystemHeader c
bruno updated this revision to Diff 53363.
bruno added a comment.
Hi Richard & Ben,
Thanks for the review!
I've attached a new patch and changed the approach: made
findUsableModuleForHeader receive a FileName
instead of FileEntry. Answering the questions below:
FileManager::getFile returns th
EricWF created this revision.
EricWF added a subscriber: cfe-commits.
http://reviews.llvm.org/D19006
Files:
include/tuple
test/std/utilities/tuple/tuple.tuple/tuple.cnstr/alloc_UTypes.pass.cpp
Index: test/std/utilities/tuple/tuple.tuple/tuple.cnstr/alloc_UTypes.pass.cpp
=
Author: abataev
Date: Tue Apr 12 00:28:34 2016
New Revision: 266041
URL: http://llvm.org/viewvc/llvm-project?rev=266041&view=rev
Log:
[OPENMP 4.0] Support for 'uniform' clause in 'declare simd' directive.
OpenMP 4.0 defines clause 'uniform' in 'declare simd' directive:
'uniform' '(' ')'
The unif
Author: mgehre
Date: Tue Apr 12 00:43:18 2016
New Revision: 266043
URL: http://llvm.org/viewvc/llvm-project?rev=266043&view=rev
Log:
[ASTMatchers]: fix crash in hasReturnValue
Summary:
The crash was reproduced by the included test case. It was initially
found through a crash of clang-tidy's misc-
This revision was automatically updated to reflect the committed changes.
Closed by commit rL266043: [ASTMatchers]: fix crash in hasReturnValue (authored
by mgehre).
Changed prior to commit:
http://reviews.llvm.org/D18991?vs=53311&id=53367#toc
Repository:
rL LLVM
http://reviews.llvm.org/D18
This revision was automatically updated to reflect the committed changes.
Closed by commit rL266044: [clang-tidy] fix
readability-avoid-const-params-in-decls creating invalid… (authored by mgehre).
Changed prior to commit:
http://reviews.llvm.org/D18993?vs=53322&id=53368#toc
Repository:
rL L
Author: mgehre
Date: Tue Apr 12 00:45:13 2016
New Revision: 266044
URL: http://llvm.org/viewvc/llvm-project?rev=266044&view=rev
Log:
[clang-tidy] fix readability-avoid-const-params-in-decls creating invalid code
in fix-its
Summary:
The Fix-Its for the added test cases were before:
-void F11(cons
doug.gregor added a comment.
I think it's completely reasonable to implement support for VLAs as a GNU C++
extension. We did go through a phase where we tried to avoid implementing VLAs
in C++ because we considered them to be a poor feature in C++. However, their
use was wide-spread enough that
joker.eph closed this revision.
joker.eph added a comment.
r265977
http://reviews.llvm.org/D18947
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
twoh updated this revision to Diff 53369.
twoh added a comment.
Fix attribute annotation from 'const' to 'pure'. Add support for 'pure'
attribute to builtin function database related code. Test case
(test/Sema/libbuiltins-ctype.c) added. Line 116 of test/FixIt/typo.m is removed
because it is no
101 - 126 of 126 matches
Mail list logo