rsmith closed this revision.
rsmith added a comment.
Committed as r261034.
http://reviews.llvm.org/D16930
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: arsenm
Date: Tue Feb 16 18:27:27 2016
New Revision: 261042
URL: http://llvm.org/viewvc/llvm-project?rev=261042&view=rev
Log:
amdgcn: Use new workitem intrinsics
Added:
libclc/trunk/amdgcn/lib/workitem/
libclc/trunk/amdgcn/lib/workitem/get_group_id.ll
libclc/trunk/amdgcn/lib/wo
Author: arsenm
Date: Tue Feb 16 18:27:31 2016
New Revision: 261043
URL: http://llvm.org/viewvc/llvm-project?rev=261043&view=rev
Log:
Add .gitignore for build directories
Added:
libclc/trunk/.gitignore
Added: libclc/trunk/.gitignore
URL:
http://llvm.org/viewvc/llvm-project/libclc/trunk/.giti
doug.gregor added a comment.
The approach and patch look okay to me, but can we give "UnavailableCheck" a
less ambiguous name? For example, "TreatUnavailableAsInvalid"?
http://reviews.llvm.org/D15314
___
cfe-commits mailing list
cfe-commits@lists.l
Author: mehdi_amini
Date: Tue Feb 16 18:42:20 2016
New Revision: 261045
URL: http://llvm.org/viewvc/llvm-project?rev=261045&view=rev
Log:
Teach clang to use the ThinLTO pipeline
Summary: Use the new pipeline implemented in D17115
Reviewers: tejohnson
Subscribers: joker.eph, cfe-commits
Differe
jlebar created this revision.
jlebar added reviewers: rnk, majnemer.
jlebar added subscribers: tra, cfe-commits.
We need the notion of convergent functions -- which may expose
convergent behavior to callers -- and convergent calls, which are calls
where we would like to preserve convergent behavio
Author: davidxl
Date: Tue Feb 16 18:58:13 2016
New Revision: 261046
URL: http://llvm.org/viewvc/llvm-project?rev=261046&view=rev
Log:
Restrengthen tests relaxed in r259955
Modified:
cfe/trunk/test/CoverageMapping/ir.c
cfe/trunk/test/CoverageMapping/unused_names.c
Modified: cfe/trunk/test
Author: davidxl
Date: Tue Feb 16 18:59:01 2016
New Revision: 261047
URL: http://llvm.org/viewvc/llvm-project?rev=261047&view=rev
Log:
Test simplification
Modified:
cfe/trunk/test/Profile/def-assignop.cpp
Modified: cfe/trunk/test/Profile/def-assignop.cpp
URL:
http://llvm.org/viewvc/llvm-proj
Author: silvas
Date: Tue Feb 16 20:08:19 2016
New Revision: 261053
URL: http://llvm.org/viewvc/llvm-project?rev=261053&view=rev
Log:
[AttrDocs.td] Fix up some reST syntax.
Modified:
cfe/trunk/include/clang/Basic/AttrDocs.td
Modified: cfe/trunk/include/clang/Basic/AttrDocs.td
URL:
http://llv
Btw, thanks to nlewycky to pointing this out.
-- Sean Silva
On Tue, Feb 16, 2016 at 6:08 PM, Sean Silva via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: silvas
> Date: Tue Feb 16 20:08:19 2016
> New Revision: 261053
>
> URL: http://llvm.org/viewvc/llvm-project?rev=261053&view=rev
>
Author: chandlerc
Date: Tue Feb 16 20:13:35 2016
New Revision: 261054
URL: http://llvm.org/viewvc/llvm-project?rev=261054&view=rev
Log:
[cmake] Revert r260742 (and r260744) to improve order file support.
This appears to be passing '-Wl,-order_file' to Linux link commands,
which then causes the li
FYI, I had to revert this in r261054 because it caused Linux links to write
the output to 'rder_file' in all cases. See that commit for some details,
and I think several build bots hit this as well. Happy to chat to help
figure out what to do long term.
-Chandler
On Fri, Feb 12, 2016 at 1:41 PM C
jlebar updated this revision to Diff 48143.
jlebar added a comment.
Fix typo.
http://reviews.llvm.org/D17313
Files:
lib/CodeGen/CGCall.cpp
test/CodeGenCUDA/convergent.cu
test/CodeGenCUDA/device-var-init.cu
Index: test/CodeGenCUDA/device-var-init.cu
===
ABataev added inline comments.
Comment at: lib/CodeGen/CGOpenMPRuntime.cpp:3811-3818
@@ -3789,1 +3810,10 @@
DeviceID, FileID, ParentName, Line, Column, OutlinedFn, OutlinedFnID);
+
+ // If the current target region has a teams region enclosed, we need to get
+ // the numb
ABataev added inline comments.
Comment at: lib/CodeGen/CGOpenMPRuntime.cpp:3901-3932
@@ +3900,34 @@
+// Reference types are ignored for mapping purposes.
+if (auto *RefTy = ExprTy->getAs())
+ ExprTy = RefTy->getPointeeType().getCanonicalType();
+
+// Given that an
compnerd added a comment.
This change seems fine to me as is, just waiting to iron out the macro
situation with @logan before accepting it.
Comment at: lib/Headers/unwind.h:61
@@ +60,3 @@
+#define _UNWIND_ARM_EHABI 0
+#endif
+
logan wrote:
> Since this is `unwi
On Thu, Feb 4, 2016 at 8:12 PM, Saleem Abdulrasool via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: compnerd
> Date: Thu Feb 4 22:12:40 2016
> New Revision: 259874
>
> URL: http://llvm.org/viewvc/llvm-project?rev=259874&view=rev
> Log:
> CodeGen: correct Windows ARM C++ assertion
>
ABataev added a comment.
Carlo, thanks for the patch! Please update the code to trunk HEAD
Comment at: lib/CodeGen/CGOpenMPRuntime.h:677
@@ -676,1 +676,3 @@
+ virtual bool isStaticNonchunked(OpenMPDistScheduleClauseKind ScheduleKind,
+ bool Ch
ryee88 updated this revision to Diff 48149.
ryee88 added a comment.
Keeping the number of test files to a minimum makes sense.
Couldn't find an existing test for this diagnostic. I did find a
cxx-reference.cpp that tests reference diagnostics so this seems like a
reasonable location for this ne
Ugh... That is most scary. Do you happen to know if this occurred with Gold,
GNU ld or both? I had tested this patch on Darwin, FreeBSD and Linux with GNU
ld. For that error to happen it means that the linker isn't handling
-order_file as an invalid argument instead it is treating it as a "-o" a
On Tue, Feb 16, 2016 at 10:01 PM, Ryan Yee via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> ryee88 updated this revision to Diff 48149.
> ryee88 added a comment.
>
> Keeping the number of test files to a minimum makes sense.
>
> Couldn't find an existing test for this diagnostic.
That woul
danielmarjamaki marked 2 inline comments as done.
Comment at: docs/clang-tidy/checks/readability-non-const-parameter.rst:15
@@ +14,3 @@
+
+ // warning here; p should be const
+ char f1(char *p) {
LegalizeAdulthood wrote:
> With pointers, there are always two lay
101 - 122 of 122 matches
Mail list logo