This revision was automatically updated to reflect the committed changes.
Closed by commit rL258870: Fix Clang-tidy modernize-use-override warning in
unittests/clang… (authored by eugenezelenko).
Changed prior to commit:
http://reviews.llvm.org/D16566?vs=45938&id=46054#toc
Repository:
rL LLV
tra updated this revision to Diff 46055.
tra marked 6 inline comments as done.
tra added a comment.
Fixed few issues revealed by -Wdouble-promotion
http://reviews.llvm.org/D16593
Files:
lib/Headers/CMakeLists.txt
lib/Headers/__clang_cuda_cmath.h
lib/Headers/__clang_cuda_runtime_wrapper.h
tra added inline comments.
Comment at: lib/Headers/__clang_cuda_cmath.h:33
@@ +32,3 @@
+// builtins if CUDA does not provide a suitable function.
+// We also provide device-side std::abs() for integer types.
+
jlebar wrote:
> Why is std::abs a special case that ne
mclow.lists created this revision.
mclow.lists added reviewers: EricWF, howard.hinnant.
mclow.lists added a subscriber: cfe-commits.
This is part of the Library Fundamentals 2 TS
http://reviews.llvm.org/D16605
Files:
include/experimental/iterator
test/std/experimental/iterator/nothing_to_do.
Author: majnemer
Date: Tue Jan 26 17:14:47 2016
New Revision: 258877
URL: http://llvm.org/viewvc/llvm-project?rev=258877&view=rev
Log:
[WinEH] Annotate calls to __RTtypeid with a funclet bundle
Clang's CodeGen has several paths which end up invoking or calling a
function. The one that we used for
Sunil_Srivastava created this revision.
Sunil_Srivastava added a reviewer: rsmith.
Sunil_Srivastava added a subscriber: cfe-commits.
We are planning to upstream changes needed for maintaining PS4 ABI across
future releases.
Unlike many other targets, we need to maintain, in most cases, strict ob
> Eric, Marshall, what do you think about using only /*...*/-style
comments in these headers, to handle the case where libc++ is somehow in
the include path for a C89 compilation?
I'm NOT OK with this in general. These are C++ standard library headers
that are written in C++. These headers should
Author: tra
Date: Tue Jan 26 17:37:29 2016
New Revision: 258880
URL: http://llvm.org/viewvc/llvm-project?rev=258880&view=rev
Log:
[CUDA] Implemented device-side support functions in .
CUDA expects math functions in std:: namespace to work on device side.
In order to make it work with clang withou
This revision was automatically updated to reflect the committed changes.
Closed by commit rL258880: [CUDA] Implemented device-side support functions in
. (authored by tra).
Changed prior to commit:
http://reviews.llvm.org/D16593?vs=46055&id=46066#toc
Repository:
rL LLVM
http://reviews.llvm
Author: dcoughlin
Date: Tue Jan 26 17:58:48 2016
New Revision: 258886
URL: http://llvm.org/viewvc/llvm-project?rev=258886&view=rev
Log:
[analyzer] Body farm: Look for property ivar in shadowing readwrite property.
After r251874, readonly properties that are shadowed by a readwrite property
in a c
As per the discussion on http://reviews.llvm.org/D16408, I've merged
this in r258887.
On Thu, Jan 21, 2016 at 9:36 AM, Daniel Sanders
wrote:
> I'm not sure why my reply-all dropped Hans from the recipients. Re-added
> him.
>
>
>
> From: cfe-commits [mailto:cfe-commits-boun...@lists.llvm.org] On B
Author: hans
Date: Tue Jan 26 18:07:27 2016
New Revision: 258887
URL: http://llvm.org/viewvc/llvm-project?rev=258887&view=rev
Log:
Merging r258403:
r258403 | dsanders | 2016-01-21 07:35:15 -0800 (Thu, 21 Jan 2016) | 7 lines
EricWF updated this revision to Diff 46071.
EricWF added a comment.
Address @mclow.lists comment about `__get_node_unchecked()`'s name.
http://reviews.llvm.org/D15836
Files:
include/__config
include/forward_list
test/std/containers/sequences/forwardlist/incomplete.pass.cpp
Index: test/st
EricWF accepted this revision.
EricWF added a reviewer: EricWF.
EricWF added a comment.
This revision is now accepted and ready to land.
Accepting on phab to reflect @mclow.lists LGTM.
Comment at: include/forward_list:369
@@ +368,3 @@
+}
+__node_pointer __get_node_unchec
This revision was automatically updated to reflect the committed changes.
Closed by commit rL25: [libcxx] Fix undefined behavior in forward_list
(authored by EricWF).
Changed prior to commit:
http://reviews.llvm.org/D15836?vs=46071&id=46073#toc
Repository:
rL LLVM
http://reviews.llvm.or
Author: ericwf
Date: Tue Jan 26 18:11:54 2016
New Revision: 25
URL: http://llvm.org/viewvc/llvm-project?rev=25&view=rev
Log:
[libcxx] Fix undefined behavior in forward_list
Summary:
This patch is similar to the fix but it has a few differences. This
patch doesn't use a `__link_pointer`
hubert.reinterpretcast added a comment.
In http://reviews.llvm.org/D15120#336430, @rjmccall wrote:
> As I understand it, PPC's long-double (~103 bits of precision) is still
> strictly less precise than float128_t (113 bits of precision), so it ought to
> be have lower rank. Is there actually a
Hello everyone,
Below are some buildbot numbers for the last week of 1/17/2016 - 1/23/2016.
Thanks
Galina
Number of commits by project:
project | commits
---+---
llvm | 315
cfe |86
vkalintiris created this revision.
vkalintiris added reviewers: dsanders, mclow.lists, EricWF, jroelofs.
vkalintiris added a subscriber: cfe-commits.
This fixes the tests under std/atomics for 32-bit MIPS CPUs where the
8-byte atomic operations call into the libatomic library.
http://reviews.llvm
Author: ericwf
Date: Tue Jan 26 18:49:20 2016
New Revision: 258893
URL: http://llvm.org/viewvc/llvm-project?rev=258893&view=rev
Log:
Fix broken commit r25. I missed adding two pointer conversions
Modified:
libcxx/trunk/include/forward_list
Modified: libcxx/trunk/include/forward_list
URL:
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
http://reviews.llvm.org/D16613
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cf
silvas added inline comments.
Comment at: lib/Driver/Tools.cpp:5520
@@ +5519,3 @@
+A->claim();
+if ((StringRef(A->getValue(0)) == "-fprofile-ir-instr") &&
+(Args.hasArg(options::OPT_fprofile_instr_generate) ||
This is definitely not the right thing
rjmccall added a comment.
In http://reviews.llvm.org/D15120#336776, @hubert.reinterpretcast wrote:
> In http://reviews.llvm.org/D15120#336430, @rjmccall wrote:
>
> > As I understand it, PPC's long-double (~103 bits of precision) is still
> > strictly less precise than float128_t (113 bits of pre
Author: jyknight
Date: Tue Jan 26 19:04:51 2016
New Revision: 258894
URL: http://llvm.org/viewvc/llvm-project?rev=258894&view=rev
Log:
Revert "Change of UserLabelPrefix default value from "_" to """
This reverts commit r258504.
This commit breaks (at least) sparc-rtems -- the OS (RTEMS) used to
ahatanak added inline comments.
Comment at: lib/CodeGen/ModuleBuilder.cpp:219
@@ -211,2 +218,3 @@
+ }
}
Is it possible to avoid the code duplication if the condition is inverted as
shown below?
if (!Diags.hasErrorOccurred())
// call Builder->Releas
I reverted this change with r258894, as it breaks (at least) sparc-rtems.
Clearly this area of the code was not sufficiently covered by the testsuite.
On Fri, Jan 22, 2016 at 10:24 AM, Andrey Bokhanko via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: asbokhan
> Date: Fri Jan 22 09:24
hubert.reinterpretcast added a comment.
In http://reviews.llvm.org/D15120#336827, @rjmccall wrote:
> Here's the thing, though: I don't think there's a reasonable language
> solution here besides saying that float128_t has higher rank. You can't make
> the types incompatible, because it's clear
Author: dcoughlin
Date: Tue Jan 26 19:41:58 2016
New Revision: 258896
URL: http://llvm.org/viewvc/llvm-project?rev=258896&view=rev
Log:
[analyzer] ObjCDeallocChecker: Only operate on classes with retained properties.
Previously the ObjC Dealloc Checker only checked classes with ivars, not
retaine
This revision was automatically updated to reflect the committed changes.
Closed by commit rL258896: [analyzer] ObjCDeallocChecker: Only operate on
classes with retained properties. (authored by dcoughlin).
Changed prior to commit:
http://reviews.llvm.org/D5023?vs=45756&id=46087#toc
Repository
Author: ahatanak
Date: Tue Jan 26 19:55:11 2016
New Revision: 258900
URL: http://llvm.org/viewvc/llvm-project?rev=258900&view=rev
Log:
[libcxx] Remove -Wpadded from buildit script.
Per discussion with Eric and Joerg, this commit removes -Wpadded to
silence the warning about the padding inserted a
ahatanak abandoned this revision.
ahatanak added a comment.
Abandoning this patch as I've removed -Wpadded in r258900.
http://reviews.llvm.org/D15897
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listi
LegalizeAdulthood added inline comments.
Comment at: clang-tidy/modernize/RawStringLiteralCheck.cpp:35
@@ +34,3 @@
+ const bool HasBackSlash = Text.find(R"(\\)") != StringRef::npos;
+ const bool HasNewLine = Text.find(R"(\n)") != StringRef::npos;
+ const bool HasQuote = Text.fi
george.burgess.iv added a reviewer: hfinkel.
george.burgess.iv updated this revision to Diff 46088.
george.burgess.iv added a comment.
+hfinkel as a reviewer, because `git` said he originally added the tests I'm
removing.
I played around a bit, and it turns out that we don't generate correct mac
Author: ygao
Date: Tue Jan 26 20:18:28 2016
New Revision: 258902
URL: http://llvm.org/viewvc/llvm-project?rev=258902&view=rev
Log:
Adding a test for PR25717.
The test tries to produce a large preprocessed output to the console, and checks
that we do not see any unexpected fatal errors.
The test
arsenm closed this revision.
arsenm added a comment.
r258794
http://reviews.llvm.org/D16498
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
rjmccall added a comment.
In http://reviews.llvm.org/D15120#336855, @hubert.reinterpretcast wrote:
> In http://reviews.llvm.org/D15120#336827, @rjmccall wrote:
>
> > Here's the thing, though: I don't think there's a reasonable language
> > solution here besides saying that float128_t has higher
rtrieu added a comment.
It looks like you are limiting to one diagnostic per printf, no matter the
number of format strings. How is the case when multiple format strings would
trigger the warning?
http://reviews.llvm.org/D15636
___
cfe-commits ma
pxli168 marked 6 inline comments as done.
pxli168 added a comment.
I will separate this patch into small ones.
Comment at: lib/Sema/SemaDecl.cpp:5724
@@ +5723,3 @@
+ R->isPipeType()) {
+Diag(D.getIdentifierLoc(),
+ diag::err_opencl_type_can_only_be_used_as_funct
hubert.reinterpretcast added a comment.
In http://reviews.llvm.org/D15120#336891, @rjmccall wrote:
> > The C committee decided that "undefined behavior" was what they could agree
> > on for this sort of case.
>
>
> That's only when the operand value is actually outside of the range of the
> typ
pxli168 added inline comments.
Comment at: test/Parser/opencl-image-access.cl:9
@@ -7,1 +8,3 @@
+#if CL20
__kernel void f__rw(__read_write image2d_t a) { }
+#endif
Anastasia wrote:
> Btw, I can see that read_write is now accepted even if -cl-std=CL1.1. So
> esse
LegalizeAdulthood updated this revision to Diff 46101.
LegalizeAdulthood marked 2 inline comments as done.
LegalizeAdulthood added a comment.
Update from comments:
- leave existing raw string literals unchanged
- don't change UTF-8, UTF-16, UTF-32 or wide character string literals
- apply changes
rjmccall added a comment.
In http://reviews.llvm.org/D15120#336996, @hubert.reinterpretcast wrote:
> In http://reviews.llvm.org/D15120#336891, @rjmccall wrote:
>
> > > The C committee decided that "undefined behavior" was what they could
> > > agree on for this sort of case.
> >
> >
> > That's o
Author: danielmarjamaki
Date: Wed Jan 27 01:33:50 2016
New Revision: 258911
URL: http://llvm.org/viewvc/llvm-project?rev=258911&view=rev
Log:
Fix array index out of bounds
Differential Revision: http://reviews.llvm.org/D16582
Modified:
cfe/trunk/lib/Driver/MSVCToolChain.cpp
Modified: cfe/tr
This revision was automatically updated to reflect the committed changes.
Closed by commit rL258911: Fix array index out of bounds (authored by
danielmarjamaki).
Changed prior to commit:
http://reviews.llvm.org/D16582?vs=45991&id=46102#toc
Repository:
rL LLVM
http://reviews.llvm.org/D16582
101 - 144 of 144 matches
Mail list logo