ayartsev updated this revision to Diff 42762.
ayartsev added a comment.
Updated the patch following Laszlo's advises:
+ Changed config file format to YAML.
+ Dump current configuration.
+ Search for config file from the current folder and upper.
In http://reviews.llvm.org/D14629#294023, @jroelofs
ayartsev added a comment.
Upd: Forgot to remove the printHash() subroutine from libscanbuild.pm. Using it
locally for debug purpose.
http://reviews.llvm.org/D14629
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bi
eugenis updated this revision to Diff 42782.
eugenis marked 3 inline comments as done.
Repository:
rL LLVM
http://reviews.llvm.org/D15367
Files:
include/clang/Driver/Options.td
include/clang/Driver/SanitizerArgs.h
include/clang/Frontend/CodeGenOptions.def
lib/CodeGen/CGClass.cpp
lib/
eugenis added inline comments.
Comment at: lib/CodeGen/CGExpr.cpp:3871
@@ +3870,3 @@
+isa(MD) && dyn_cast(MD)->isDistinct();
+if (CGM.getCodeGenOpts().SanitizeCfiCrossDso && !hasLocalScope) {
+ EmitCfiSlowPathCheck(BitSetTest, MD, CastedCallee);
p
mcrosier added a comment.
In http://reviews.llvm.org/D15195#307136, @hfinkel wrote:
> Can you use a StringSet instead of a vector and avoid all (most) of the code
> iterating over the vector of builtins being disabled?
Hi Hal,
I began converting the code to use StringSets, but I soon realized
nikola created this revision.
nikola added a reviewer: rsmith.
nikola added a subscriber: cfe-commits.
Current diagnostic says "expected expression" or "reference to non-static
member function must be called". This should fix PR13566 and PR18995
http://reviews.llvm.org/D15509
Files:
lib/Parse
On Fri, Dec 11, 2015 at 6:19 PM, Justin Bogner wrote:
> Easwaran Raman writes:
>> eraman updated this revision to Diff 42549.
>> eraman added a comment.
>>
>> Added a test case.
>>
>>
>> Repository:
>> rL LLVM
>>
>> http://reviews.llvm.org/D15163
>>
>> Files:
>> lib/CodeGen/CodeGenModule.cpp
pcc added a comment.
Please add documentation. At the very least please document flags in
`docs/ControlFlowIntegrity.rst` and `docs/UsersManual.rst`. We should also
document the design in `docs/ControlFlowIntegrityDesign.rst`.
Comment at: lib/CodeGen/CGExpr.cpp:3868
@@ +3867,3
silvas added a comment.
In http://reviews.llvm.org/D15462#309889, @beanz wrote:
> Sean,
>
> The reason for restricting to Unix is two fold. (1) the shell script goop,
> which I can replace with python and (2) I don't have a windows box to test
> on, so I didn't want people to think it worked.
>
Author: rafael
Date: Mon Dec 14 17:17:07 2015
New Revision: 255572
URL: http://llvm.org/viewvc/llvm-project?rev=255572&view=rev
Log:
Update for llvm api change.
Modified:
cfe/trunk/lib/CodeGen/CodeGenAction.cpp
Modified: cfe/trunk/lib/CodeGen/CodeGenAction.cpp
URL:
http://llvm.org/viewvc/ll
On Fri, Dec 11, 2015 at 6:19 PM, Justin Bogner wrote:
> Easwaran Raman writes:
>> eraman updated this revision to Diff 42549.
>> eraman added a comment.
>>
>> Added a test case.
>>
>>
>> Repository:
>> rL LLVM
>>
>> http://reviews.llvm.org/D15163
>>
>> Files:
>> lib/CodeGen/CodeGenModule.cpp
Author: davidxl
Date: Mon Dec 14 17:26:46 2015
New Revision: 255576
URL: http://llvm.org/viewvc/llvm-project?rev=255576&view=rev
Log:
[PGO] Shorten profile symbol prefixes
(test case update)
Profile symbols have long prefixes which waste space and creating pressure for
linker.
This patch shorten
On Fri, Dec 11, 2015 at 6:12 PM, Justin Bogner
wrote:
> Easwaran Raman writes:
> > eraman added a comment.
> >
> > I have reverted the commit in r255416 because the test failed in many
> > architectures.
>
> You also committed without waiting for further review, despite that
> David said "LGTM b
On Mon, Dec 14, 2015 at 3:26 PM, Xinliang David Li
wrote:
> On Fri, Dec 11, 2015 at 6:19 PM, Justin Bogner
> wrote:
> > Easwaran Raman writes:
> >> eraman updated this revision to Diff 42549.
> >> eraman added a comment.
> >>
> >> Added a test case.
> >>
> >>
> >> Repository:
> >> rL LLVM
> >
LGTM, please commit (if you like, if you want to wait for other feedback
that's OK too)
On Tue, Dec 15, 2015 at 2:15 AM, Nico Weber wrote:
> On Sun, Dec 13, 2015 at 6:57 PM, David Blaikie wrote:
>
>> (attachment missing)
>>
>
> (whoops. looks as expected though, here it is.)
>
> Cursory review
On Tue, Dec 15, 2015 at 5:46 AM, Hans Wennborg via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: hans
> Date: Mon Dec 14 12:46:11 2015
> New Revision: 255524
>
> URL: http://llvm.org/viewvc/llvm-project?rev=255524&view=rev
> Log:
> clang-cl: make /Wall turn on both -Wall and -Wextra (
On Mon, Dec 14, 2015 at 3:47 PM, David Blaikie via cfe-commits
wrote:
> On Tue, Dec 15, 2015 at 5:46 AM, Hans Wennborg via cfe-commits
> wrote:
>>
>> Author: hans
>> Date: Mon Dec 14 12:46:11 2015
>> New Revision: 255524
>>
>> URL: http://llvm.org/viewvc/llvm-project?rev=255524&view=rev
>> Log:
>
djasper added a comment.
I'd just prefer the setting of the new option and ignore the old one then, but
I don't think it matters to much. Warning or err'ing out also seems like a
reasonable approach.
http://reviews.llvm.org/D10370
___
cfe-commits
eraman updated this revision to Diff 42797.
eraman added a comment.
Updated the patch addressing Justin's comments and a new test case.
(Should I open a new review thread since phabricator thinks this has been
submitted?)
Repository:
rL LLVM
http://reviews.llvm.org/D15163
Files:
lib/Code
eraman updated this revision to Diff 42801.
eraman added a comment.
Fix the comment in the test case
Repository:
rL LLVM
http://reviews.llvm.org/D15163
Files:
lib/CodeGen/CodeGenModule.cpp
test/Profile/Inputs/max-function-count.proftext
test/Profile/max-function-count.c
Index: test/Pr
Author: ericwf
Date: Mon Dec 14 18:32:21 2015
New Revision: 255585
URL: http://llvm.org/viewvc/llvm-project?rev=255585&view=rev
Log:
Fix various GCC mis-configurations for newer versions.
This patch goes through and enables C++11 and C++14 features for newer GCC's.
The main changes are:
1. Turn
Author: davidxl
Date: Mon Dec 14 18:33:12 2015
New Revision: 255587
URL: http://llvm.org/viewvc/llvm-project?rev=255587&view=rev
Log:
[PGO] make profile prefix even shorter and more readable
Modified:
cfe/trunk/test/CoverageMapping/ir.c
cfe/trunk/test/CoverageMapping/unused_names.c
cf
samsonov added a comment.
Richard, could you take a look at this?
http://reviews.llvm.org/D15363
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
hfinkel added a comment.
In http://reviews.llvm.org/D15195#310395, @mcrosier wrote:
> In http://reviews.llvm.org/D15195#307136, @hfinkel wrote:
>
> > Can you use a StringSet instead of a vector and avoid all (most) of the
> > code iterating over the vector of builtins being disabled?
>
>
> Hi Ha
alexfh accepted this revision.
alexfh added a comment.
This revision is now accepted and ready to land.
Looks good with a few nits.
Thank you for the new awesome check!
Comment at: clang-tidy/misc/StringIntegerAssignmentCheck.cpp:74
@@ +73,3 @@
+return;
+ } else if (IsLite
eugenis added a comment.
added some docs
Comment at: lib/CodeGen/CodeGenModule.cpp:1041
@@ -988,3 +1040,3 @@
void CodeGenModule::addUsedGlobal(llvm::GlobalValue *GV) {
assert(!GV->isDeclaration() &&
"Only globals with definition can force usage.");
eugenis updated this revision to Diff 42806.
eugenis marked 2 inline comments as done.
Repository:
rL LLVM
http://reviews.llvm.org/D15367
Files:
docs/ControlFlowIntegrity.rst
docs/ControlFlowIntegrityDesign.rst
include/clang/Driver/Options.td
include/clang/Driver/SanitizerArgs.h
incl
bob.wilson added a comment.
Regarding the FIXME in lib/Frontend/CompilerInvocation.cpp: I agree with Hal
that you can remove that. We used to complain about unsupported -fno-builtin-*
options (and until now they have *all* been unsupported), but in r191434,
Rafael changed clang to silently igno
adek05 added a comment.
@aaron.ballman I think this could be hard to achieve without an extra note if
you have something like:
cat test2.c
int main() {
char *c = 'a';
char volatile** cc = &c;
cc = &c;
}
test2.c:2:15: warning: incompatible integer to po
Author: ericwf
Date: Mon Dec 14 19:41:41 2015
New Revision: 255599
URL: http://llvm.org/viewvc/llvm-project?rev=255599&view=rev
Log:
Mark declarations of externally instantiated functions as inline so GCC doesn't
complain.
Modified:
libcxx/trunk/include/valarray
Modified: libcxx/trunk/inclu
adek05 added inline comments.
Comment at: lib/Sema/SemaPseudoObject.cpp:739-751
@@ -738,15 +738,15 @@
// C++ class type.
if (!S.getLangOpts().CPlusPlus || !op->getType()->isRecordType()) {
QualType paramType = (*Setter->param_begin())->getType()
EricWF abandoned this revision.
EricWF added a comment.
Another fix was committed as r255599. It simply puts the inline keyword on the
declaration of the methods so that they are allowed to be inlined.
14.7.2 [temp.explicit]p10
> Except for inline functions, declarations with types deduced from
EricWF created this revision.
EricWF added reviewers: mclow.lists, danalbert, jroelofs.
EricWF added a subscriber: cfe-commits.
This patch allows GCC 4.6 and above to use `noexcept` as opposed to `throw()`.
Is it an ABI safe change to suddenly switch on `noexcept`? I imagine it must be
because
EricWF updated this revision to Diff 42813.
EricWF added a comment.
Woops. I forgot to turn off `noexcept` support in C++03 mode for GCC.
http://reviews.llvm.org/D15516
Files:
include/__config
Index: include/__config
===
--- inc
So, this change makes it impossible to download the build lots from the
Windows self-hosting builders because of -Wunused-parameter errors.
http://lab.llvm.org:8011/builders/clang-x86-win2008-selfhost/builds/5103/steps/build%20stage%202/logs/stdio
Maybe that's an indication that users don't really
majnemer created this revision.
majnemer added reviewers: rnk, andrew.w.kaylor, JosephTremoulet, sanjoy.
majnemer added a subscriber: cfe-commits.
majnemer added a dependency: D15517: [WinEH] Use operand bundles to describe
call sites.
This updates clang to use bundle operands to associate an inv
EricWF added a comment.
Pair and array look good. Still have to look at tuple.
Could you add test that check the overloads are actually `noexcept` as well?
Comment at: include/utility:139
@@ -132,2 +138,3 @@
+
// C++14
Can you add the by-type overloads to th
ABataev added inline comments.
Comment at: lib/Parse/ParseOpenMP.cpp:209
@@ -142,2 +208,3 @@
case OMPD_taskloop_simd:
+ default:
Diag(Tok, diag::err_omp_unexpected_directive)
fraggamuffin wrote:
> ABataev wrote:
> > Do not add default:, coding standard re
EricWF added a comment.
LGTM after the requested changes. Thanks.
Comment at:
test/std/utilities/tuple/tuple.tuple/tuple.elem/get_const_rv.fail.cpp:30
@@ +29,3 @@
+{
+cref(std::get<0>(tup4())); // expected-error {{call to deleted
function 'cref'}}
+}
-
EricWF added a comment.
In http://reviews.llvm.org/D14839#307171, @K-ballo wrote:
> In http://reviews.llvm.org/D14839#306306, @EricWF wrote:
>
> > int x = 42;
> > int const y = 43;
> > std::pair const p(x, y);
> > static_assert(std::is_same > decltype(std::get<0>(std::move(p)))>::value, "
rnk accepted this revision.
rnk added a comment.
This revision is now accepted and ready to land.
lgtm
http://reviews.llvm.org/D15518
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
101 - 141 of 141 matches
Mail list logo