Here too:
http://bb.pgr.jp/builders/ninja-clang-i686-msc18-R/builds/3285
http://bb.pgr.jp/builders/ninja-clang-i686-msc18-R/builds/3285/steps/test-clang/logs/Clang%20%3A%3A%20Driver__ps4-linker-win.c
2015-09-25 2:10 GMT+03:00 Romanova, Katya via cfe-commits <
cfe-commits@lists.llvm.org>:
> Hi,
labrinea added a comment.
In http://reviews.llvm.org/D12633#252758, @labrinea wrote:
> @t.p.northover I think we should not be defining _ARM_FP_FENV_ROUNDING on
> neither of ARM and AArch64 targets since "-frounding-math" is not available
> on clang: clang/llvm don't support C99 FP rounding mod
Author: kromanova
Date: Fri Sep 25 04:10:33 2015
New Revision: 248567
URL: http://llvm.org/viewvc/llvm-project?rev=248567&view=rev
Log:
New test ps4-linker-win.c (added in r48546) is causing problems for Windows
bots. I'm deleting this file during investigation.
Removed:
cfe/trunk/test/Drive
seaneveson added a comment.
I've realized that the patch doesn't handle pointers correctly, since a const
method can modify the memory pointed at by a member. While pointer members
should not be invalidated by const methods (if they are not mutable), the
memory they point to should still be inv
Author: abataev
Date: Fri Sep 25 05:37:12 2015
New Revision: 248569
URL: http://llvm.org/viewvc/llvm-project?rev=248569&view=rev
Log:
[OPENMP 4.1] Add 'threads' clause for '#pragma omp ordered'.
OpenMP 4.1 extends format of '#pragma omp ordered'. It adds 3 additional
clauses: 'threads', 'simd' an
chapuni added a subscriber: chapuni.
chapuni added a comment.
Would this cause bunch of failures if target is *-ps4 and SDK_DIR is empty?
clang-3.8: error: unable to find PS4 system headers directory, expected to be
in
'/home/buildbot/Buildbot/Slave/llvm-clang-lld-x86_64-scei-ps4-ubuntu-fast/
aaron.ballman added a subscriber: aaron.ballman.
aaron.ballman added a comment.
Thank you for working on this -- I think it's a good cleanup and feature-add! I
have a few minor comments, but generally LGTM. You should wait for an okay from
Richard, however.
Comment at: lib/Ana
aaron.ballman added a comment.
Ping?
http://reviews.llvm.org/D12945
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
zoran.jovanovic updated this revision to Diff 35727.
zoran.jovanovic added a comment.
Updated to follow new revision of patch for iterative compilation in llvm:
http://reviews.llvm.org/D12199
http://reviews.llvm.org/D12200
Files:
include/clang/Driver/Compilation.h
include/clang/Driver/Drive
seaneveson added a comment.
My initial approach was for the analyzer to have as much information as
possible after the loop. This means there are cases where the information is
incorrect. Future work would be to reduce these cases.
I believe your preferred approach is to have no inaccuracies af
Author: gbedwell
Date: Fri Sep 25 11:11:00 2015
New Revision: 248578
URL: http://llvm.org/viewvc/llvm-project?rev=248578&view=rev
Log:
Revert "This patch adds missing pieces to clang, including the PS4 toolchain
definition, added warnings, PS4 defaults, and Driver changes needed for our
compiler
Temporarily reverted in r248578 until we have implemented a solution for
the failure on the llvm-clang-lld-x86_64-scei-ps4-ubuntu-fast bot.
On 24 September 2015 at 23:06, Ekaterina Romanova via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: kromanova
> Date: Thu Sep 24 17:06:52 2015
>
alexfh accepted this revision.
alexfh added a comment.
This revision is now accepted and ready to land.
Looks good with a few comments.
Please tell me, if you need me to commit the patch for you after you address
the comments.
Comment at: clang-tidy/readability/IdentifierNamin
angelgarcia created this revision.
angelgarcia added a reviewer: alexfh.
angelgarcia added subscribers: klimek, cfe-commits.
create a check that replaces 'std::unique_ptr(new type(args...))' with
'std::make_unique(args...)'. It was on the list of "Ideas for new Tools".
It needs to be tested more
klimek added a comment.
This is definitely a useful check to have in modernize.
Comment at: clang-tidy/modernize/MakeUniqueCheck.cpp:25-27
@@ +24,5 @@
+
+/// \brief Returns the length of the token that goes since the beggining of the
+/// constructor call until the '<' of the te
Anastasia updated this revision to Diff 35732.
Anastasia added a comment.
Thanks! The review comments are addressed in this update!
http://reviews.llvm.org/D13105
Files:
include/clang/Basic/DiagnosticSemaKinds.td
include/clang/Basic/Specifiers.h
lib/AST/Decl.cpp
lib/AST/DeclPrinter.cpp
zarko added a comment.
Great!
I don't have commit access; would someone who does please land this?
Repository:
rL LLVM
http://reviews.llvm.org/D12982
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/l
Author: echristo
Date: Fri Sep 25 12:44:31 2015
New Revision: 248592
URL: http://llvm.org/viewvc/llvm-project?rev=248592&view=rev
Log:
The Clang gcc-compatible driver (clang/tools/driver/driver.cpp) has some
logic to select an alternate target based on the executable it was
called as. For instance
Anastasia created this revision.
Anastasia added a reviewer: pekka.jaaskelainen.
Anastasia added a subscriber: cfe-commits.
If address space (AS) of a variable/parameter declaration is not set, OpenCL2.0
s6.5 defines explicit rules for default ASes:
- The AS of global and local static variables
Oh, sure I can.
Done thusly:
dzur:~/sources/llvm/tools/clang> git svn dcommit
Committing to https://llvm.org/svn/llvm-project/cfe/trunk ...
M include/clang/Driver/ToolChain.h
M lib/Driver/ToolChain.cpp
M tools/driver/driver.cpp
Committed r248592
-eric
On Fri, Sep 25, 2015 at 10:20 AM Luke Zark
echristo added a subscriber: echristo.
echristo added a comment.
Oh, sure I can.
Done thusly:
dzur:~/sources/llvm/tools/clang> git svn dcommit
Committing to https://llvm.org/svn/llvm-project/cfe/trunk ...
M include/clang/Driver/ToolChain.h
M lib/Driver/ToolChain.cpp
M tools/driver/driver.cpp
Com
Author: alexfh
Date: Fri Sep 25 12:50:11 2015
New Revision: 248594
URL: http://llvm.org/viewvc/llvm-project?rev=248594&view=rev
Log:
[clang-tidy] Updated misc-unused-raii documentation.
Modified:
clang-tools-extra/trunk/clang-tidy/misc/UnusedRAIICheck.h
clang-tools-extra/trunk/docs/clang-
tra created this revision.
tra added a reviewer: echristo.
tra added a subscriber: cfe-commits.
- added detection of libdevice bitcode file and API to find one appropriate
for the GPU we're compiling for.
- added include paths to detected CUDA installation
- added include paths for -aux-tri
Author: gbiv
Date: Fri Sep 25 12:53:16 2015
New Revision: 248595
URL: http://llvm.org/viewvc/llvm-project?rev=248595&view=rev
Log:
Make incomplete type errors better with enable_if
This patch fixes the order in which we evaluate the different ways that
a function call could be disallowed. Now, if
Author: klimek
Date: Fri Sep 25 12:53:16 2015
New Revision: 248596
URL: http://llvm.org/viewvc/llvm-project?rev=248596&view=rev
Log:
Fix bug on reporting availability of deleted methods in libclang.
Patch by Sergey Kalinichev.
Added:
cfe/trunk/test/Index/availability.cpp
Modified:
cfe/tr
Submitted as r248596. Sergey, if you plan to work on libclang more, please
get commit access (it's easy :) Thx
On Fri, Sep 18, 2015 at 5:25 AM Milian Wolff wrote:
> milianw added a subscriber: milianw.
> milianw added a comment.
>
> Ping? Can someone please submit this upstream?
>
>
> http://re
klimek added a comment.
Submitted as r248596. Sergey, if you plan to work on libclang more, please
get commit access (it's easy :) Thx
http://reviews.llvm.org/D12666
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-
Sorry for the delay -- didn't see this email come in.
Committed as r248595. :)
On Tue, Sep 22, 2015 at 1:06 PM, Ettore Speziale
wrote:
> Hello,
>
> > Looks good to me!
> >
> > Do you have commit access, or would you like for me to commit it for you?
>
> I do not have commit access. It would be
tra created this revision.
tra added reviewers: echristo, eliben, jholewinski.
tra added a subscriber: cfe-commits.
Header files that come with CUDA are assuming split host/device compilation and
are not usable by clang out of the box.
With a bit of preprocessor magic it's possible to twist them
alexfh added a comment.
Awesome! This makes the check far more usable.
See a few minor comments in-line.
Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:140
@@ +139,3 @@
+ Finder->addMatcher(
+ namedDecl(unless(isExpansionInSystemHeader())).bind("decl"), this
george.burgess.iv updated this revision to Diff 35744.
george.burgess.iv marked an inline comment as done.
george.burgess.iv added a comment.
Addressed all feedback
http://reviews.llvm.org/D13157
Files:
lib/Analysis/CFG.cpp
test/Sema/warn-overlap.c
Index: test/Sema/warn-overlap.c
=
george.burgess.iv added inline comments.
Comment at: lib/Analysis/CFG.cpp:54
@@ +53,3 @@
+auto *DR = dyn_cast(E->IgnoreParenImpCasts());
+if (DR == nullptr)
+ return nullptr;
aaron.ballman wrote:
> Please don't compare a pointer against nullptr with a
Alexander_Droste added inline comments.
Comment at:
tools/clang/lib/StaticAnalyzer/Checkers/MPI-Checker/MPICheckerPathSensitive.cpp:35
@@ +34,3 @@
+ if (!isa(MR) ||
+ (ER && !isa(ER->getSuperRegion(
+return;
Thanks for the hint! I tried `iterBinding
tra updated this revision to Diff 35747.
tra added a comment.
Fixed typos and whitespace nits.
use #pragma push_macro for __CUDACC_RTC__, too.
http://reviews.llvm.org/D13171
Files:
lib/Headers/CMakeLists.txt
lib/Headers/clang_cuda_support.h
Index: lib/Headers/clang_cuda_support.h
=
jroelofs accepted this revision.
jroelofs added a reviewer: jroelofs.
jroelofs added a comment.
This revision is now accepted and ready to land.
Now that you've got http://reviews.llvm.org/D13155 squared away, LGTM.
http://reviews.llvm.org/D12996
__
dirty added a comment.
Should I go ahead and commit this change?
http://reviews.llvm.org/D12774
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
eliben added inline comments.
Comment at: lib/Headers/clang_cuda_support.h:53
@@ +52,3 @@
+// WARNING: Preprocessor hacks below are based on specific of
+// implementation of CUDA-7.0 headers and are expected to break with
+// any other version of CUDA headers.
If
aaron.ballman accepted this revision.
aaron.ballman added a reviewer: aaron.ballman.
aaron.ballman added a comment.
This revision is now accepted and ready to land.
Thanks, I think this looks good (pending confirmation from Richard).
~Aaron
http://reviews.llvm.org/D13157
Hi Pete,
Thanks for working on this.
+ class IntegerAlignment {
+ private:
+uint64_t Align;
You explain in the patch summary why this is here, but please add a comment
with the explanation as well.
Regarding the auto-upgrade, are we going to run into problems if we separate
our the 'vol
tra updated this revision to Diff 35760.
tra added a comment.
Include cuda.h and #error if we see wrong CUDA_VERSION.
http://reviews.llvm.org/D13171
Files:
lib/Headers/CMakeLists.txt
lib/Headers/clang_cuda_support.h
Index: lib/Headers/clang_cuda_support.h
==
tra marked an inline comment as done.
tra added a comment.
http://reviews.llvm.org/D13171
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
eliben accepted this revision.
eliben added a comment.
This revision is now accepted and ready to land.
lgtm
http://reviews.llvm.org/D13171
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-co
rjmccall added a comment.
X and Y aren't unreasonable for the operands, although you could also use
"left" and "right" (or LHS/RHS), especially since it's significant for
subtraction. R is short for "result" and should be spelled out. E is
presumably short for "encompassing", but that is not
Author: yrnkrn
Date: Fri Sep 25 17:09:07 2015
New Revision: 248626
URL: http://llvm.org/viewvc/llvm-project?rev=248626&view=rev
Log:
Relax test to allow for __attribute__((thiscall)). Under Win32 c-index-test
output is
CXXMethod=foo:4:7 (unavailable) [type=int () __attribute__((thiscall))]
[typ
tra created this revision.
tra added reviewers: eliben, jholewinski, echristo.
tra added a subscriber: cfe-commits.
Herald added a subscriber: jholewinski.
Currently 32-bit NVPTX happens to have 64-bit long which does not match host's
long in 32-bit mode.
http://reviews.llvm.org/D13181
Files:
Author: echristo
Date: Fri Sep 25 20:25:08 2015
New Revision: 248645
URL: http://llvm.org/viewvc/llvm-project?rev=248645&view=rev
Log:
Replace a loop and temporary string copying with llvm::join.
Modified:
cfe/trunk/lib/CodeGen/BackendUtil.cpp
Modified: cfe/trunk/lib/CodeGen/BackendUtil.cpp
sunfish added a comment.
This code has been questioned in this way before, and every time it comes up,
it turns out that there's a bug somewhere else that really ought to be fixed
anyway.
In previous iterations of this discussion, when clang is found attempting to
print something like a dep fi
Eugene.Zelenko created this revision.
Eugene.Zelenko added a reviewer: hans.
Eugene.Zelenko added a subscriber: cfe-commits.
Eugene.Zelenko set the repository for this revision to rL LLVM.
Also fixed Clang-tidy readability-simplify-boolean-expr in
tools/libclang/CIndex.cpp.
I checked this patch
dcoughlin requested changes to this revision.
dcoughlin added a comment.
This revision now requires changes to proceed.
Thanks for the patch Ismail! Some comments inline.
Comment at: lib/StaticAnalyzer/Core/Store.cpp:408
@@ +407,3 @@
+if (!Base.isZeroConstant()) {
+ if
Author: compnerd
Date: Fri Sep 25 22:26:44 2015
New Revision: 248649
URL: http://llvm.org/viewvc/llvm-project?rev=248649&view=rev
Log:
Driver: support ARM/HF on a single toolchain
ARM EABI adds target attributes to the object file. Amongst the attributes that
are emitted is the VFP argument pass
Author: ctopper
Date: Sat Sep 26 00:10:14 2015
New Revision: 248658
URL: http://llvm.org/viewvc/llvm-project?rev=248658&view=rev
Log:
Fix a couple other places that were returning SourceLocation by reference. NFC
Modified:
cfe/trunk/lib/CodeGen/CoverageMappingGen.cpp
Modified: cfe/trunk/lib/
Author: ctopper
Date: Sat Sep 26 00:10:16 2015
New Revision: 248659
URL: http://llvm.org/viewvc/llvm-project?rev=248659&view=rev
Log:
Remove move constructor and assignment operator from SourceMappingRegion. The
types of the fields are trivially copyable. NFC
Modified:
cfe/trunk/lib/CodeGen/
Author: ctopper
Date: Sat Sep 26 00:22:17 2015
New Revision: 248660
URL: http://llvm.org/viewvc/llvm-project?rev=248660&view=rev
Log:
Use None to avoid re-mentioning the ArrayRef type to call the default
constructor.
Modified:
cfe/trunk/include/clang/Analysis/Analyses/ThreadSafetyTIL.h
c
Author: ctopper
Date: Sat Sep 26 00:42:17 2015
New Revision: 248661
URL: http://llvm.org/viewvc/llvm-project?rev=248661&view=rev
Log:
Revert part of r248660 as using None didn't work with the ArrayRef being
returned as an Optional.
Modified:
cfe/trunk/lib/AST/Type.cpp
Modified: cfe/trunk/li
nemanjai created this revision.
nemanjai added reviewers: wschmidt, seurer, kbarton, hfinkel.
nemanjai added a subscriber: cfe-commits.
nemanjai set the repository for this revision to rL LLVM.
Implemented the following interfaces to conform to ELF V2 ABI version 1.1.
vector signed __int128 vec_
55 matches
Mail list logo