rengolin added a comment.
In http://reviews.llvm.org/D12633#250612, @labrinea wrote:
> __ARM_FP_FAST is defined to 1 if floating-point optimizations may occur such
> that the computed results are different from those prescribed by the order of
> operations according to the C standard. Examples
dcoughlin added a comment.
Aditya, can you update the patch title and summary to a commit message so I can
commit it? Thanks!
http://reviews.llvm.org/D9924
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailma
samsonov added a subscriber: samsonov.
samsonov accepted this revision.
samsonov added a reviewer: samsonov.
samsonov added a comment.
LGTM
http://reviews.llvm.org/D12840
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/
Author: dcoughlin
Date: Tue Sep 22 18:58:04 2015
New Revision: 248350
URL: http://llvm.org/viewvc/llvm-project?rev=248350&view=rev
Log:
[analyzer] Improve localizability checks for iOS / OS X.
Various improvements to the localization checker:
* Adjusted copy to be consistent with diagnostic text
This revision was automatically updated to reflect the committed changes.
Closed by commit rL248350: [analyzer] Improve localizability checks for iOS /
OS X. (authored by dcoughlin).
Changed prior to commit:
http://reviews.llvm.org/D12417?vs=35404&id=35445#toc
Repository:
rL LLVM
http://rev
dcheng created this revision.
dcheng added a reviewer: thakis.
dcheng added a subscriber: cfe-commits.
This better matches the behavior of MSVC and libstdc++: neither
standard library sets the stored pointer to null when destroying the
unique_ptr.
http://reviews.llvm.org/D13080
Files:
include/
echristo accepted this revision.
echristo added a comment.
This revision is now accepted and ready to land.
LGTM.
Thanks!
-eric
http://reviews.llvm.org/D12989
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/ma
dblaikie added a subscriber: dblaikie.
dblaikie added a comment.
I'd still be curious to see a stronger justification from the standard
about this.
I know you mentioned/quoted the definition of ~unique_ptr in the standard -
but I'm not sure that is meant to imply observable behavior during
destru
echristo accepted this revision.
echristo added a comment.
This revision is now accepted and ready to land.
Seems to be what we were chatting about.
Thanks!
-eric
http://reviews.llvm.org/D13067
___
cfe-commits mailing list
cfe-commits@lists.llvm.o
Author: dcoughlin
Date: Tue Sep 22 19:17:52 2015
New Revision: 248351
URL: http://llvm.org/viewvc/llvm-project?rev=248351&view=rev
Log:
Revert "[analyzer] Improve localizability checks for iOS / OS X."
This reverts commit r248350. The pluralization checks are failing on some bots.
Modified:
It says "error: unable to create target: 'No available targets are
compatible with this triple, see -version for the available targets.'" I
guess you disable a bunch of targets on that bot?
On Tue, Sep 22, 2015 at 6:00 PM, Renato Golin via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> On 21
dcoughlin added a comment.
This is causing tests to fail on the bots:
http://lab.llvm.org:8011/builders/clang-x86_64-debian-fast/builds/31373
/home/llvmbb/llvm-build-dir/clang-x86_64-debian-fast/llvm.obj/Release+Asserts/bin/clang
-cc1 -internal-isystem
/home/llvmbb/llvm-build-dir/clang-x86_
Author: nico
Date: Tue Sep 22 19:24:34 2015
New Revision: 248355
URL: http://llvm.org/viewvc/llvm-project?rev=248355&view=rev
Log:
Make ms-intrin.cpp test require the x86 target.
Modified:
cfe/trunk/test/Headers/ms-intrin.cpp
Modified: cfe/trunk/test/Headers/ms-intrin.cpp
URL:
http://llvm.o
r248355 might help.
On Tue, Sep 22, 2015 at 8:23 PM, Nico Weber wrote:
> It says "error: unable to create target: 'No available targets are
> compatible with this triple, see -version for the available targets.'" I
> guess you disable a bunch of targets on that bot?
>
> On Tue, Sep 22, 2015 at 6
dcheng added a comment.
In http://reviews.llvm.org/D13080#251324, @dblaikie wrote:
> I'd still be curious to see a stronger justification from the standard
> about this.
>
> I know you mentioned/quoted the definition of ~unique_ptr in the standard -
> but I'm not sure that is meant to imply obs
On Tue, Sep 22, 2015 at 5:26 PM, Daniel Cheng via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> dcheng added a comment.
>
> In http://reviews.llvm.org/D13080#251324, @dblaikie wrote:
>
> > I'd still be curious to see a stronger justification from the standard
> > about this.
> >
> > I know y
rengolin added a comment.
In http://reviews.llvm.org/D12903#249406, @thakis wrote:
> Also also, this approach fundamentally doesn't work on Windows.
I don't think it's supposed to, anyway. :)
Repository:
rL LLVM
http://reviews.llvm.org/D12903
thakis added a subscriber: thakis.
thakis added a comment.
mclow should review this, not me.
http://reviews.llvm.org/D13080
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
compnerd added a comment.
Yeah, I realize that we will need that part of the change as well. However, I
think that this is a sufficiently standalone piece that we can merge this first.
http://reviews.llvm.org/D12996
___
cfe-commits mailing list
cf
hiraditya updated this revision to Diff 35461.
hiraditya added a comment.
Updated commit message and summary.
http://reviews.llvm.org/D9924
Files:
lib/StaticAnalyzer/Checkers/MallocOverflowSecurityChecker.cpp
test/Analysis/malloc-overflow.c
test/Analysis/malloc-overflow2.c
Index: test/An
vsk added a comment.
Yes, that looks good.
http://reviews.llvm.org/D12774
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
rtrieu added inline comments.
Comment at: lib/Basic/SourceManager.cpp:1008
@@ -1008,1 +1007,3 @@
+bool SourceManager::isMacroArgExpansion(SourceLocation Loc,
+ SourceLocation *NewLoc) const {
if (!Loc.isMacroID()) return false;
dirty updated this revision to Diff 35463.
dirty added a comment.
- Update patch with feedback from vsk: better handle errors from
make_absolute().
Updating D12774: createUniqueFile() is documented to create the file in the
temporary directory unless it's supplied an absolute path.
berenm changed the visibility of this Differential Revision from "berenm (Beren
Minor)" to "Public (No Login Required)".
berenm updated this revision to Diff 35465.
berenm added a comment.
Remove remaining commented code.
http://reviews.llvm.org/D13081
Files:
clang-tidy/readability/Identifie
Ping^2...
Il 29/08/2015 10:01, Abramo Bagnara ha scritto:
> Il 28/08/2015 23:27, Richard Smith ha scritto:
>> On Tue, Aug 25, 2015 at 10:27 AM, Abramo Bagnara
>> mailto:abramo.bagn...@bugseng.com>> wrote:
>>
>> Comparing the result of InitListExpr::getSyntacticForm between r224986
>> and r
berenm updated this revision to Diff 35466.
berenm added a comment.
Fix incorrect line removal in unit test.
http://reviews.llvm.org/D13081
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
test/clang-tidy/readability-identifier-naming.cpp
Index: test/clang-tidy/readability-identifie
101 - 126 of 126 matches
Mail list logo