yaxunl accepted this revision.
yaxunl added a comment.
LGTM. Thanks.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D88976/new/
https://reviews.llvm.org/D88976
___
cfe-commits mailing list
cfe-commits@list
arsenm added a comment.
Herald added subscribers: mattd, gchakrabarti, asavonic.
Herald added a project: All.
ping?
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D88976/new/
https://reviews.llvm.org/D88976
__
scott.linder added inline comments.
Comment at: clang/lib/Basic/Targets/NVPTX.h:47
-1, // Default, opencl_private or opencl_generic - not defined
-5, // opencl_global
+-1, // opencl_global
-1,
Does anyone have any thoughts on this change specif
scott.linder added inline comments.
Comment at: clang/test/CodeGenHIP/debug-info-address-class.hip:8
+
+// CHECK-DAG: ![[FILEVAR0:[0-9]+]] = distinct !DIGlobalVariable(name:
"FileVar0", scope: !{{[0-9]+}}, file: !{{[0-9]+}}, line: {{[0-9]+}}, type:
!{{[0-9]+}}, isLocal: false,
scott.linder updated this revision to Diff 297309.
scott.linder added a comment.
Replace uses of CHECK-DAG, use more meaningful names in test
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D88976/new/
https://reviews.llvm.org/D88976
Files:
clang/l
aprantl accepted this revision.
aprantl added a comment.
This revision is now accepted and ready to land.
That looks much nicer.
Comment at: clang/test/CodeGenHIP/debug-info-address-class.hip:8
+
+// CHECK-DAG: ![[FILEVAR0:[0-9]+]] = distinct !DIGlobalVariable(name:
"FileVar0"
scott.linder added a comment.
I'm not certain I fully understand NVPTX's relationship with its debugger, but
from https://reviews.llvm.org/D57162 I gather the "default" address space in
the debugger is global, and so the frontend omits it rather than explicitly
mentioning it. I think it would b
scott.linder created this revision.
Herald added subscribers: cfe-commits, jholewinski.
Herald added a project: clang.
scott.linder requested review of this revision.
The target needs to be queried here, but previously we seemed to only
duplicate CUDA's (and so HIP's) behavior, and only partially.