This revision was automatically updated to reflect the committed changes.
Meinersbur marked an inline comment as done.
Closed by commit rC348762: Use zip_longest for iterator range comparisons. NFC.
(authored by Meinersbur, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D5546
dblaikie added inline comments.
Comment at: lib/Serialization/ASTReaderDecl.cpp:2922
+// Return false if the number of enable_if attributes is different.
+if (std::get<0>(Pair).hasValue() != std::get<1>(Pair).hasValue())
+ return false;
Meinersbur wr
Meinersbur marked 3 inline comments as done.
Meinersbur added inline comments.
Comment at: lib/Serialization/ASTReaderDecl.cpp:2922
+// Return false if the number of enable_if attributes is different.
+if (std::get<0>(Pair).hasValue() != std::get<1>(Pair).hasValue())
+
dblaikie accepted this revision.
dblaikie added a comment.
This revision is now accepted and ready to land.
Overall I'm not sure this construct/pattern improves readability, but not too
fussed either way.
Repository:
rC Clang
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55468/new/
Meinersbur updated this revision to Diff 177447.
Meinersbur added a comment.
- Fix xor
- Store tuple elements in variables
Repository:
rC Clang
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55468/new/
https://reviews.llvm.org/D55468
Files:
lib/Sema/SemaOverload.cpp
lib/Serializa
dblaikie added inline comments.
Comment at: lib/Sema/SemaOverload.cpp:8979
+// has fewer enable_if attributes than Cand2, and vice versa.
+if (std::get<0>(Pair) == None)
return Comparison::Worse;
Meinersbur wrote:
> dblaikie wrote:
> > I'd probably
Meinersbur added inline comments.
Comment at: lib/Sema/SemaOverload.cpp:8979
+// has fewer enable_if attributes than Cand2, and vice versa.
+if (std::get<0>(Pair) == None)
return Comparison::Worse;
dblaikie wrote:
> I'd probably write this as "if (
Meinersbur updated this revision to Diff 177444.
Meinersbur marked 4 inline comments as done.
Meinersbur added a comment.
- Address @dblaikie's review
Repository:
rC Clang
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D55468/new/
https://reviews.llvm.org/D55468
Files:
lib/Sema/Sema
dblaikie added inline comments.
Comment at: lib/Sema/SemaOverload.cpp:8979
+// has fewer enable_if attributes than Cand2, and vice versa.
+if (std::get<0>(Pair) == None)
return Comparison::Worse;
I'd probably write this as "if (!std::get<0>(Pair))"