mclow.lists added a comment.
Herald added subscribers: bixia, jlebar.
In general, this looks good to me.
I suggested a lot of test improvements, but not very much to the code.
Needs the same kind of namespace changes in the tests as in
https://reviews.llvm.org/D41376, but that's a minor thing.
timshen updated this revision to Diff 139039.
timshen added a comment.
Herald added a subscriber: christof.
Rebase.
https://reviews.llvm.org/D41415
Files:
libcxx/include/experimental/simd
libcxx/test/std/experimental/simd/simd.casts/simd_cast.pass.cpp
libcxx/test/std/experimental/simd/sim
timshen updated this revision to Diff 129010.
timshen added a comment.
Rebased.
https://reviews.llvm.org/D41415
Files:
libcxx/include/experimental/simd
libcxx/test/std/experimental/simd/simd.casts/simd_cast.pass.cpp
libcxx/test/std/experimental/simd/simd.casts/static_simd_cast.pass.cpp
timshen updated this revision to Diff 127639.
timshen added a comment.
s/_LIBCPP_HAS_VECTOR_EXTENSION/_LIBCPP_HAS_NO_VECTOR_EXTENSION/
https://reviews.llvm.org/D41415
Files:
libcxx/include/experimental/simd
libcxx/test/std/experimental/simd/simd.casts/simd_cast.pass.cpp
libcxx/test/std/ex
timshen created this revision.
timshen added reviewers: mclow.lists, EricWF.
Herald added a subscriber: sanjoy.
This patch also changed all simd size-related types to size_t. Before the
change, as P0214 proposed, they are half-int, half-size_t in different
places. The inconsistency of size types c