pengfei updated this revision to Diff 460991.
pengfei marked 2 inline comments as done.
pengfei added a comment.
Address review comments.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D133920/new/
https://reviews.llvm.org/D133920
Files:
clang/doc
rnk added inline comments.
Comment at: clang/lib/CodeGen/TargetInfo.cpp:1781
+
+ return (Ty->isIntegralOrEnumerationType() || Ty->isPointerType() ||
+ Ty->isReferenceType());
I think we could improve readability here with some named variable boo
hans added a comment.
Instead of just referring to the bug in the commit message, can you add some
text explaining the effects of this change, e.g. on the `__fastcall void
f(unsigned long long a, int b, int c)` function in the bug and that this
matches MSVC?
Did you double check whether this m
pengfei created this revision.
pengfei added a reviewer: rnk.
Herald added a project: All.
pengfei requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
Fixes: #57737
Repository:
rG LLVM Github Monorepo
https://reviews.llvm.org/D133920
File