Re: [PATCH] D12530: Fix several corner cases for loop-convert check.

2015-09-01 Thread Manuel Klimek via cfe-commits
klimek accepted this revision. klimek added a comment. This revision is now accepted and ready to land. Learned that I need to learn to read, because the deleted comment was just duplicated. Looks good, great first step towards making this significantly more useful :) http://reviews.llvm.org/D1

Re: [PATCH] D12530: Fix several corner cases for loop-convert check.

2015-09-01 Thread Manuel Klimek via cfe-commits
klimek added inline comments. Comment at: test/clang-tidy/modernize-loop-convert-basic.cpp:448 @@ +447,3 @@ +ret = it; + } +} angelgarcia wrote: > klimek wrote: > > This test seems to be missing the it.insert(0) case that was removed from > > the "unsupporte

Re: [PATCH] D12530: Fix several corner cases for loop-convert check.

2015-09-01 Thread Angel Garcia via cfe-commits
angelgarcia updated this revision to Diff 33690. angelgarcia added a comment. Renamed Usage::E, moved some tests and other fixes. http://reviews.llvm.org/D12530 Files: clang-tidy/modernize/LoopConvertCheck.cpp clang-tidy/modernize/LoopConvertUtils.cpp clang-tidy/modernize/LoopConvertUtils

Re: [PATCH] D12530: Fix several corner cases for loop-convert check.

2015-09-01 Thread Angel Garcia via cfe-commits
angelgarcia marked 2 inline comments as done. Comment at: test/clang-tidy/modernize-loop-convert-basic.cpp:448 @@ +447,3 @@ +ret = it; + } +} klimek wrote: > This test seems to be missing the it.insert(0) case that was removed from the > "unsupported" comme

Re: [PATCH] D12530: Fix several corner cases for loop-convert check.

2015-09-01 Thread Manuel Klimek via cfe-commits
klimek added a comment. Nice! Comment at: clang-tidy/modernize/LoopConvertCheck.cpp:378 @@ +377,3 @@ + for (const auto &U : Usages) { +if (!U.E->isRValue()) + return false; (not necessarily in this CL) please rename E to Expression or similar; I'm fine

[PATCH] D12530: Fix several corner cases for loop-convert check.

2015-09-01 Thread Angel Garcia via cfe-commits
angelgarcia created this revision. angelgarcia added a reviewer: alexfh. angelgarcia added subscribers: klimek, cfe-commits. Reduced the amount of wrong conversions of this check. http://reviews.llvm.org/D12530 Files: clang-tidy/modernize/LoopConvertCheck.cpp clang-tidy/modernize/LoopConvert