JamesReynolds added a comment.
Thank you! Can you land this for me please?
This is me done for the time being, but once our implementation gets into the
swing of things I'll try and start picking up some bugs / enhancements.
https://reviews.llvm.org/D21472
__
JamesReynolds updated the summary for this revision.
JamesReynolds updated this revision to Diff 63462.
JamesReynolds added a comment.
> You mean Upper_Separated and upper_Separated_Back? ;) Actually, these names
> are not particularly clear. I've managed to find "Camel_Snake_Case"
> used for e
JamesReynolds added a comment.
Ah, I took this from a single example in the CPP core guidelines - that PDF is
indeed a very different style. An idea we toyed with was "UpperSeparated" and
"UpperSeparatedBack"? Would that work?
This comes from a concession to Window developers in a large commer
JamesReynolds added a comment.
I'm not 100% sure that my regexes are the best balance between readability and
terseness - or that I've named the case types particularly well. If there are
better ideas for either of those things I'm very happy to accept criticism!
http://reviews.llvm.org/D21472
JamesReynolds created this revision.
JamesReynolds added a reviewer: alexfh.
JamesReynolds added a subscriber: cfe-commits.
Added Stroustrup_Case and stroustrup_Back
(http://isocpp.github.io/CppCoreGuidelines/CppCoreGuidelines#S-naming)
```
class Stroustrup_Case_Class_Name
{
void private_Strou
JamesReynolds marked an inline comment as done.
JamesReynolds added a comment.
Thanks! All fixed now. Could you land this for me please?
http://reviews.llvm.org/D21020
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi
JamesReynolds marked 2 inline comments as done.
Comment at: clang-tidy/readability/IdentifierNamingCheck.h:98
@@ +97,3 @@
+
+ /// Add a usage of a macro if it already has a violation.
+ void expandMacro(const Token &MacroNameTok, const MacroInfo *MI);
Fixed this
JamesReynolds updated this revision to Diff 61071.
JamesReynolds added a comment.
Fixed nits.
http://reviews.llvm.org/D21020
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
clang-tidy/readability/IdentifierNamingCheck.h
docs/ReleaseNotes.rst
test/clang-tidy/readability-identifie
JamesReynolds marked an inline comment as done.
JamesReynolds added a comment.
http://reviews.llvm.org/D21020
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
JamesReynolds marked an inline comment as done.
JamesReynolds added a comment.
http://reviews.llvm.org/D21020
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
JamesReynolds updated this revision to Diff 60058.
JamesReynolds marked an inline comment as not done.
JamesReynolds added a comment.
Missed one modification in last update.
http://reviews.llvm.org/D21020
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
clang-tidy/readability/Identif
JamesReynolds added inline comments.
Comment at: clang-tidy/readability/IdentifierNamingCheck.h:89
@@ +88,3 @@
+
+ typedef std::pair NamingCheckId;
+
I think I thought that this wouldn't get picked up by the specialization
machinery - but you're right, a typedef
JamesReynolds updated this revision to Diff 60056.
JamesReynolds marked 5 inline comments as done.
JamesReynolds added a comment.
Applied suggested code changes.
http://reviews.llvm.org/D21020
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
clang-tidy/readability/IdentifierNamingChe
JamesReynolds updated this revision to Diff 60010.
JamesReynolds added a comment.
Changed the clang-tidy release notes addition to be in alphabetical order.
http://reviews.llvm.org/D21020
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
clang-tidy/readability/IdentifierNamingCheck.h
JamesReynolds marked an inline comment as done.
JamesReynolds added a comment.
http://reviews.llvm.org/D21020
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
JamesReynolds updated this revision to Diff 59857.
JamesReynolds added a comment.
Thanks Eugene, I've added a comment into docs/ReleaseNotes.rst to say this is
in. I'll create a BugZilla account to update PR.
I've also added a new test and code to create FixIts for uses of the Macros as
well as
JamesReynolds created this revision.
JamesReynolds added a reviewer: alexfh.
JamesReynolds added a subscriber: cfe-commits.
Added support for macro definitions.
--
1. Added a pre-processor callback to catch macro definitions
2. Changed the type of the failure map so that macros and declarations c
JamesReynolds added a comment.
Great, and happy to help. I'm working on another couple that I should hopefully
complete sometime next week. If you could commit this for me that would be
great, thank you!
http://reviews.llvm.org/D20856
___
cfe-comm
JamesReynolds created this revision.
JamesReynolds added a reviewer: alexfh.
JamesReynolds added a subscriber: cfe-commits.
Added support for Type Alias declarations.
http://reviews.llvm.org/D20856
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
test/clang-tidy/readability-identifier
19 matches
Mail list logo