dcandler abandoned this revision.
dcandler added a comment.
Sorry for the quiet on this. I'm going to abandon this for the moment, as what
I eventually found was that there was some ambiguity in the ARM ABI regarding
half-floats which would be better to address first, so that the attributes can
dcandler added a comment.
There are currently no Arm specific changes, this is just being able to more
accurately describe the floating point environment via attributes in the case
where singles and doubles should be flushed, but not halves.
With three precisions to control, an alternative may
dcandler created this revision.
dcandler added reviewers: arsenm, spatel, echristo, andrew.w.kaylor,
cameron.mcinally.
Herald added subscribers: jsji, kosarev, jdoerfert, pengfei, hiraditya,
kristof.beyls, tpr.
Herald added a project: All.
dcandler requested review of this revision.
Herald added
This revision was automatically updated to reflect the committed changes.
Closed by commit rG9e7c9967c3fd: Additionally set f32 mode with
denormal-fp-math (authored by dcandler).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D122589/new/
https://revi
dcandler added a comment.
The issue I found was trying to use getDefaultDenormalModeForType during
constant folding to account for denormals (https://reviews.llvm.org/D116952).
Setting denormal-fp-math to a non-IEEE mode without specifying
denormal-fp-math-f32 still results in the denormal-fp-m
dcandler updated this revision to Diff 418865.
dcandler added a comment.
Added a test that checks attributes based on the -fdenormal-fp-math and
-fdenormal-fp-math-f32 flags.
Only the cases where -fdenormal-fp-math is set to preserve-sign or
positive-zero and -fdenormal-fp-math-f32 is unset are
dcandler created this revision.
dcandler added reviewers: arsenm, spatel.
Herald added a project: All.
dcandler requested review of this revision.
Herald added subscribers: cfe-commits, MaskRay, wdng.
Herald added a project: clang.
When the denormal-fp-math option is used, this should set the
deno
This revision was landed with ongoing or failed builds.
This revision was automatically updated to reflect the committed changes.
Closed by commit rG3d59f9d22440: [ARM][AArch64] Correct __ARM_FEATURE_CRYPTO
macro and crypto feature (authored by dcandler).
Repository:
rG LLVM Github Monorepo
CH
dcandler created this revision.
dcandler added reviewers: t.p.northover, lenary.
Herald added subscribers: danielkiss, kristof.beyls.
dcandler requested review of this revision.
Herald added a project: clang.
Herald added a subscriber: cfe-commits.
This patch contains a couple of minor corrections
This revision was automatically updated to reflect the committed changes.
Closed by commit rGb8baa2a91324: [ARM][AArch64] Require appropriate features
for crypto algorithms (authored by dcandler).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99079/n
dcandler added inline comments.
Comment at: clang/lib/Basic/Targets/AArch64.h:36
+ bool HasSHA3;
+ bool HasSM4;
bool HasUnaligned;
rsanthir.quic wrote:
> Would it make sense to further differentiate SM3 and SM4? I see that we
> differentiate between the two
dcandler updated this revision to Diff 338126.
dcandler marked 2 inline comments as done.
dcandler added a comment.
Removed one duplicated line.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D99079/new/
https://reviews.llvm.org/D99079
Files:
clang/include/clang/Basic/arm_neon.td
cla
dcandler updated this revision to Diff 338046.
dcandler added a comment.
I've updated the patch to fix the test failures, and slightly reworked the
driver code to avoid the above iterator invalidation. I've also added a comment
there to clarify what it is doing: individually determining whether
dcandler created this revision.
dcandler added reviewers: t.p.northover, rsanthir.quic, SjoerdMeijer, efriedma,
peter.smith, labrinea.
Herald added subscribers: danielkiss, hiraditya, kristof.beyls.
dcandler requested review of this revision.
Herald added projects: clang, LLVM.
Herald added subscr
This revision was automatically updated to reflect the committed changes.
Closed by commit rG92aa0c2dbcb7: [cfi] Add flag to always generate .debug_frame
(authored by dcandler).
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67216/new/
https://review
dcandler updated this revision to Diff 226147.
dcandler added a comment.
Updated with the new name for the option.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67216/new/
https://reviews.llvm.org/D67216
Files:
clang/include/clang/Basic/CodeGenOptions.def
clang/include/clang/Driver
dcandler added a comment.
I think `-f[no-]force-dwarf-frame` suitably describes the behavior, and looks
in line with other options. I'll update the patch shortly unless anyone else
has any other input.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D67216/new/
https://reviews.llvm.org/D
dcandler added a comment.
I added the negative option more as a way to disable the flag, since I'm
currently looking at cases where it may want to be turned on by default (and a
negative option would then allow you to only get .eh_frame in cases where you'd
get both .debug_frame/.eh_frame).
Th
dcandler added a comment.
Ping?
I already spotted the line in CommandFlags.inc needs formatting with a couple
of breaks. Also the help text in Options.td could be clearer. In particular,
-gno-dwarf-frame shouldn't suggest .debug_frame won't be generated at all
(since -g might still emit it). I
dcandler updated this revision to Diff 224581.
dcandler retitled this revision from "[cfi] Add flag to always generate call
frame information" to "[cfi] Add flag to always generate .debug_frame".
dcandler edited the summary of this revision.
dcandler added reviewers: rengolin, joerg.
dcandler adde
dcandler added a comment.
Herald added a subscriber: ychen.
I was actually torn myself on whether to put the flag in the g group or not, so
I'm happy to rename it. As far as I could find, no compiler has an existing
option to control this: instead armcc always includes a debug_frame section by
This revision was automatically updated to reflect the committed changes.
Closed by commit rL371079: [ARM] Add support for the s,j,x,N,O inline asm
constraints (authored by dcandler, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D65863?vs=214205&id=218927#toc
Repository:
dcandler created this revision.
dcandler added reviewers: echristo, probinson, aprantl.
Herald added subscribers: llvm-commits, cfe-commits, hiraditya, kristof.beyls,
javed.absar.
Herald added projects: clang, LLVM.
This adds a flag to LLVM and clang to always generate call frame information,
ev
dcandler added a comment.
Ping. @compnerd any other changes before this could be accepted?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D65863/new/
https://reviews.llvm.org/D65863
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http
dcandler updated this revision to Diff 214205.
dcandler marked an inline comment as done.
dcandler added a comment.
Adjusted the formatting on some comment lines, and added FIXMEs for all the
constraints that require additional validation to clarify what is still needed
and where.
CHANGES SINC
dcandler marked 5 inline comments as done.
dcandler added inline comments.
Comment at: clang/lib/Basic/Targets/ARM.cpp:938
+// Thumb1: An immediate integer which is a multiple of 4 between 0 and
1020.
+Info.setRequiresImmediate();
return true;
compn
dcandler created this revision.
dcandler added reviewers: rsmith, t.p.northover, compnerd, void, joerg,
efriedma, ostannard.
Herald added subscribers: llvm-commits, cfe-commits, hiraditya, kristof.beyls,
javed.absar.
Herald added projects: clang, LLVM.
A number of inline assembly constraints are
27 matches
Mail list logo