danielmartin added a comment.
Using explicit UTF-8 string literals is a possible solution, but it makes the
code a bit less readable. Another possible solution is to save the source file
using UTF-8 with BOM, but this is confusing outside the Microsoft world (and
it's very easy to remove the BO
danielmartin added inline comments.
Comment at: clang-tools-extra/clangd/ClangdServer.h:277
+ ///
+ /// If NewName is provided, it peforms a name validation.
void prepareRename(PathRef File, Position Pos,
Repository:
rG LLVM Github Monorepo
CHANGES SIN
danielmartin updated this revision to Diff 266540.
danielmartin added a comment.
Rebase and squash
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D80472/new/
https://reviews.llvm.org/D80472
Files:
clang-tools-extra/clang-doc/Generators.cpp
clang
danielmartin added a comment.
Thanks for the review! I don't have commit access so I'd need someone to land
this patch for me.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D80472/new/
https://reviews.llvm.org/D80472
danielmartin updated this revision to Diff 266322.
danielmartin marked 2 inline comments as done.
danielmartin added a comment.
Address feedback
Rename getAccess to getAccessSpelling.
Replace more parts of the codebase that were using their own version of
getAccessSpelling.
Use StringRef's str()
danielmartin marked 6 inline comments as done.
danielmartin added inline comments.
Comment at: clang-tools-extra/clangd/Hover.cpp:680
+StringRef getAccessString(AccessSpecifier AS) {
+ switch (AS) {
kadircet wrote:
> it is annoying to have this function duplic
danielmartin updated this revision to Diff 265942.
danielmartin added a comment.
Move clang::getAccess to Specifiers.h and refactor logic in clang-doc
to use that function instead of its own.
Also changes where "public", "private" etc. is shown in the hover
contents. Now it's shown at the bottom.
danielmartin created this revision.
Herald added subscribers: cfe-commits, usaxena95, kadircet, arphaman, jkorous,
MaskRay, ilya-biryukov.
Herald added a project: clang.
danielmartin edited the summary of this revision.
For https://github.com/clangd/clangd/issues/382
This commit adds access spec
danielmartin updated this revision to Diff 112855.
danielmartin added a comment.
Make comment fit in one line
https://reviews.llvm.org/D37192
Files:
lib/Format/UnwrappedLineParser.cpp
unittests/Format/FormatTestObjC.cpp
Index: unittests/Format/FormatTestObjC.cpp
==
danielmartin created this revision.
Herald added a subscriber: klimek.
Objective C supports lightweight generics in categories. This patch
adds support for that in clang-format.
https://reviews.llvm.org/D37192
Files:
lib/Format/UnwrappedLineParser.cpp
unittests/Format/FormatTestObjC.cpp
I
10 matches
Mail list logo