[PATCH] D108905: [ItaniumCXXABI] Set nounwind on __cxa_begin_catch/__cxa_end_catch nounwind

2021-08-29 Thread Chuanqi Xu via Phabricator via cfe-commits
ChuanqiXu added a comment. Thanks for looking into this! I am not familiar with exception handling. But from the comments, I worried that if it is a problem if there are exceptions whose destructor could throw (although it is not usual nor good). Repository: rG LLVM Github Monorepo CHANGES

[PATCH] D108905: [ItaniumCXXABI] Set nounwind on __cxa_begin_catch/__cxa_end_catch nounwind

2021-08-29 Thread Fangrui Song via Phabricator via cfe-commits
MaskRay created this revision. MaskRay added reviewers: ChuanqiXu, rjmccall. MaskRay requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. See https://lists.llvm.org/pipermail/cfe-dev/2021-August/068740.html A catch clause calls __cxa_begin_catc

[PATCH] D108881: [clang][driver] Honor the last -flto= flag even if an earlier -flto is present

2021-08-29 Thread Teresa Johnson via Phabricator via cfe-commits
tejohnson added a comment. In D108881#2971651 , @tbaeder wrote: > That code has changed quite a bit since I've worked on it. > > The only problem I could see is that passing `-flto=thin -flto` and choosing > thin LTO kinda makes sense if you interpret `-

[PATCH] D108881: [clang][driver] Honor the last -flto= flag even if an earlier -flto is present

2021-08-29 Thread Timm Bäder via Phabricator via cfe-commits
tbaeder added a comment. That code has changed quite a bit since I've worked on it. The only problem I could see is that passing `-flto=thin -flto` and choosing thin LTO kinda makes sense if you interpret `-flto` as just "use LTO". The `-flto=thin` is more specific, so it could make sense to pi

[PATCH] D108886: Add RISC-V sifive-s51 cpu

2021-08-29 Thread Alexander Pivovarov via Phabricator via cfe-commits
apivovarov updated this revision to Diff 369369. apivovarov added a comment. fix typo in MCPU-ABI-SIFIVE-S51 Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108886/new/ https://reviews.llvm.org/D108886 Files: clang/test/Driver/riscv-cpus.c llvm/

[clang] 80f7ce8 - [X86] Support __SSC_MARK(const int id)

2021-08-29 Thread Xiang1 Zhang via cfe-commits
Author: Xiang1 Zhang Date: 2021-08-30T09:55:35+08:00 New Revision: 80f7ce89938874fb6b40ca5bafa1f5c4eca4746d URL: https://github.com/llvm/llvm-project/commit/80f7ce89938874fb6b40ca5bafa1f5c4eca4746d DIFF: https://github.com/llvm/llvm-project/commit/80f7ce89938874fb6b40ca5bafa1f5c4eca4746d.diff

[PATCH] D105168: [RISCV] Unify the arch string parsing logic to RISCVISAInfo.

2021-08-29 Thread Kito Cheng via Phabricator via cfe-commits
kito-cheng marked an inline comment as done. kito-cheng added inline comments. Comment at: llvm/lib/Support/RISCVISAInfo.cpp:268 +// omitted from the version string. E.g., rv32i2p0, rv32i2, rv32i2p1. +static Error getExtensionVersion(StringRef MArch, StringRef Ext, StringRef In,

[PATCH] D105168: [RISCV] Unify the arch string parsing logic to RISCVISAInfo.

2021-08-29 Thread Kito Cheng via Phabricator via cfe-commits
kito-cheng updated this revision to Diff 369364. kito-cheng added a comment. Changes: - Remove unused argument MArch for getExtensionVersion. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D105168/new/ https://reviews.llvm.org/D105168 Files: clan

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Eugene Zelenko via Phabricator via cfe-commits
Eugene.Zelenko added inline comments. Comment at: clang-tools-extra/docs/ReleaseNotes.rst:87 + + Finds cases where code could use ``data`` rather than the address of an element. + It'll be good idea to mention containers and that `data` is method. ===

[clang] 4c29dc1 - Revert "[X86] Support __SSC_MARK(const int id)"

2021-08-29 Thread Xiang1 Zhang via cfe-commits
Author: Xiang1 Zhang Date: 2021-08-30T09:50:26+08:00 New Revision: 4c29dc18cf23d3a644158b567b8c3d471358e2bd URL: https://github.com/llvm/llvm-project/commit/4c29dc18cf23d3a644158b567b8c3d471358e2bd DIFF: https://github.com/llvm/llvm-project/commit/4c29dc18cf23d3a644158b567b8c3d471358e2bd.diff

[PATCH] D101759: [PowerPC] Scalar IBM MASS library conversion pass

2021-08-29 Thread Eli Friedman via Phabricator via cfe-commits
efriedma added a comment. errno handling for math library functions is a mess. Currently, we don't model it properly; we just mark the calls "readnone" and hope for the best. If you don't want to fix that, just check for readnone for now. I don't think we want to be querying function attribut

[PATCH] D107394: [AIX] "aligned" attribute does not decrease alignment

2021-08-29 Thread Steven Wan via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG71b170ccf36e: [AIX] "aligned" attribute does not decrease alignment (authored by stevewan). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107394/new/ https:

[clang] 71b170c - [AIX] "aligned" attribute does not decrease alignment

2021-08-29 Thread Steven Wan via cfe-commits
Author: Steven Wan Date: 2021-08-29T21:33:05-04:00 New Revision: 71b170ccf36ee02e6a4c472bc1d3e89bbaf0e2b4 URL: https://github.com/llvm/llvm-project/commit/71b170ccf36ee02e6a4c472bc1d3e89bbaf0e2b4 DIFF: https://github.com/llvm/llvm-project/commit/71b170ccf36ee02e6a4c472bc1d3e89bbaf0e2b4.diff LO

[clang] 78fbde5 - [X86] Support __SSC_MARK(const int id)

2021-08-29 Thread Xiang1 Zhang via cfe-commits
Author: Xiang1 Zhang Date: 2021-08-30T09:21:22+08:00 New Revision: 78fbde57794e50f5629979f5d69592caf64067e3 URL: https://github.com/llvm/llvm-project/commit/78fbde57794e50f5629979f5d69592caf64067e3 DIFF: https://github.com/llvm/llvm-project/commit/78fbde57794e50f5629979f5d69592caf64067e3.diff

[clang] fd88fac - Revert "[X86] Support __SSC_MARK(const int id)"

2021-08-29 Thread Xiang1 Zhang via cfe-commits
Author: Xiang1 Zhang Date: 2021-08-30T09:18:27+08:00 New Revision: fd88fac6ca3967e85906dfd059f512c0cee3fdaf URL: https://github.com/llvm/llvm-project/commit/fd88fac6ca3967e85906dfd059f512c0cee3fdaf DIFF: https://github.com/llvm/llvm-project/commit/fd88fac6ca3967e85906dfd059f512c0cee3fdaf.diff

[PATCH] D108682: [X86] Support __SSC_MARK(const int id) in x86gprintrin.h

2021-08-29 Thread Xiang Zhang via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG83e82ff76753: [X86] Support __SSC_MARK(const int id) (authored by xiangzhangllvm). Herald added a project: clang. Herald added a subscriber: cfe-commits. Repository: rG LLVM Github Monorepo CHANGES SIN

[clang] 83e82ff - [X86] Support __SSC_MARK(const int id)

2021-08-29 Thread Xiang1 Zhang via cfe-commits
Author: Xiang1 Zhang Date: 2021-08-30T08:51:20+08:00 New Revision: 83e82ff767530158fd5590ffea617f50a07534b5 URL: https://github.com/llvm/llvm-project/commit/83e82ff767530158fd5590ffea617f50a07534b5 DIFF: https://github.com/llvm/llvm-project/commit/83e82ff767530158fd5590ffea617f50a07534b5.diff

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd updated this revision to Diff 369343. compnerd edited the summary of this revision. compnerd added a comment. Add some documentation and release notes. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108893/new/ https://reviews.llvm.org/D108

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd added a comment. Hmm, one case that doesn't currently get handled properly is the following test case: c++ template void f(const T *); void g(const std::vector **v) { f(&(**v)[0]); } Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.o

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd added inline comments. Comment at: clang-tools-extra/clang-tidy/readability/ContainerDataPointerCheck.cpp:18 +namespace tidy { +namespace readability { +ContainerDataPointerCheck::ContainerDataPointerCheck(StringRef Name, Eugene.Zelenko wrote: > compner

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Eugene Zelenko via Phabricator via cfe-commits
Eugene.Zelenko added inline comments. Comment at: clang-tools-extra/clang-tidy/readability/ContainerDataPointerCheck.cpp:18 +namespace tidy { +namespace readability { +ContainerDataPointerCheck::ContainerDataPointerCheck(StringRef Name, compnerd wrote: > Eugene.

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd added a comment. In D108893#2971410 , @Eugene.Zelenko wrote: > Thank you for implementing 26817 > ! But shouldn't this check > belong to `modernize` module? Oh, I was unaware of the PR, I'll tag th

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd updated this revision to Diff 369340. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108893/new/ https://reviews.llvm.org/D108893 Files: clang-tools-extra/clang-tidy/readability/CMakeLists.txt clang-tools-extra/clang-tidy/readability/Con

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Eugene Zelenko via Phabricator via cfe-commits
Eugene.Zelenko added a comment. Thank you for implementing 26817 ! But shouldn't this check belong to `modernize` module? Please add documentation and mention new check in Release Notes. Comment at: clang-tools-extra/clang-tidy/re

[PATCH] D108882: Add backward compatibility tests for PackConstructorInitializers

2021-08-29 Thread Owen Pan via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG4b1fde8a2b68: [clang-format] Add PackConstructorInitializers backward compat test (authored by owenpan). Changed prior to commit: https://reviews.llvm.org/D108882?vs=369308&id=369339#toc Repository:

[clang] 4b1fde8 - [clang-format] Add PackConstructorInitializers backward compat test

2021-08-29 Thread via cfe-commits
Author: owenca Date: 2021-08-29T13:47:11-07:00 New Revision: 4b1fde8a2b681dad2ce0c082a5d6422caa06b0bc URL: https://github.com/llvm/llvm-project/commit/4b1fde8a2b681dad2ce0c082a5d6422caa06b0bc DIFF: https://github.com/llvm/llvm-project/commit/4b1fde8a2b681dad2ce0c082a5d6422caa06b0bc.diff LOG: [

[PATCH] D108882: Add backward compatibility tests for PackConstructorInitializers

2021-08-29 Thread Owen Pan via Phabricator via cfe-commits
owenpan added a comment. In D108882#2971192 , @MyDeveloperDay wrote: > It seems a little convoluted, but OK Will add comments to explain the logic. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108882/new/ https://reviews.llvm.org/D108882 __

[PATCH] D108765: [docs] Fix documentation of clang-format BasedOnStyle type

2021-08-29 Thread Björn Schäpers via Phabricator via cfe-commits
HazardyKnusperkeks added inline comments. Comment at: clang/docs/tools/dump_format_style.py:23 + plurals = { +'IncludeCategory': 'IncludeCategories' + } MyDeveloperDay wrote: > HazardyKnusperkeks wrote: > > FederAndInk wrote: > > > HazardyKnusperkeks wrote:

[PATCH] D102943: [modules] Use `HashBuilder` and `MD5` for the module hash.

2021-08-29 Thread Alexandre Rames via Phabricator via cfe-commits
arames added inline comments. Comment at: clang/include/clang/Serialization/ModuleFileExtension.h:89 + using ExtensionHashBuilder = + llvm::HashBuilderImpl; + virtual void hashExtension(ExtensionHashBuilder &HBuilder) const; This obviously needs to be fixe

[PATCH] D107394: [AIX] "aligned" attribute does not decrease alignment

2021-08-29 Thread John McCall via Phabricator via cfe-commits
rjmccall accepted this revision. rjmccall added a comment. This revision is now accepted and ready to land. Thanks, LGTM! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107394/new/ https://reviews.llvm.org/D107394 __

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd updated this revision to Diff 369331. compnerd added a comment. Reflow the text using clang-format. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108893/new/ https://reviews.llvm.org/D108893 Files: clang-tools-extra/clang-tidy/readabili

[PATCH] D108893: clang-tidy: introduce readability-containter-data-pointer check

2021-08-29 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd created this revision. compnerd added a reviewer: aaron.ballman. Herald added a subscriber: mgorny. compnerd requested review of this revision. Herald added a project: clang-tools-extra. This introduces a new check, readability-containter-data-pointer. This check is meant to catch the ca

[PATCH] D86958: [Docs] Add/update release notes for D71913 (LTO WPD changes)

2021-08-29 Thread Teresa Johnson via Phabricator via cfe-commits
tejohnson closed this revision. tejohnson added a comment. This was committed awhile back (d3f1f588f902a968f102d6cdaf052674efc257aa ), manually closing. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https

[PATCH] D107394: [AIX] "aligned" attribute does not decrease alignment

2021-08-29 Thread Steven Wan via Phabricator via cfe-commits
stevewan updated this revision to Diff 369319. stevewan added a comment. Rename lambda and add comments Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D107394/new/ https://reviews.llvm.org/D107394 Files: clang/lib/AST/RecordLayoutBuilder.cpp cla

[PATCH] D108765: [docs] Fix documentation of clang-format BasedOnStyle type

2021-08-29 Thread MyDeveloperDay via Phabricator via cfe-commits
MyDeveloperDay added inline comments. Comment at: clang/docs/tools/dump_format_style.py:23 + plurals = { +'IncludeCategory': 'IncludeCategories' + } HazardyKnusperkeks wrote: > FederAndInk wrote: > > HazardyKnusperkeks wrote: > > > Could you not just check

[PATCH] D108882: Add backward compatibility tests for PackConstructorInitializers

2021-08-29 Thread MyDeveloperDay via Phabricator via cfe-commits
MyDeveloperDay accepted this revision. MyDeveloperDay added a comment. This revision is now accepted and ready to land. It seems a little convoluted, but OK CHANGES SINCE LAST ACTION https://reviews.llvm.org/D108882/new/ https://reviews.llvm.org/D108882 __