rjmccall accepted this revision.
rjmccall added a comment.
This revision is now accepted and ready to land.
Great!
https://reviews.llvm.org/D54048
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo
NoQ added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
aaron.ballman wrote:
> NoQ wrote:
>
This revision was not accepted when it landed; it landed in state "Needs
Review".
This revision was automatically updated to reflect the committed changes.
Closed by commit rL346113: [analyzer] Restrict AnalyzerOptions' interface
so that non-checker objects have… (authored by Szelethus, committed
Author: szelethus
Date: Sun Nov 4 19:50:37 2018
New Revision: 346113
URL: http://llvm.org/viewvc/llvm-project?rev=346113&view=rev
Log:
[analyzer] Restrict AnalyzerOptions' interface so that non-checker objects have
to be registered
One of the reasons why AnalyzerOptions is so chaotic is that op
Szelethus closed this revision.
Szelethus added a comment.
Woohoo, it seems to be fine! ^-^
I thought the evaluation order in braced initializer lists are from left to
right, but apparently not. Certainly not on windows.
Repository:
rL LLVM
https://reviews.llvm.org/D52794
___
wuzish marked an inline comment as done.
wuzish added inline comments.
Comment at: clang/lib/Sema/SemaOverload.cpp:3913
+for (auto Type : Types) {
+ if (S.Context.getCanonicalType(Type)->getTypeClass() != Type::Vector)
+return false;
wuzish marked an inline comment as done.
wuzish added a comment.
Gentle ping. Could anyone else have a more review?
https://reviews.llvm.org/D53417
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinf
wuzish created this revision.
wuzish added reviewers: hfinkel, nemanjai, kbarton.
Herald added a subscriber: jsji.
The second parameter of vec_sr function is representing shift bits and it
should be modulo the number of bits in the element like what vec_sl does now.
Repository:
rC Clang
http
krytarowski requested review of this revision.
krytarowski added a comment.
Herald added a subscriber: llvm-commits.
This change happened to be required in downstream usage.. knowing its limits
can we merge it as it is?
Repository:
rL LLVM
https://reviews.llvm.org/D34018
_
Author: szelethus
Date: Sun Nov 4 18:37:29 2018
New Revision: 346112
URL: http://llvm.org/viewvc/llvm-project?rev=346112&view=rev
Log:
Ensure the correct order of evaluation in part 2. of PlistMacroExpansion
Windows buildbots break with the previous commit
'[analyzer][PlistMacroExpansion]
Part
Author: szelethus
Date: Sun Nov 4 18:14:36 2018
New Revision: 346111
URL: http://llvm.org/viewvc/llvm-project?rev=346111&view=rev
Log:
Reland '[analyzer][PlistMacroExpansion] Part 2.: Retrieving the macro name and
primitive expansion'
Modified:
cfe/trunk/lib/StaticAnalyzer/Core/PlistDiagnos
Szelethus added inline comments.
Comment at: lib/StaticAnalyzer/Core/SarifDiagnostics.cpp:237-242
+#define GET_CHECKERS
+#define CHECKER(FULLNAME, CLASS, CXXFILE, HELPTEXT, GROUPINDEX, HIDDEN)
\
+ .Case(FULLNAME, HELPTEXT)
+#include "clang/StaticAnalyzer/Checkers/Checker
Szelethus added inline comments.
Comment at: lib/StaticAnalyzer/Core/SarifDiagnostics.cpp:237-242
+#define GET_CHECKERS
+#define CHECKER(FULLNAME, CLASS, CXXFILE, HELPTEXT, GROUPINDEX, HIDDEN)
\
+ .Case(FULLNAME, HELPTEXT)
+#include "clang/StaticAnalyzer/Checkers/Checker
Szelethus updated this revision to Diff 172534.
https://reviews.llvm.org/D53995
Files:
include/clang/Driver/CC1Options.td
include/clang/StaticAnalyzer/Checkers/CheckerBase.td
include/clang/StaticAnalyzer/Checkers/Checkers.td
lib/StaticAnalyzer/Checkers/ClangCheckers.cpp
lib/StaticAnalyz
Szelethus updated this revision to Diff 172533.
Szelethus added a comment.
- Came to the shocking realization that `Hidden` is also an unused property, so
I removed that too.
- Added comments to `CheckerBase.td`.
- Added missing ` // end "packagename"` comments
Now that `CheckerBase.td` isn't th
This revision was automatically updated to reflect the committed changes.
Closed by commit rL346107: [Driver] Use -Bstatic/dynamic for libc++ on Fuchsia
(authored by phosek, committed by ).
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https://reviews.llvm.org/D54082?vs=1725
Author: phosek
Date: Sun Nov 4 14:38:47 2018
New Revision: 346107
URL: http://llvm.org/viewvc/llvm-project?rev=346107&view=rev
Log:
[Driver] Use -Bstatic/dynamic for libc++ on Fuchsia
-static relies on lld's behavior, but -Bstatic/dynamic is supported
across all linkers.
Differential Revision:
aaron.ballman added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
NoQ wrote:
> aaron.ballman
mattd added a comment.
In https://reviews.llvm.org/D54048#1286654, @rjmccall wrote:
> That looks a lot better, thanks. Did you check whether any other tests
> needed adjustment? That's not uncommon from this kind of desugaring change.
>
> If not, LGTM.
Thanks again. I ran the typical 'check
hubert.reinterpretcast added inline comments.
Comment at: clang/lib/Sema/SemaOverload.cpp:3913
+for (auto Type : Types) {
+ if (S.Context.getCanonicalType(Type)->getTypeClass() != Type::Vector)
+return false;
wuzish wrote:
> hubert.re
Author: sylvestre
Date: Sun Nov 4 09:41:41 2018
New Revision: 346103
URL: http://llvm.org/viewvc/llvm-project?rev=346103&view=rev
Log:
Add support of the next Ubuntu (Ubuntu 19.04 - Disco Dingo)
Modified:
cfe/trunk/include/clang/Driver/Distro.h
cfe/trunk/lib/Driver/Distro.cpp
Modified:
NoQ added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
aaron.ballman wrote:
> Szelethus wro
aaron.ballman added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
Szelethus wrote:
> Szeleth
JonasToth added inline comments.
Comment at: clang-tidy/cppcoreguidelines/CppCoreGuidelinesTidyModule.cpp:84
"cppcoreguidelines-c-copy-assignment-signature");
+CheckFactories.registerCheck(
+"cppcoreguidelines-avoid-c-arrays");
lebedev.ri wro
lebedev.ri updated this revision to Diff 172520.
lebedev.ri marked 6 inline comments as done.
lebedev.ri added a comment.
Better diag for VLA arrays.
https://reviews.llvm.org/D53771
Files:
clang-tidy/cppcoreguidelines/CMakeLists.txt
clang-tidy/cppcoreguidelines/CppCoreGuidelinesTidyModule.c
lebedev.ri added inline comments.
Comment at: clang-tidy/cppcoreguidelines/CppCoreGuidelinesTidyModule.cpp:84
"cppcoreguidelines-c-copy-assignment-signature");
+CheckFactories.registerCheck(
+"cppcoreguidelines-avoid-c-arrays");
lebedev.ri wr
Szelethus reopened this revision.
Szelethus added a comment.
This revision is now accepted and ready to land.
Here's to losing a couple more handfuls of hair, tests break on many platforms,
so I reverted it.
Repository:
rL LLVM
https://reviews.llvm.org/D52794
_
Author: szelethus
Date: Sun Nov 4 06:18:37 2018
New Revision: 346096
URL: http://llvm.org/viewvc/llvm-project?rev=346096&view=rev
Log:
Revert '[analyzer][PlistMacroExpansion] Part 2.: Retrieving the macro name and
primitive expansion'
Modified:
cfe/trunk/lib/StaticAnalyzer/Core/PlistDiagnos
Author: szelethus
Date: Sun Nov 4 05:59:44 2018
New Revision: 346095
URL: http://llvm.org/viewvc/llvm-project?rev=346095&view=rev
Log:
[analyzer][PlistMacroExpansion] Part 2.: Retrieving the macro name and
primitive expansion
This patch adds a couple new functions to acquire the macro's name, a
This revision was automatically updated to reflect the committed changes.
Closed by commit rL346095: [analyzer][PlistMacroExpansion] Part 2.: Retrieving
the macro name and… (authored by Szelethus, committed by ).
Herald added a subscriber: llvm-commits.
Changed prior to commit:
https://reviews.
lebedev.ri marked 4 inline comments as done.
lebedev.ri added a comment.
(only comments, patch to follow)
Comment at: clang-tidy/cppcoreguidelines/CppCoreGuidelinesTidyModule.cpp:84
"cppcoreguidelines-c-copy-assignment-signature");
+CheckFactories.registerCheck(
+
JonasToth added inline comments.
Comment at: clang-tidy/modernize/AvoidCArraysCheck.cpp:44
+ unless(anyOf(hasParent(varDecl(isExternC())),
+ hasAncestor(functionDecl(isExternC())
+ .bind("typeloc"),
JonasToth wr
JonasToth added inline comments.
Comment at: clang-tidy/cppcoreguidelines/CppCoreGuidelinesTidyModule.cpp:84
"cppcoreguidelines-c-copy-assignment-signature");
+CheckFactories.registerCheck(
+"cppcoreguidelines-avoid-c-arrays");
lebedev.ri wro
JonasToth added a comment.
Regarding the warning discussion: It is ok to have this check here in
clang-tidy first and let it mature. Once we can handle all kind of loops and do
not produce false positives this logic can move into the frontend.
But in my opinion the warning-version should handle
Szelethus added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
Szelethus wrote:
> ZaMaZaN4iK
Szelethus added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
ZaMaZaN4iK wrote:
> lebedev.ri
ZaMaZaN4iK updated this revision to Diff 172516.
ZaMaZaN4iK added a comment.
Fix using `auto` in case where it leads to worse readability
https://reviews.llvm.org/D33672
Files:
include/clang/StaticAnalyzer/Checkers/Checkers.td
lib/StaticAnalyzer/Checkers/CMakeLists.txt
lib/StaticAnalyzer/
ZaMaZaN4iK added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
lebedev.ri wrote:
> ZaMaZaN4i
lebedev.ri added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
ZaMaZaN4iK wrote:
> lebedev.r
ztamas marked 10 inline comments as done.
ztamas added a comment.
Mark all handled inline comments as Done.
Repository:
rCTE Clang Tools Extra
https://reviews.llvm.org/D53974
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.ll
ZaMaZaN4iK added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
lebedev.ri wrote:
> ZaMaZaN4i
lebedev.ri added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
ZaMaZaN4iK wrote:
> lebedev.r
ZaMaZaN4iK added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
lebedev.ri wrote:
> ZaMaZaN4i
lebedev.ri added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
ZaMaZaN4iK wrote:
> aaron.bal
ZaMaZaN4iK updated this revision to Diff 172515.
ZaMaZaN4iK added a comment.
1. Fix indentation in test file
2. Return back capitalization for the checker description
https://reviews.llvm.org/D33672
Files:
include/clang/StaticAnalyzer/Checkers/Checkers.td
lib/StaticAnalyzer/Checkers/CMakeLi
ZaMaZaN4iK added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/EnumCastOutOfRangeChecker.cpp:96
+ // Get the value of the expression to cast.
+ const auto ValueToCastOptional =
+ C.getSVal(CE->getSubExpr()).getAs();
aaron.ballman wrote:
> `const
46 matches
Mail list logo