Author: rjmccall
Date: Sat Jan 6 22:28:49 2018
New Revision: 321957
URL: http://llvm.org/viewvc/llvm-project?rev=321957&view=rev
Log:
Simplify the internal API for checking whether swiftcall passes a type
indirectly and expose that API externally.
Modified:
cfe/trunk/include/clang/CodeGen/S
hintonda added a comment.
ping...
https://reviews.llvm.org/D41621
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
hintonda added a comment.
ping...
Repository:
rCXX libc++
https://reviews.llvm.org/D41622
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
hintonda added a comment.
ping...
Repository:
rCXXA libc++abi
https://reviews.llvm.org/D41623
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
hintonda created this revision.
hintonda added reviewers: arphaman, beanz.
Herald added a subscriber: mgorny.
Delete redundant install command for clang-refactor. Install
targets for clang tools are controled by CLANG_BUILD_TOOLS, and when
OFF, cmake issues the following warning:
WARNING: Target
dyung updated this revision to Diff 128861.
dyung added a comment.
Updated change to address review feedback.
https://reviews.llvm.org/D41507
Files:
avxintrin.h
Index: avxintrin.h
===
--- avxintrin.h
+++ avxintrin.h
@@ -1120,7 +
dim created this revision.
dim added reviewers: EricWF, mclow.lists.
Herald added a subscriber: krytarowski.
After https://reviews.llvm.org/rL319736 for https://reviews.llvm.org/D28253
(which fixes PR28929), gcc cannot compile `` anymore in pre-C+11 modes,
complaining:
In file included from /
On 5 Dec 2017, at 05:09, Marshall Clow via cfe-commits
wrote:
>
> Author: marshall
> Date: Mon Dec 4 20:09:49 2017
> New Revision: 319736
>
> URL: http://llvm.org/viewvc/llvm-project?rev=319736&view=rev
> Log:
> Land D28253 which fixes PR28929 (which we mistakenly marked as fixed before)
...
>
Author: d0k
Date: Sat Jan 6 13:49:54 2018
New Revision: 321948
URL: http://llvm.org/viewvc/llvm-project?rev=321948&view=rev
Log:
Add support for a limited subset of TS 18661-3 math builtins.
These just overloads for _Float128. They're supported by GCC 7 and used
by glibc. APFloat support is alre
aaron.ballman updated this revision to Diff 128858.
aaron.ballman marked 3 inline comments as done.
aaron.ballman added a comment.
Herald added a subscriber: javed.absar.
Updated based on review feedback.
https://reviews.llvm.org/D33563
Files:
include/clang/AST/Expr.h
lib/AST/ASTDumper.cpp
aaron.ballman added a comment.
Thanks for the review!
Comment at: include/clang/AST/Expr.h:1728
+ UnaryOperator(Expr *input, Opcode opc, QualType type, ExprValueKind VK,
+ExprObjectKind OK, SourceLocation l, bool CanOverflow = false)
+ : Expr(UnaryOperator
Author: compnerd
Date: Sat Jan 6 10:47:03 2018
New Revision: 321937
URL: http://llvm.org/viewvc/llvm-project?rev=321937&view=rev
Log:
Correct mistake in pragma usage for Windows
The autolink pragma was missing the pragma name itself. This would
result in the pragma being silently dropped.
Modi
aaron.ballman added inline comments.
Comment at: clang-tidy/bugprone/BugproneTidyModule.cpp:64
+CheckFactories.registerCheck(
+"bugprone-stream-int8");
CheckFactories.registerCheck(
I don't think this is a good name for the check, especially beca
aaron.ballman added inline comments.
Comment at: clang-tidy/fuchsia/StaticallyConstructedObjectsCheck.cpp:48
+ if (const auto *D = Result.Nodes.getNodeAs("decl")) {
+diag(D->getLocStart(), "explicit global static objects are disallowed: if "
+ "poss
aaron.ballman added inline comments.
Comment at: clang-tidy/bugprone/UnusedReturnValueCheck.cpp:69
+ "the value returned by %0 should normally be used")
+<< dyn_cast_or_null(Matched->getCalleeDecl())
+<< Matched->getSourceRange();
khuttun
aaron.ballman added inline comments.
Comment at: include/clang/Basic/Attr.td:1159
+def TrivialABI : InheritableAttr {
+ let Spellings = [Clang<"trivial_abi">];
+ let Subjects = SubjectList<[CXXRecord]>;
Would this attribute make sense in C, or does it really on
xazax.hun added a comment.
In https://reviews.llvm.org/D41538#969205, @sylvestre.ledru wrote:
> It missed the 6.0 branching. Will you try to get it on this branch?
> Thanks
Sure! I will try to do so: https://reviews.llvm.org/rC321933
Repository:
rC Clang
https://reviews.llvm.org/D41538
sylvestre.ledru added a comment.
It missed the 6.0 branching. Will you try to get it on this branch?
Thanks
Repository:
rC Clang
https://reviews.llvm.org/D41538
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin
xgsa added inline comments.
Comment at: clang-tidy/ClangTidyDiagnosticConsumer.cpp:839-840
+case NolintCommentType::Nolint:
+ Message = "there is no diagnostics on this line, "
+"the NOLINT comment is redundant";
+ break;
JonasToth added inline comments.
Comment at: clang-tidy/bugprone/StreamInt8Check.h:20
+/// Checks that objects of types int8_t or uint8_t aren't streamed to ostreams,
+/// where the intended behavior is likely to stream them as ints
+///
Missing full stop in comm
JonasToth added a comment.
In https://reviews.llvm.org/D41740#968567, @BRevzin wrote:
> In https://reviews.llvm.org/D41740#968134, @JonasToth wrote:
>
> > Could you please add a test case with a template that reduces the type to
> > int8 or uint8?
>
>
> I don't actually know how to do that. I tr
xazax.hun added a comment.
https://reviews.llvm.org/D41538 is superior and committed.
https://reviews.llvm.org/D37437
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
This revision was automatically updated to reflect the committed changes.
Closed by commit rC321933: [analyzer] Fix some check's output plist not
containing the check name (authored by xazax, committed by ).
Changed prior to commit:
https://reviews.llvm.org/D41538?vs=128630&id=128845#toc
Repos
Author: xazax
Date: Sat Jan 6 02:51:00 2018
New Revision: 321933
URL: http://llvm.org/viewvc/llvm-project?rev=321933&view=rev
Log:
[analyzer] Fix some check's output plist not containing the check name
Differential Revision: https://reviews.llvm.org/D41538
Modified:
cfe/trunk/include/clang/
khuttun updated this revision to Diff 128844.
khuttun added a comment.
Fix review comments
https://reviews.llvm.org/D41655
Files:
clang-tidy/bugprone/BugproneTidyModule.cpp
clang-tidy/bugprone/CMakeLists.txt
clang-tidy/bugprone/UnusedReturnValueCheck.cpp
clang-tidy/bugprone/UnusedReturn
khuttun marked an inline comment as done.
khuttun added inline comments.
Comment at: clang-tidy/bugprone/UnusedReturnValueCheck.cpp:69
+ "the value returned by %0 should normally be used")
+<< dyn_cast_or_null(Matched->getCalleeDecl())
+<< Matched->getSour
26 matches
Mail list logo