timshen created this revision.
Herald added a subscriber: sanjoy.
Herald added a reviewer: EricWF.
Currently it's checked in three places, including one place that's at
regex runtime.
There is no need to do runtime check, as all uses and definitions of
subexpress is known at regex compile-time.
timshen updated this revision to Diff 115554.
timshen added a comment.
Remove "#include " in the test. It was for debugging.
https://reviews.llvm.org/D37955
Files:
libcxx/include/regex
libcxx/test/std/re/re.alg/re.alg.search/invert_neg_word_search.pass.cpp
Index: libcxx/test/std/re/re.alg
timshen created this revision.
Herald added a subscriber: sanjoy.
Herald added a reviewer: EricWF.
Ideally we want !(neg_mask || neg_char), aka (!neg_mask && !neg_char). Before
the change, the code is (!neg_mask || !neg_char).
This fixes PR34310.
https://reviews.llvm.org/D37955
Files:
libcx
Lekensteyn added a comment.
I tried to contact Simon (the author of the GCC) patch with a question about
the -fno-canonical-system-headers, but his Google address is bouncing.
GCC has long survived with doing this by default, I wonder if this option could
just me omitted, enabling the feature b
Lekensteyn created this revision.
Herald added a subscriber: klimek.
GCC defaults to expanding the dependencies in depfiles, resolving
components like ".." and symlinks. Mimic this feature to ensure that the
Ninja build tool detects the correct dependencies when a symlink changes
directory levels,
This is a bug in the libc++ tests. It's OK for them to check that the
static_assert message is produced, but not that they're prefixed with the
exact string "static_assert failed:".
On 16 September 2017 at 05:54, NAKAMURA Takumi via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> This triggere
lebedev.ri added inline comments.
Comment at: clang-tidy/readability/FunctionCognitiveComplexityCheck.cpp:102-114
+const std::array CognitiveComplexity::Msgs = {{
+// B1 + B2 + B3
+"+%0, including nesting penalty of %1, nesting level increased to %2",
+
+// B1 + B2
+
lebedev.ri updated this revision to Diff 115547.
lebedev.ri marked 13 inline comments as done.
lebedev.ri added a comment.
Address even more @JonasToth's review notes.
- Fixed docs
- Validated the implementation (the testcase) against the "reference"
implementation
- Fixed discrepancies in the i
compnerd added inline comments.
Comment at: lib/CodeGen/CodeGenModule.cpp:477
Context.getTypeSizeInChars(Context.getWideCharType()).getQuantity();
- assert((LangOpts.ShortWChar ||
- llvm::TargetLibraryInfoImpl::getTargetWCharSize(Target.getTriple())
==
-
rjmccall added a comment.
Thanks, that looks good.
https://reviews.llvm.org/D32210
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Author: mstorsjo
Date: Sat Sep 16 13:52:05 2017
New Revision: 313470
URL: http://llvm.org/viewvc/llvm-project?rev=313470&view=rev
Log:
Fix a typo in the documentation. NFC.
Modified:
libunwind/trunk/docs/index.rst
Modified: libunwind/trunk/docs/index.rst
URL:
http://llvm.org/viewvc/llvm-pro
Thanks for doing this! It has been long time I work on big change for LLVM
so sorry for forgetting that.
On Saturday, September 16, 2017, NAKAMURA Takumi via Phabricator <
revi...@reviews.llvm.org> wrote:
> chapuni added a comment.
>
> Fixed in https://reviews.llvm.org/rL313456.
>
>
>
> =
This revision was automatically updated to reflect the committed changes.
Closed by commit rL313462: [X86] Remove unnecessary extra encodings from the
CPU name enum in clang (authored by ctopper).
Changed prior to commit:
https://reviews.llvm.org/D37938?vs=115512&id=115540#toc
Repository:
rL
Author: ctopper
Date: Sat Sep 16 09:44:39 2017
New Revision: 313462
URL: http://llvm.org/viewvc/llvm-project?rev=313462&view=rev
Log:
[X86] Remove unnecessary extra encodings from the CPU name enum in clang
Summary:
For a lot of older CPUs we have a 1:1 mapping between CPU name and enum name.
Bu
sepavloff updated this revision to Diff 115539.
sepavloff added a comment.
Rebased
https://reviews.llvm.org/D21508
Files:
include/clang/AST/DeclBase.h
lib/AST/Decl.cpp
lib/Sema/SemaDecl.cpp
lib/Sema/SemaTemplateInstantiateDecl.cpp
test/SemaCXX/friend2.cpp
Index: test/SemaCXX/friend2.
lebedev.ri added subscribers: thakis, cfe-commits, dblaikie, malcolm.parsons,
hans, lebedev.ri.
lebedev.ri raised a concern with this commit.
lebedev.ri added a comment.
Hi @thakis!
Are you planning on addressing the kind-of false-positives this diagnostic
produces?
It should not warn if `0` is:
This triggered failure in libcxx tests.
http://bb.pgr.jp/builders/bootstrap-clang-libcxx-lld-i686-linux/builds/97
On Fri, Sep 15, 2017 at 8:40 AM Douglas Gregor via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: dgregor
> Date: Thu Sep 14 16:38:42 2017
> New Revision: 313315
>
> URL:
sepavloff updated this revision to Diff 115534.
sepavloff added a comment.
Rebased patch.
https://reviews.llvm.org/D30170
Files:
include/clang/AST/Decl.h
lib/Sema/SemaDecl.cpp
lib/Sema/SemaTemplateInstantiateDecl.cpp
test/SemaCXX/friend2.cpp
Index: test/SemaCXX/friend2.cpp
JonasToth added a comment.
Informationen my part think that both switch and else should stay here for now.
Running it over llvm gave really a lot of warnings, and that a rather good
codebase.
The check did not recognize logic, your example would be warned against. I
don't see a way to implemen
lebedev.ri added a comment.
In https://reviews.llvm.org/D37808#869810, @Eugene.Zelenko wrote:
> In https://reviews.llvm.org/D37808#869612, @JonasToth wrote:
>
> > In https://reviews.llvm.org/D37808#869602, @Eugene.Zelenko wrote:
> >
> > > I think will be good idea to extend -Wswitch diagnostics.
chapuni added a comment.
Fixed in https://reviews.llvm.org/rL313456.
Comment at: include/llvm/IR/DiagnosticHandler.h:12
+//===--===//
+
+#include "llvm/ADT/StringRef.h"
Did you forget include g
JonasToth added a comment.
In https://reviews.llvm.org/D37808#869810, @Eugene.Zelenko wrote:
> In https://reviews.llvm.org/D37808#869612, @JonasToth wrote:
>
> > In https://reviews.llvm.org/D37808#869602, @Eugene.Zelenko wrote:
> >
> > > I think will be good idea to extend -Wswitch diagnostics.
>
JonasToth added a comment.
I see, forgot that.
The doc were the interesting part for me, I trust that you test the code
correctlty :)
Repository:
rL LLVM
https://reviews.llvm.org/D36836
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
ht
lebedev.ri added a comment.
In https://reviews.llvm.org/D36836#873032, @JonasToth wrote:
> I built the patch locally, here is my output:
>
> The Unittest failed for me: `Neither CHECK-FIXES nor CHECK-MESSAGES found in
> the input`
>
> Script call:
> `/usr/bin/python2.7
> /home/jonas/opt/llvm/
JonasToth added a comment.
I built the patch locally, here is my output:
The Unittest failed for me: `Neither CHECK-FIXES nor CHECK-MESSAGES found in
the input`
Script call:
`/usr/bin/python2.7
/home/jonas/opt/llvm/tools/clang/tools/extra/test/../test/clang-tidy/check_clang_tidy.py
/home/jo
RKSimon accepted this revision.
RKSimon added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D37938
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe
RKSimon accepted this revision.
RKSimon added a comment.
This revision is now accepted and ready to land.
LGTM, there are a couple of other fall-throughs that could still be done.
Comment at: lib/Basic/Targets/X86.cpp:141
setFeatureEnabledImpl(Features, "sse2", true);
27 matches
Mail list logo