dberris created this revision.
This change allows us to add arg1 logging support to functions through
the special case list provided through -fxray-always-instrument=. This
is useful for adding arg1 logging to functions that are either in
headers that users don't have control over (i.e. cannot cha
dexonsmith added inline comments.
Comment at: src/cxa_demangle.cpp:3042-3051
+for (size_t k = k0; k < k1; ++k) {
+auto tmp = db.names[k].move_full();
+if (!tmp.empty())
+{
+
compnerd added inline comments.
Comment at: cmake/caches/BaremetalARM.cmake:1
+set(LLVM_TARGETS_TO_BUILD ARM CACHE STRING "")
+
jroelofs wrote:
> compnerd wrote:
> > Please rename this file to `BareMetalARMv6.cmake`. (I'm interested in the
> > suffix primarily)
faisalv closed this revision.
faisalv added a comment.
Committed here : https://reviews.llvm.org/rL303492
https://reviews.llvm.org/D31588
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-comm
faisalv closed this revision.
faisalv added a comment.
Closed by commit https://reviews.llvm.org/rL295279
https://reviews.llvm.org/D29748
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-comm
compnerd requested changes to this revision.
compnerd added inline comments.
This revision now requires changes to proceed.
Comment at: src/cxa_demangle.cpp:3036
break;
-if (db.names.size() < 2)
+if (k1 <= k0)
compnerd added a comment.
Can you please ensure that you cross-port this into
`llvm/lib/Demangle/ItaniumDemangle.cpp`?
https://reviews.llvm.org/D33385
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/lis
martell added a comment.
I want to give some context here to dispel the confusion of what is and isn't
win32 api specific.
First lets take `vasprintf` and `asprintf ` which are not implemented in msvcrt.
In mingw-w64 we would just have posix implementations of both.
They are hidden behind the gu
atanasyan updated this revision to Diff 99703.
atanasyan added a comment.
Thanks for review.
This changes:
- Allow simultaneous using of micromips and interrupt attributes.
- Fix wording of micromips attribute description.
Repository:
rL LLVM
https://reviews.llvm.org/D33363
Files:
includ
aaron.ballman added inline comments.
Comment at: include/clang/ASTMatchers/ASTMatchers.h:3846
+ CXXBoolLiteralExpr,
+ IntegerLiteral),
+ unsi
sepavloff updated this revision to Diff 99698.
sepavloff added a comment.
Made the patch a bit more compact. NFC.
https://reviews.llvm.org/D30170
Files:
include/clang/AST/Decl.h
lib/AST/Decl.cpp
lib/Sema/SemaDecl.cpp
test/SemaCXX/cxx0x-cursory-default-delete.cpp
test/SemaCXX/friend2.c
aaron.ballman added a reviewer: aaron.ballman.
aaron.ballman added a comment.
In https://reviews.llvm.org/D3#760419, @jyu2 wrote:
> In https://reviews.llvm.org/D3#760149, @aaron.ballman wrote:
>
> > As an FYI, there is a related check currently under development in
> > clang-tidy; we pro
jyu2 added a comment.
In https://reviews.llvm.org/D3#760149, @aaron.ballman wrote:
> As an FYI, there is a related check currently under development in
> clang-tidy; we probably should not duplicate this functionality in both
> places. See https://reviews.llvm.org/D19201 for the other rev
aaron.ballman added a comment.
In https://reviews.llvm.org/D33135#754278, @Lekensteyn wrote:
> By the way, I think that `long double` is less common than long unsigned
> literals, so changing unsigned to uint64_t might be something more important?
I agree that it's likely a more common use cas
tberghammer created this revision.
Previously if we parsed a constructor then we set parsed_ctor_dtor_cv
to true and never reseted it. This causes issue when a template argument
references a constructor (e.g. type of lambda defined inside a
constructor) as we will have the parsed_ctor_dtor_cv flag
aaron.ballman added a comment.
In https://reviews.llvm.org/D19201#760358, @Prazek wrote:
> In https://reviews.llvm.org/D19201#760151, @aaron.ballman wrote:
>
> > As an FYI, there is a related check being implemented in clang currently;
> > we probably should not duplicate this effort. See
> > h
oren_ben_simhon added inline comments.
Comment at: lib/CodeGen/CGBuiltin.cpp:7526
+llvm::Type *ResultType = ConvertType(E->getType());
+llvm::Function *F = CGM.getIntrinsic(Intrinsic::ctpop, ResultType);
+return Builder.CreateCall(F, Ops);
oren_ben_si
oren_ben_simhon added inline comments.
Comment at: lib/CodeGen/CGBuiltin.cpp:7527
+Value *X = EmitScalarExpr(E->getArg(0));
+llvm::Function *F = CGM.getIntrinsic(Intrinsic::ctpop, ResultType);
+return Builder.CreateCall(F, X);
craig.topper wrote:
> I
Prazek accepted this revision.
Prazek added a comment.
LGTM, but wait if Aaron will accept it.
https://reviews.llvm.org/D19201
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
Prazek added a comment.
In https://reviews.llvm.org/D19201#760151, @aaron.ballman wrote:
> As an FYI, there is a related check being implemented in clang currently; we
> probably should not duplicate this effort. See
> https://reviews.llvm.org/D3.
I think that clang is the right place for
Prazek added a comment.
Could you add similar tests as the ones that Stanislaw provied in his patch?
Like the one with checking if throw is catched, or the conditional noexcept (by
a macro, etc)
https://reviews.llvm.org/D3
___
cfe-commits maili
craig.topper added inline comments.
Comment at: lib/CodeGen/CGBuiltin.cpp:7526
+llvm::Type *ResultType = ConvertType(E->getType());
+llvm::Function *F = CGM.getIntrinsic(Intrinsic::ctpop, ResultType);
+return Builder.CreateCall(F, Ops);
Why did the ca
Author: ctopper
Date: Sun May 21 02:29:07 2017
New Revision: 303501
URL: http://llvm.org/viewvc/llvm-project?rev=303501&view=rev
Log:
[Format] Add curly braces to suppress a -Wmisleading-indentation warning from
gcc.
Modified:
cfe/trunk/lib/Format/TokenAnnotator.cpp
Modified: cfe/trunk/lib/
oren_ben_simhon updated this revision to Diff 99685.
oren_ben_simhon marked an inline comment as done.
oren_ben_simhon added a comment.
Implemented comments posted until 05/20 (Thanks Craig)
Repository:
rL LLVM
https://reviews.llvm.org/D33170
Files:
include/clang/Basic/BuiltinsX86.def
in
24 matches
Mail list logo