brenoguim updated this revision to Diff 93062.
brenoguim added a comment.
- Removed the "#include " which caused problems in environments
without that header
- Included a directory with -isystem to simulate system headers
- Added a "macro.h" header with definitions of types, functions and macros
Author: gornishanov
Date: Sat Mar 25 21:18:05 2017
New Revision: 298784
URL: http://llvm.org/viewvc/llvm-project?rev=298784&view=rev
Log:
[coroutines] Add codegen for await and yield expressions
Details:
Emit suspend expression which roughly looks like:
auto && x = CommonExpr();
if (!x.await_re
GorNishanov updated this revision to Diff 93061.
GorNishanov added a comment.
Thank you very much for the review!
Merged with the top of the trunk and preparing to land
https://reviews.llvm.org/D30809
Files:
lib/CodeGen/CGCoroutine.cpp
lib/CodeGen/CGExprAgg.cpp
lib/CodeGen/CGExprComplex.
aaron.ballman added inline comments.
Comment at: clang-tidy/cppcoreguidelines/ProTypeMemberInitCheck.cpp:377
+else if (type->isIntegerType())
+ Initializer = " = 0";
+else if (type->isFloatingType())
mgehre wrote:
> aaron.ballman wrote:
>
mgehre added inline comments.
Comment at: clang-tidy/modernize/NoexceptCorrectnessCheck.cpp:60
+ N.getNodeAs("direct_throwing_decl")) {
+// FIXME how is that done? i did not find a noThrow predicate
+//if (ThrowingDecl->isNoThrow()) {
JonasToth w
mgehre added a comment.
Friendly ping
https://reviews.llvm.org/D18914
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
mgehre updated this revision to Diff 93057.
mgehre added a comment.
Rename check to readability-operators-representation
https://reviews.llvm.org/D31308
Files:
clang-tidy/readability/CMakeLists.txt
clang-tidy/readability/OperatorsRepresentationCheck.cpp
clang-tidy/readability/OperatorsRep
mgehre added inline comments.
Comment at: clang-tidy/cppcoreguidelines/ProTypeMemberInitCheck.cpp:377
+else if (type->isIntegerType())
+ Initializer = " = 0";
+else if (type->isFloatingType())
aaron.ballman wrote:
> What about cases where
mgehre updated this revision to Diff 93056.
mgehre marked 2 inline comments as done.
mgehre added a comment.
Add suffix for floating point literals; clang-format
https://reviews.llvm.org/D24892
Files:
clang-tidy/cppcoreguidelines/ProTypeMemberInitCheck.cpp
clang-tidy/cppcoreguidelines/ProTy
mgehre updated this revision to Diff 93055.
mgehre added a comment.
Added test to misc; minor wording
https://reviews.llvm.org/D24886
Files:
include/clang/Basic/Attr.td
include/clang/Basic/AttrDocs.td
lib/Sema/SemaDeclAttr.cpp
lib/Sema/SemaStmtAttr.cpp
test/Misc/ast-dump-attr.cpp
te
Reading comprehension is hard. :)
Thanks for the catch.
echristo@athyra ~/s/l/t/clang> git svn dcommit
Committing to https://llvm.org/svn/llvm-project/cfe/trunk ...
M lib/Basic/Targets.cpp
M test/Preprocessor/init.c
Committed r298778
-eric
On Sat, Mar 25, 2017 at 12:44 AM David Majnemer
wrote:
Author: echristo
Date: Sat Mar 25 14:26:04 2017
New Revision: 298778
URL: http://llvm.org/viewvc/llvm-project?rev=298778&view=rev
Log:
_CALL_LINUX is only defined on 64-bit ppc linux platforms, not 32-bit.
Adjust and add a test for the 32-bit side.
Modified:
cfe/trunk/lib/Basic/Targets.cpp
Eugene.Zelenko added a comment.
Please mention this check in docs/ReleaseNotes.rst (in alphabetical order).
Comment at: docs/clang-tidy/checks/modernize-noexcept-correctness.rst:7
+This check will mark functions as noexcept if that is possible.
+`noexcept` is a new keyword in C
rjmccall accepted this revision.
rjmccall added a comment.
This revision is now accepted and ready to land.
Looks great, thanks.
https://reviews.llvm.org/D30809
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/ma
rjmccall accepted this revision.
rjmccall added a comment.
This revision is now accepted and ready to land.
LGTM, thanks.
https://reviews.llvm.org/D31005
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/l
anemet added a comment.
In https://reviews.llvm.org/D31276#710608, @hfinkel wrote:
> In https://reviews.llvm.org/D31276#709111, @anemet wrote:
>
> > In https://reviews.llvm.org/D31276#708992, @hfinkel wrote:
> >
> > > High-level comment ;)
> > >
> > > #pragma clang fast_math contract_fast(on)
>
hfinkel added a comment.
In https://reviews.llvm.org/D31276#709111, @anemet wrote:
> In https://reviews.llvm.org/D31276#708992, @hfinkel wrote:
>
> > High-level comment ;)
> >
> > #pragma clang fast_math contract_fast(on)
> >
> >
> > This seems a bit unfortunate because 'fast' appears twice?
Author: yaxunl
Date: Sat Mar 25 06:34:41 2017
New Revision: 298773
URL: http://llvm.org/viewvc/llvm-project?rev=298773&view=rev
Log:
[AMDGPU] Make AMDGPUTargetInfo::AS private
Modified:
cfe/trunk/lib/Basic/Targets.cpp
Modified: cfe/trunk/lib/Basic/Targets.cpp
URL:
http://llvm.org/viewvc/llv
v.g.vassilev added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/CloneChecker.cpp:147
+// different algorithm).
+// TODO: In very big clones even multiple variables can be unintended,
+// so replacing this number with a percentage could better h
Thanks for your comments. I will fix that.
Sam
From: Eric Christopher [mailto:echri...@gmail.com]
Sent: Saturday, March 25, 2017 1:52 AM
To: Liu, Yaxun (Sam) ; cfe-commits@lists.llvm.org
Subject: Re: r298767 - [AMDGPU] Switch address space mapping by triple
environment amdgiz
On Fri, Mar 24, 2
Shouldn't this only be defined on 64-bit PPC platforms? I think that's what
GCC does:
https://github.com/gcc-mirror/gcc/blob/700a97608cadfe8adcd1a98e6388a5cbee9d76f6/gcc/config/rs6000/linux64.h#L372
On Fri, Mar 24, 2017 at 8:33 PM, Eric Christopher via cfe-commits <
cfe-commits@lists.llvm.org> wro
21 matches
Mail list logo