Thank you very much for the suggestion, it helped clean up the algorithm
for what I was trying to do in r251388.
-eric
On Mon, Oct 26, 2015 at 5:12 PM Eric Christopher wrote:
> On Mon, Oct 26, 2015 at 5:11 PM David Blaikie wrote:
>
>> On Mon, Oct 26, 2015 at 5:06 PM, Eric Christopher via cfe-c
Author: echristo
Date: Tue Oct 27 01:11:03 2015
New Revision: 251388
URL: http://llvm.org/viewvc/llvm-project?rev=251388&view=rev
Log:
Handle target builtin options that are all required rather than
only one of a group of possibilities.
This changes the syntax in the builtin files to represent:
Author: rsmith
Date: Tue Oct 27 01:02:45 2015
New Revision: 251387
URL: http://llvm.org/viewvc/llvm-project?rev=251387&view=rev
Log:
[coroutines] Creation of promise object, lookup of operator co_await, building
of await_* calls, and AST representation for same.
Modified:
cfe/trunk/include/cl
Author: davidxl
Date: Tue Oct 27 00:15:35 2015
New Revision: 251385
URL: http://llvm.org/viewvc/llvm-project?rev=251385&view=rev
Log:
Create undef reference to profile hook symbol
Create undef reference to profile hook symbol when
PGO instrumentation is turned on. This allows
LLVM to omit emiss
Author: rjmccall
Date: Mon Oct 26 23:54:50 2015
New Revision: 251384
URL: http://llvm.org/viewvc/llvm-project?rev=251384&view=rev
Log:
Be more conservative about diagnosing "incorrect" uses of __weak:
allow them to be written in certain kinds of user declaration and
diagnose on the use-site instea
On Mon, Oct 26, 2015 at 9:43 PM, Daniel Jasper wrote:
> If you look closely, there are multiple tests for different configuration
> options.
>
Ah, I see one that's "( int, int )" now - cool, thanks!
> The before/after is always just one example.
>
> On Tue, Oct 27, 2015 at 5:42 AM, David Blaik
If you look closely, there are multiple tests for different configuration
options. The before/after is always just one example.
On Tue, Oct 27, 2015 at 5:42 AM, David Blaikie wrote:
>
>
> On Mon, Oct 26, 2015 at 9:21 PM, Daniel Jasper wrote:
>
>> I mixed up before and after. Other than that, I
On Mon, Oct 26, 2015 at 9:21 PM, Daniel Jasper wrote:
> I mixed up before and after. Other than that, I don't see a typo.
>
It looks like the test case "+ verifyFormat("std::function< void(int, int)
> fct;", Spaces);" ensures no spaces between the parameters and the () in
the function type ("vo
I mixed up before and after. Other than that, I don't see a typo.
On Mon, Oct 26, 2015 at 5:44 PM, David Blaikie wrote:
>
>
> On Mon, Oct 26, 2015 at 5:08 AM, Daniel Jasper via cfe-commits <
> cfe-commits@lists.llvm.org> wrote:
>
>> Author: djasper
>> Date: Mon Oct 26 07:08:47 2015
>> New Revisi
ping
On Mon, Oct 19, 2015 at 5:59 PM, Akira Hatanaka wrote:
> ahatanak updated this revision to Diff 37816.
> ahatanak added a comment.
>
> Address review comments:
>
> 1. Renamed the attribute to "not_tail_called".
>
> I chose "not_tail_called" over "notailcall" or "notail" to better
> distingu
djasper created this revision.
djasper added a reviewer: klimek.
djasper added a subscriber: cfe-commits.
Herald added a subscriber: klimek.
This is especially important so that if a change is solely inserting a block
around a few statements, clang-format-diff.py will still clean up and add
inde
djasper created this revision.
djasper added a reviewer: klimek.
djasper added a subscriber: cfe-commits.
Herald added a subscriber: klimek.
If this option is set, clang-format will always insert a line wrap, e.g.
before the first parameter of a function call unless all parameters fit
on the same
jroelofs added a comment.
LGTM
Comment at: lib/Driver/ToolChains.cpp:3545
@@ +3544,3 @@
+!VersionText.slice(1, StringRef::npos).getAsInteger(10, Version)) {
+ if (Version > MaxVersion) {
+MaxVersion = Version;
Since you've got logic here to
eugenis added a comment.
ping
We will need this when libc++ is bumped to v2. There are no plans to do this
AFAIK but the ABI version macros are in so it is possible and clang should be
ready.
http://reviews.llvm.org/D12382
___
cfe-commits mailing
On Mon, Oct 26, 2015 at 5:11 PM David Blaikie wrote:
> On Mon, Oct 26, 2015 at 5:06 PM, Eric Christopher via cfe-commits <
> cfe-commits@lists.llvm.org> wrote:
>
>> Author: echristo
>> Date: Mon Oct 26 19:06:21 2015
>> New Revision: 251371
>>
>> URL: http://llvm.org/viewvc/llvm-project?rev=251371
On Mon, Oct 26, 2015 at 5:06 PM, Eric Christopher via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: echristo
> Date: Mon Oct 26 19:06:21 2015
> New Revision: 251371
>
> URL: http://llvm.org/viewvc/llvm-project?rev=251371&view=rev
> Log:
> Use early exits to reduce indentation.
>
> Mod
Author: echristo
Date: Mon Oct 26 19:06:21 2015
New Revision: 251371
URL: http://llvm.org/viewvc/llvm-project?rev=251371&view=rev
Log:
Use early exits to reduce indentation.
Modified:
cfe/trunk/lib/CodeGen/CGBuiltin.cpp
Modified: cfe/trunk/lib/CodeGen/CGBuiltin.cpp
URL:
http://llvm.org/view
sbenza added inline comments.
Comment at: clang-tidy/cppcoreguidelines/ProTypeCstyleCastCheck.cpp:44
@@ +43,3 @@
+ if (MatchedCast->getCastKind() == CK_BitCast ||
+ MatchedCast->getCastKind() == CK_LValueBitCast ||
+ MatchedCast->getCastKind() == CK_IntegralToPointer ||
mgehre created this revision.
mgehre added reviewers: alexfh, sbenza, bkramer, aaron.ballman.
mgehre added a subscriber: cfe-commits.
This check flags all use of c-style casts that perform a static_cast
downcast, const_cast, or reinterpret_cast.
Use of these casts can violate type safety and caus
This revision was automatically updated to reflect the committed changes.
Closed by commit rL251358: [clang-tidy] Add new check
cppcoreguidelines-pro-bounds-array-to-pointer-decay (authored by mgehre).
Changed prior to commit:
http://reviews.llvm.org/D13640?vs=38353&id=38467#toc
Repository:
Author: mgehre
Date: Mon Oct 26 16:56:02 2015
New Revision: 251358
URL: http://llvm.org/viewvc/llvm-project?rev=251358&view=rev
Log:
[clang-tidy] Add new check cppcoreguidelines-pro-bounds-array-to-pointer-decay
Summary:
This check flags all array to pointer decays.
Pointers should not be used a
Author: mgehre
Date: Mon Oct 26 16:48:08 2015
New Revision: 251355
URL: http://llvm.org/viewvc/llvm-project?rev=251355&view=rev
Log:
clang-tidy/add_new_check.py: Adapt to use %check_clang_tidy in tests
Summary: Adapt clang-tidy/add_new_check.py according to commit r251010 "Add
%check_clang_tidy
This revision was automatically updated to reflect the committed changes.
Closed by commit rL251355: clang-tidy/add_new_check.py: Adapt to use
%check_clang_tidy in tests (authored by mgehre).
Changed prior to commit:
http://reviews.llvm.org/D14049?vs=38354&id=38466#toc
Repository:
rL LLVM
h
rjmccall added inline comments.
Comment at: include/clang/AST/ExprCXX.h:689
@@ +688,3 @@
+/// indices. In this case, i=p->x[a][b] will be turned into i=p->GetX(a, b),
and
+/// p->x[a][b] = i will be turned into p->PutX(a, b, i).
+class MSPropertySubscriptExpr : public Expr {
thakis added a reviewer: rnk.
thakis added a comment.
rnk: Can you look at this if Richard is still away doing committee thing?
http://reviews.llvm.org/D13969
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mail
sbenza added a comment.
Just fyi, I am looking at this diff. It is very large with a lot of rounds of
comments and I didn't have the context.
I don't know if I should giving comments at this point of the change, but here
it is.
Have you considered matching on typeLoc() instead of having a large
Hi,
this patch addresses a crash-on-valid on 3.7. Could you please merge
this to 3.7 branch?
Ismail
On Mon, Oct 26, 2015 at 8:20 PM, Ismail Pazarbasi via cfe-commits
wrote:
> Author: ismailp
> Date: Mon Oct 26 14:20:24 2015
> New Revision: 251335
>
> URL: http://llvm.org/viewvc/llvm-project?rev
This revision was automatically updated to reflect the committed changes.
Closed by commit rL251335: MismatchingNewDeleteDetector uses incorrect field,
and finds no initializer (authored by ismailp).
Changed prior to commit:
http://reviews.llvm.org/D9898?vs=26271&id=38449#toc
Repository:
rL
Author: ismailp
Date: Mon Oct 26 14:20:24 2015
New Revision: 251335
URL: http://llvm.org/viewvc/llvm-project?rev=251335&view=rev
Log:
MismatchingNewDeleteDetector uses incorrect field, and finds no initializer
Summary:
In `MismatchingNewDeleteDetector::analyzeInClassInitializer`, if
`Field`'s ini
Author: ericwf
Date: Mon Oct 26 14:08:53 2015
New Revision: 251334
URL: http://llvm.org/viewvc/llvm-project?rev=251334&view=rev
Log:
Fix test suite configuration. Sorry Marshall
Modified:
libcxx/trunk/test/libcxx/test/config.py
Modified: libcxx/trunk/test/libcxx/test/config.py
URL:
http://l
chandlerc added a comment.
In http://reviews.llvm.org/D13802#274847, @ABataev wrote:
> Hi Chandler, thanks for the review.
>
> In http://reviews.llvm.org/D13802#272053, @chandlerc wrote:
>
> > I've also had one test fail, and then start passing for me on Linux (after
> > fixing the above). I hav
pgousseau updated this revision to Diff 38438.
pgousseau added a comment.
Following Anna's review:
Remove unnecessary AST walk over declarations by reusing already captured
declarations.
Add handling of merge conflicts using Sema merge methods.
Add condition at the end of ModelInjector::onBodySy
sbenza accepted this revision.
sbenza added a comment.
This revision is now accepted and ready to land.
Thanks for the fix.
http://reviews.llvm.org/D14049
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/
sbenza accepted this revision.
sbenza added a comment.
This revision is now accepted and ready to land.
Just one formatting comment.
Comment at:
clang-tidy/cppcoreguidelines/ProBoundsArrayToPointerDecayCheck.cpp:52
@@ +51,3 @@
+
+ diag(MatchedCast->getExprLoc(), "do not implic
Added missing testcase in r251313.
On 26 October 2015 at 17:45, David Blaikie wrote:
>
>
> On Mon, Oct 26, 2015 at 6:32 AM, Gabor Horvath via cfe-commits <
> cfe-commits@lists.llvm.org> wrote:
>
>> Author: xazax
>> Date: Mon Oct 26 08:32:26 2015
>> New Revision: 251289
>>
>> URL: http://llvm.org
Author: xazax
Date: Mon Oct 26 12:42:14 2015
New Revision: 251313
URL: http://llvm.org/viewvc/llvm-project?rev=251313&view=rev
Log:
[analyzer] Added a missing test case for r251289.
Modified:
cfe/trunk/test/Analysis/lambdas.cpp
Modified: cfe/trunk/test/Analysis/lambdas.cpp
URL:
http://llvm.
This revision was automatically updated to reflect the committed changes.
Closed by commit rL251312: [analyzer] ccc-analyzer: Fix -isystem value passing.
(authored by dcoughlin).
Changed prior to commit:
http://reviews.llvm.org/D13800?vs=37567&id=38433#toc
Repository:
rL LLVM
http://reviews
Author: dcoughlin
Date: Mon Oct 26 12:19:51 2015
New Revision: 251312
URL: http://llvm.org/viewvc/llvm-project?rev=251312&view=rev
Log:
[analyzer] ccc-analyzer: Fix -isystem value passing.
The regex for -isystem matching is broken. -[D,I,Usystem] matches "-D", "-,",
"-I", "-U", "-s" "-y", etc. Be
On 26 October 2015 at 17:45, David Blaikie wrote:
>
>
> On Mon, Oct 26, 2015 at 6:32 AM, Gabor Horvath via cfe-commits <
> cfe-commits@lists.llvm.org> wrote:
>
>> Author: xazax
>> Date: Mon Oct 26 08:32:26 2015
>> New Revision: 251289
>>
>> URL: http://llvm.org/viewvc/llvm-project?rev=251289&view
On Mon, Oct 26, 2015 at 5:08 AM, Daniel Jasper via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: djasper
> Date: Mon Oct 26 07:08:47 2015
> New Revision: 251284
>
> URL: http://llvm.org/viewvc/llvm-project?rev=251284&view=rev
> Log:
> clang-format: Fix false positive in cast detection
On Mon, Oct 26, 2015 at 6:32 AM, Gabor Horvath via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Author: xazax
> Date: Mon Oct 26 08:32:26 2015
> New Revision: 251289
>
> URL: http://llvm.org/viewvc/llvm-project?rev=251289&view=rev
> Log:
> [analyzer] Fixed a rare crash when analyzing lambda
seaneveson marked an inline comment as done.
seaneveson added a comment.
Hi Devin,
Sorry it also took me so long to get back to you.
Comment at: include/clang/StaticAnalyzer/Core/AnalyzerOptions.h:266
@@ +265,3 @@
+ /// \sa shouldWidenLoops
+ bool WidenLoops;
+
--
hans added a comment.
The release script change looks good to me. Better than good actually; it's a
great improvement :-)
http://reviews.llvm.org/D13802
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/l
ygribov marked 43 inline comments as done.
ygribov added a comment.
http://reviews.llvm.org/D14014
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
ygribov removed rL LLVM as the repository for this revision.
ygribov updated this revision to Diff 38423.
ygribov added a comment.
Updated based on review.
http://reviews.llvm.org/D14014
Files:
lib/StaticAnalyzer/Checkers/CMakeLists.txt
lib/StaticAnalyzer/Checkers/Checkers.td
lib/StaticAn
On Mon, Oct 26, 2015 at 8:44 AM, Vedant Kumar wrote:
> vsk added a comment.
>
> This looks good to me. Does this mean we will get rid of
> `getInstrProfRuntimeHookVarUseFuncName`?
>
not yet -- note that this is only enabled for Linux toolchain only for
now. If it works for all platforms, we can
Great.
So this is what I wanted to know. I think understand what you are saying.
You are saying that most of the work that I would need to do from the AST
(I'm assuming that this stands from Abstract Syntax Tree) is allready being
done by LLVM and I should look to modify for a my new arquitecture.
vsk added a comment.
This looks good to me. Does this mean we will get rid of
`getInstrProfRuntimeHookVarUseFuncName`?
http://reviews.llvm.org/D14030
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/list
On Monday, October 26, 2015, Ariel Arelovich via cfe-commits <
cfe-commits@lists.llvm.org> wrote:
> Hi:
>
> Where I'm working I've been asked to look into developing a C (by this I
> mean C89 C standard) compiler a new processor architecture being created
> inhouse.
>
> On looking at the options a
o.gyorgy added a comment.
Hi,
You are right the diff is is based on the hash. We already tried to
use an earlier hash generator (before the patch was introduced), which
generates a slightly different plist, that is why the current version
does not work with the patch.
We will fix CodeChecker to u
Hi,
You are right the diff is is based on the hash. We already tried to
use an earlier hash generator (before the patch was introduced), which
generates a slightly different plist, that is why the current version
does not work with the patch.
We will fix CodeChecker to use new hash tag introduced
Hi:
Where I'm working I've been asked to look into developing a C (by this I
mean C89 C standard) compiler a new processor architecture being created
inhouse.
On looking at the options and brushing up on compiler theory, I came up
with Flex/Bison, Writing the compiler from scratch or use Clang. I
Author: xazax
Date: Mon Oct 26 08:32:26 2015
New Revision: 251289
URL: http://llvm.org/viewvc/llvm-project?rev=251289&view=rev
Log:
[analyzer] Fixed a rare crash when analyzing lambda functions.
Modified:
cfe/trunk/lib/StaticAnalyzer/Core/MemRegion.cpp
Modified: cfe/trunk/lib/StaticAnalyzer/
Some high level style comments:
1. Please convert the file to LLVM style for the things that
clang-format doesn't change. In particular PascalCase for all
variables and cameCase for all function names.
2. We don't do author attribution in file comments, sorry.
3. Try to avoid commented out/#if 0'd
jeanphilippeD added a comment.
Thanks a lot.
Yes, it makes a lot more sense this way.
http://reviews.llvm.org/D14052
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
djasper accepted this revision.
djasper added a comment.
This revision is now accepted and ready to land.
Submitted tests and alternative fix in r251284. Seems to me, there can never be
a cast right before a ">".
http://reviews.llvm.org/D14052
___
Author: djasper
Date: Mon Oct 26 07:08:47 2015
New Revision: 251284
URL: http://llvm.org/viewvc/llvm-project?rev=251284&view=rev
Log:
clang-format: Fix false positive in cast detection.
Before (with spaces in parentheses):
void inFunction() { std::function fct; }
After:
void inFunction() { s
Author: d0k
Date: Mon Oct 26 04:57:00 2015
New Revision: 251279
URL: http://llvm.org/viewvc/llvm-project?rev=251279&view=rev
Log:
Drop dead return after llvm_unreachable. NFC.
Modified:
clang-tools-extra/trunk/clang-tidy/readability/ImplicitBoolCastCheck.cpp
Modified:
clang-tools-extra/trun
58 matches
Mail list logo