[bug #57962] make attempts to execute a directory found on PATH

2020-05-21 Thread anonymous
Follow-up Comment #12, bug #57962 (project make): [comment #7 comment #7:] > I verified this fix was applied to gnulib, so it will be present in the next release of GNU make. Thanks! It seems that gnulib fixed findprog but not findprog_in that GNU make uses so the bug is still present. _

Re: Tail call elimination

2020-05-21 Thread Pete Dietl
> 5 + (2 * 9 / (7 + 5 + 4)) * (1024 * 1024) / 19 > > becomes: > > $(math +, 5 $(math /, $(math *, $(math /, $(math *, 2 9) $(math +, 7 5 4)) > $(math *, 1024 1024)) 19)) > > versus: > > $(op + 5 $(op / $(op * $(op / $(op * 2 9) $(op + 7 5 4)) $(op * 1024 1024)) > 19)) > > or: > > $(+ 5 $(

Re: Tail call elimination

2020-05-21 Thread Paul Smith
On Thu, 2020-05-21 at 11:46 -0400, Paul Smith wrote: > In my discussion of the way to handle conditions I even mentioned > allowing just one operand which would give the identity function. > > After sleeping on it, though, I'm not sure if that's the best idea. > Maybe we should assume "0" for a m

Re: Tail call elimination

2020-05-21 Thread Paul Smith
On Thu, 2020-05-21 at 11:22 -0500, Kevin R. Bulgrien wrote: >FILE_SIZES := 5 2 1 4 >TOTAL :- $(math +, $(FILE_SIZES)) > > 2) > > FILE_SIZES := 5 2 1 4 > TOTAL :- $(+ $(FILE_SIZES)) > > In my mind, TOTAL obviously ends up with the same value, but, 1) is > more readable in the same way

Re: Tail call elimination

2020-05-21 Thread Kevin R. Bulgrien
> I plan to bow out of this discussion as I'm not vested in it, but, a > distinguishing significant functional or interpretive difference > between these two forms is not self-evident: > > 1) > >FILE_SIZES := 5 2 1 4 >TOTAL :- $(math +, $(FILE_SIZES)) > > 2) > > FILE_SIZES := 5 2 1 4

Re: Tail call elimination

2020-05-21 Thread Kevin R. Bulgrien
> There's something to be said for this being able potentially to work > - not that I'm pushing it mind: > FILE_SIZES:= 5 2 1 4 > TOTAL:=$(+ $(FILE_SIZES)) # TOTAL is 5+2+1+4 > Here I'm not objecting to ($math +,$(FILE_SIZES)) or $(op > +,$(FILE_SIZES)) - whatever on them - I am only trying to po

Re: Tail call elimination

2020-05-21 Thread Paul Smith
On Thu, 2020-05-21 at 15:35 +, Tim Murphy wrote: > There's something to be said for this being able potentially to work > - not that I'm pushing it mind: > > FILE_SIZES:= 5 2 1 4 > TOTAL:=$(+ $(FILE_SIZES)) # TOTAL is 5+2+1+4 > > Here I'm not objecting to ($math +,$(FILE_SIZES)) or $(op > +,$

Re: Tail call elimination

2020-05-21 Thread Tim Murphy
On Thu, 21 May 2020 at 13:08, Paul Smith wrote: > > > Other function syntax where there are "different" types of parameters > > or arguments (i.e. subst, patsubst, findstring, filter, etc.), use a > > syntax something like: > > > > $(math operator, value list) > > > > Consistent syntax patterns a

Re: Tail call elimination

2020-05-21 Thread Paul Smith
On Thu, 2020-05-21 at 00:37 -0500, Kevin R. Bulgrien wrote: > > Of course we can still do prefix notation with a single function we > > just have to choose a name for it and it's a little less slick; for > > example something like: > > > >$(op + 5 7 $(op * 3 2) 9) > > > > or whatever so the f