[PATCH v2 rumpkernel] pci-userspace: Add acpi lookup of irqs with fallback

2023-01-17 Thread Damien Zammit
--- debian/patches/acpi.diff | 78 debian/patches/series| 1 + 2 files changed, 79 insertions(+) create mode 100644 debian/patches/acpi.diff diff --git a/debian/patches/acpi.diff b/debian/patches/acpi.diff new file mode 100644 index 0..3ee6d2

Re: [PATCH 2/7] x86_64: expand and shrink messages in copy{in, out}msg routines

2023-01-17 Thread Luca
Luca Dariz, le lun. 16 janv. 2023 11:58:52 +0100, a ecrit: +static inline int copyin_address(const rpc_vm_offset_t *uaddr, vm_offset_t *kaddr) +{ +#ifdef __x86_64 + return copyin_32to64(uaddr, kaddr); +#else /* __x86_64__ */ + return copyin(uaddr, kaddr, sizeof(*uaddr)); +#endif /* __x86_64__

Re: [PATCH] Add kern/mach.h and kern/gnumach.h to define rpc prototypes

2023-01-17 Thread Flávio Cruz
On Tue, Jan 17, 2023 at 8:08 PM Samuel Thibault wrote: > Flavio Cruz, le mar. 17 janv. 2023 00:11:49 -0500, a ecrit: > > +kern_return_t > > +register_new_task_notification( > > + const host_t host, > > + ipc_port_t notification); > > Err, but aren't these declared in the generated gnumach

[PATCH] Include mig generated headers to avoid warnings with -Wmissing-prototypes.

2023-01-17 Thread Flavio Cruz
This also reverts 566c227636481b246d928772ebeaacbc7c37145b and 963b1794d7117064cee8ab5638b329db51dad854 --- Makefrag.am | 3 - ddb/db_aout.c| 2 +- ddb/db_ext_symtab.c | 4 +- ddb/db_sym.c | 4 +- ddb/db_sym.h | 6 +- ipc/mach_debug.c

Re: [PATCH 7/7] replace mach_port_t with mach_port_name_t

2023-01-17 Thread Samuel Thibault
Applied, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:57 +0100, a ecrit: > This is a cleanup following the introduction of mach_port_name_t. > The same set of changes is applied to all files: > - rename mach_port_t to mach_port_name_t where a port name is used, > - use MACH_PORT_NAME_NULL and M

Re: [PATCH 6/7] add conversion helpers for invalid mach port names

2023-01-17 Thread Samuel Thibault
Applied, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:56 +0100, a ecrit: > * include/mach/port.h: add _NAME_ variants for port NULL and DEAD and > add helpers to check for invalid port names > * ipc/port.h: add helpers to properly convert to/from invalid mach > port names. > --- > include

Re: [PATCH 5/7] adjust rdxtree key to the correct size

2023-01-17 Thread Samuel Thibault
Applied, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:55 +0100, a ecrit: > * Makefile.am: define RDXTREE_KEY_32 > --- > Makefile.am | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/Makefile.am b/Makefile.am > index fb557ba6..54fcf685 100644 > --- a/Makefile.am > +++ b/Makefile.am >

Re: [PATCH 4/7] update writev syscall signature with rpc types

2023-01-17 Thread Samuel Thibault
Applied, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:54 +0100, a ecrit: > * device/device_emul.h: write/writev: update trap argument types > * device/ds_routines.c: update argument types and adjust copyin > * device/ds_routines.h: write/writev: update trap argument type > * include/device/devi

Re: [PATCH 3/7] update syscall signature with rpc_vm_* and mach_port_name_t

2023-01-17 Thread Samuel Thibault
Applied, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:53 +0100, a ecrit: > * include/mach/mach_types.h: use mach port names > * kern/ipc_mig.c: update vm types and use copyin/copyout helpers > * kern/ipc_mig.h: Likewise > > Signed-off-by: Luca Dariz > --- > include/mach/mach_traps.h | 18 ++

Re: [PATCH 2/7] x86_64: expand and shrink messages in copy{in, out}msg routines

2023-01-17 Thread Samuel Thibault
Applied except a little thing, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:52 +0100, a ecrit: > +static inline int copyin_address(const rpc_vm_offset_t *uaddr, vm_offset_t > *kaddr) > +{ > +#ifdef __x86_64 > + return copyin_32to64(uaddr, kaddr); > +#else /* __x86_64__ */ > + return copyin(u

Re: [PATCH 1/7] add msg_user_header_t for user-side msg structure

2023-01-17 Thread Samuel Thibault
Applied, thanks! Luca Dariz, le lun. 16 janv. 2023 11:58:51 +0100, a ecrit: > * include/mach/message.h: use mach_msg_user_header_t only in KERNEL, > and define it as mach_msh_header_t for user space > * ipc/ipc_kmsg.c: use mach_msg_user_header_t where appropriate > * ipc/ipc_kmsg.h: Likewise > *

Re: [PATCH] Add kern/mach.h and kern/gnumach.h to define rpc prototypes

2023-01-17 Thread Samuel Thibault
Flavio Cruz, le mar. 17 janv. 2023 00:11:49 -0500, a ecrit: > +kern_return_t > +register_new_task_notification( > + const host_t host, > + ipc_port_t notification); Err, but aren't these declared in the generated gnumach.server.h? And similarly for function declarations added in 566c22763

Re: [PATCH] Delete x86 string functions

2023-01-17 Thread Samuel Thibault
Applied, thanks! Flavio Cruz, le mar. 17 janv. 2023 00:11:16 -0500, a ecrit: > The i386 functions are not used and the more portable versions in > kern/strings.c > are faster (1-4x faster in synthetic benchmarks compiled with -O2 on my > x86_64 box). > --- > i386/i386/strings.c | 54 ---

Re: [PATCH] Delete util/putchar.{c,h} and util/puts.c

2023-01-17 Thread Samuel Thibault
Applied, thanks! Flavio Cruz, le mar. 17 janv. 2023 00:09:45 -0500, a ecrit: > Those functions are unused. > --- > Makefrag.am| 3 --- > util/putchar.c | 32 > util/putchar.h | 32 > util/puts.c| 40 ---

Re: [PATCH] Fix some compiler warnings

2023-01-17 Thread Samuel Thibault
Hello, Svante Signell, le mar. 17 janv. 2023 13:15:27 +0100, a ecrit: > --- hurd-git/ext2fs/ext2fs.c 2022-12-08 15:05:29.80800 +0100 > +++ hurd-git/ext2fs/ext2fs.c 2022-12-08 19:11:12.60400 +0100 > @@ -232,7 +232,7 @@ >if (store->size < SBLOCK_OFFS + SBLOCK_SIZE) > ext2_panic ("

Re: [PATCH] Add libraries to Makefiles.

2023-01-17 Thread Samuel Thibault
Hello, Svante Signell, le mar. 17 janv. 2023 13:20:46 +0100, a ecrit: > The attached patch adds libraries needed when cross-building Hurd. Most > of them arise when enabling zlib with --with-libz. But none of these directories are actually using libz, so it doesn't make sense to make them use -lz

[PATCH] Add libraries to Makefiles.

2023-01-17 Thread Svante Signell
Hi, The attached patch adds libraries needed when cross-building Hurd. Most of them arise when enabling zlib with --with-libz. Applies nicely to hurd-0.9.git20221224 and latest git. Thanks! --- hurd/boot/Makefile 2022-11-30 11:14:21.08400 +0100 +++ hurd/boot/Makefile 2022-12-02 15:31:09.736

[PATCH] Fix some compiler warnings

2023-01-17 Thread Svante Signell
Hi, The attached patch fixes some format warnings as well as an implicit declaration of ‘startup_essential_task’ in mach-defpager/main.c. Applies nicely to hurd-0.9.git20221224 and latest git. Thanks! --- hurd-git/ext2fs/ext2fs.c 2022-12-08 15:05:29.80800 +0100 +++ hurd-git/ext2fs/ext2fs.c 2